Bug 347988 - Memcheck: the 'impossible' happened: unexpected size for Addr (OSX/wine)
Summary: Memcheck: the 'impossible' happened: unexpected size for Addr (OSX/wine)
Status: RESOLVED FIXED
Alias: None
Product: valgrind
Classification: Unclassified
Component: general (show other bugs)
Version: 3.10 SVN
Platform: Compiled Sources macOS
: NOR major (vote)
Target Milestone: ---
Assignee: Rhys Kidd
URL:
Keywords:
Depends on:
Blocks: 339017
  Show dependency treegraph
 
Reported: 2015-05-20 07:33 UTC by Austin English
Modified: 2015-07-01 23:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
valgrind output with --gen-suppressions=n (10.84 KB, text/plain)
2015-05-20 18:10 UTC, Austin English
Details
Proposed patch (2.82 KB, patch)
2015-06-12 14:08 UTC, Rhys Kidd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Austin English 2015-05-20 07:33:51 UTC
I regularly run wine's unit tests under valgrind on Fedora/Debian, which generally works well. Trying the same under OSX, however, fails quickly:

../../../tools/runtest -q -P wine -T ../../.. -M advapi32.dll -p advapi32_test.exe.so cred && touch cred.ok
--23644:0:syswrap- WARNING: Ignoring sigreturn( ..., UC_RESET_ALT_STACK );
==23647== Invalid read of size 32
==23647==    at 0x1004D9C1D: _platform_memchr$VARIANT$Haswell (in /usr/lib/system/libsystem_platform.dylib)
==23647==    by 0x1002CDB96: __sfvwrite (in /usr/lib/system/libsystem_c.dylib)
==23647==    by 0x1002D1C9A: puts (in /usr/lib/system/libsystem_c.dylib)
==23647==    by 0x10000DB77: ??? (in /bin/sh)
==23647==    by 0x100021C8F: ??? (in /bin/sh)
==23647==    by 0x1000206F7: ??? (in /bin/sh)
==23647==    by 0x10001D3B9: ??? (in /bin/sh)
==23647==    by 0x10001F9E3: ??? (in /bin/sh)
==23647==    by 0x100011BED: ??? (in /bin/sh)
==23647==    by 0x100040D1A: ??? (in /bin/sh)
==23647==    by 0x10003F5D9: ??? (in /bin/sh)
==23647==    by 0x10003E335: ??? (in /bin/sh)
==23647==    by 0x10003DF95: ??? (in /bin/sh)
==23647==    by 0x10003E259: ??? (in /bin/sh)
==23647==    by 0x10003D9F5: ??? (in /bin/sh)
==23647==    by 0x100041F7C: ??? (in /bin/sh)
==23647==    by 0x10001FD09: ??? (in /bin/sh)
==23647==    by 0x10001D3B9: ??? (in /bin/sh)
==23647==    by 0x10001D003: ??? (in /bin/sh)
==23647==    by 0x100001F2C: ??? (in /bin/sh)
==23647==  Address 0x10091b340 is 32 bytes before a block of size 32 in arena "client"
==23647== 

Memcheck: the 'impossible' happened: unexpected size for Addr

host stacktrace:
==23647==    at 0x23804B429: ???
==23647==    by 0x23804B84C: ???
==23647==    by 0x23804B8EF: ???
==23647==    by 0x23804B91E: ???
==23647==    by 0x23803B7FB: ???
==23647==    by 0x2380454C6: ???
==23647==    by 0x238043404: ???
==23647==    by 0x238042D5B: ???
==23647==    by 0x23803A04A: ???
==23647==    by 0x23802729C: ???
==23647==    by 0x700006C24D22: ???

sched status:
  running_tid=1

Thread 1: status = VgTs_Runnable (lwpid 515)
==23647==    at 0x1004D9C1D: _platform_memchr$VARIANT$Haswell (in /usr/lib/system/libsystem_platform.dylib)
==23647==    by 0x1002CDB96: __sfvwrite (in /usr/lib/system/libsystem_c.dylib)
==23647==    by 0x1002D1C9A: puts (in /usr/lib/system/libsystem_c.dylib)
==23647==    by 0x10000DB77: ??? (in /bin/sh)
==23647==    by 0x100021C8F: ??? (in /bin/sh)
==23647==    by 0x1000206F7: ??? (in /bin/sh)
==23647==    by 0x10001D3B9: ??? (in /bin/sh)
==23647==    by 0x10001F9E3: ??? (in /bin/sh)
==23647==    by 0x100011BED: ??? (in /bin/sh)
==23647==    by 0x100040D1A: ??? (in /bin/sh)
==23647==    by 0x10003F5D9: ??? (in /bin/sh)
==23647==    by 0x10003E335: ??? (in /bin/sh)
==23647==    by 0x10003DF95: ??? (in /bin/sh)
==23647==    by 0x10003E259: ??? (in /bin/sh)
==23647==    by 0x10003D9F5: ??? (in /bin/sh)
==23647==    by 0x100041F7C: ??? (in /bin/sh)
==23647==    by 0x10001FD09: ??? (in /bin/sh)
==23647==    by 0x10001D3B9: ??? (in /bin/sh)
==23647==    by 0x10001D003: ??? (in /bin/sh)
==23647==    by 0x100001F2C: ??? (in /bin/sh)
==23647==    by 0x10023B5C8: start (in /usr/lib/system/libdyld.dylib)
==23647==    by 0x3: ???
==23647==    by 0x10809C842: ???
==23647==    by 0x10809C84A: ???
==23647==    by 0x10809C858: ???
==23647==    by 0x10809C86D: ???


Note: see also the FAQ in the source distribution.
It contains workarounds to several common problems.
In particular, if Valgrind aborted or crashed after
identifying problems in your program, there's a good chance
that fixing those problems will prevent Valgrind aborting or
crashing, especially if it happened in m_mallocfree.c.

If that doesn't help, please report this bug to: www.valgrind.org

In the bug report, send all the above text, the valgrind
version, and what OS and version you are using.  Thanks.

==23648== 231 bytes in 1 blocks are definitely lost in loss record 57 of 81
==23648==    at 0x100008351: malloc (vg_replace_malloc.c:303)
==23648==    by 0x1001E98C8: currentlocale (in /usr/lib/system/libsystem_c.dylib)
==23648==    by 0x100000AC9: ??? (in /usr/bin/uname)
==23648==    by 0x1001605C8: start (in /usr/lib/system/libdyld.dylib)
==23648==    by 0x1: ???
==23648==    by 0x1080027CE: ???
==23648==    by 0x1080027DD: ???
==23648== 
{
   <insert_a_suppression_name_here>
   Memcheck:Leak
   match-leak-kinds: definite
   fun:malloc
   fun:currentlocale
   obj:/usr/bin/uname
   fun:start
   obj:*
   obj:*
   obj:*
}
--23644:0:syswrap- WARNING: Ignoring sigreturn( ..., UC_RESET_ALT_STACK );
--23644:0:syswrap- WARNING: Ignoring sigreturn( ..., UC_RESET_ALT_STACK );
--23644:0:syswrap- WARNING: Ignoring sigreturn( ..., UC_RESET_ALT_STACK );
--23644:0:syswrap- WARNING: Ignoring sigreturn( ..., UC_RESET_ALT_STACK );
--23644:0:syswrap- WARNING: Ignoring sigreturn( ..., UC_RESET_ALT_STACK );
wine: could not find the Wine loader in 
--23644:0:syswrap- WARNING: Ignoring sigreturn( ..., UC_RESET_ALT_STACK );
==23644== 231 bytes in 1 blocks are definitely lost in loss record 327 of 373
==23644==    at 0x1000A2351: malloc (vg_replace_malloc.c:303)
==23644==    by 0x1002C48C8: currentlocale (in /usr/lib/system/libsystem_c.dylib)
==23644==    by 0x100029914: ??? (in /bin/sh)
==23644==    by 0x100000B4B: ??? (in /bin/sh)
==23644==    by 0x10023B5C8: start (in /usr/lib/system/libdyld.dylib)
==23644==    by 0x3: ???
==23644==    by 0x10809C842: ???
==23644==    by 0x10809C84A: ???
==23644==    by 0x10809C858: ???
==23644==    by 0x10809C86D: ???
==23644== 
{
   <insert_a_suppression_name_here>
   Memcheck:Leak
   match-leak-kinds: definite
   fun:malloc
   fun:currentlocale
   obj:/bin/sh
   obj:/bin/sh
   fun:start
   obj:*
   obj:*
   obj:*
   obj:*
   obj:*
}
==23644== 648 (32 direct, 616 indirect) bytes in 1 blocks are definitely lost in loss record 348 of 373
==23644==    at 0x1000A2351: malloc (vg_replace_malloc.c:303)
==23644==    by 0x10004E46F: ??? (in /bin/sh)
==23644==    by 0x10002B22E: ??? (in /bin/sh)
==23644==    by 0x10002CA87: ??? (in /bin/sh)
==23644==    by 0x10001D200: ??? (in /bin/sh)
==23644==    by 0x10001D11A: ??? (in /bin/sh)
==23644==    by 0x10001CF55: ??? (in /bin/sh)
==23644==    by 0x100001F2C: ??? (in /bin/sh)
==23644==    by 0x10023B5C8: start (in /usr/lib/system/libdyld.dylib)
==23644==    by 0x3: ???
==23644==    by 0x10809C842: ???
==23644==    by 0x10809C84A: ???
==23644==    by 0x10809C858: ???
==23644==    by 0x10809C86D: ???
==23644== 
{
   <insert_a_suppression_name_here>
   Memcheck:Leak
   match-leak-kinds: definite
   fun:malloc
   obj:/bin/sh
   obj:/bin/sh
   obj:/bin/sh
   obj:/bin/sh
   obj:/bin/sh
   obj:/bin/sh
   obj:/bin/sh
   fun:start
   obj:*
   obj:*
   obj:*
   obj:*
   obj:*
}
make[1]: *** [cred.ok] Error 1

Using valgrind from svn, r15258

Reproducible: Always

Steps to Reproduce:
See http://wiki.winehq.org/Wine_and_Valgrind for how to build/use wine and valgrind together
Comment 1 Julian Seward 2015-05-20 07:53:15 UTC
Rhys, is this a dup of a known bug?  I feel like I've seen this before somewhere.
Comment 2 Rhys Kidd 2015-05-20 08:20:18 UTC
This does appear to be a duplicate of https://bugs.kde.org/show_bug.cgi?id=345929,
where the user was also running with --gen-suppressions=yes.
Comment 3 Austin English 2015-05-20 18:07:23 UTC
(In reply to Rhys Kidd from comment #2)
> This does appear to be a duplicate of
> https://bugs.kde.org/show_bug.cgi?id=345929,
> where the user was also running with --gen-suppressions=yes.

Maybe, as the stacktrace looks similar, but I don't see the prompt to press y (I was using --gen-suppresssions=yes) and am able to reproduce by using --gen-suppressions=no as well.
Comment 4 Austin English 2015-05-20 18:10:35 UTC
Created attachment 92738 [details]
valgrind output with --gen-suppressions=n
Comment 5 Rhys Kidd 2015-06-12 14:08:45 UTC
Created attachment 93134 [details]
Proposed patch
Comment 6 Rhys Kidd 2015-06-12 14:09:39 UTC
Hi Austin,
Proposed patch attached. Would you mind building a local copy of V with this patch applied, and then try it again with your Wine test suite? Keen to here of the outcome.
Comment 7 Austin English 2015-06-30 21:01:28 UTC
(In reply to Rhys Kidd from comment #6)
> Hi Austin,
> Proposed patch attached. Would you mind building a local copy of V with this
> patch applied, and then try it again with your Wine test suite? Keen to here
> of the outcome.

Hi Rhys,

Sorry for the delay, I was on holiday. With the patch applied, the impossible error goes away, but wine still doesn't work with valgrind:
../../../tools/runtest -q -P wine -T ../../.. -M advapi32.dll -p advapi32_test.exe.so cred && touch cred.ok
--26334:0:syswrap- WARNING: Ignoring sigreturn( ..., UC_RESET_ALT_STACK );
==26337== Invalid read of size 32
==26337==    at 0x1004D9C21: _platform_memchr$VARIANT$Haswell (in /usr/lib/system/libsystem_platform.dylib)
==26337==    by 0x1002CDB96: __sfvwrite (in /usr/lib/system/libsystem_c.dylib)
==26337==    by 0x1002D1C9A: puts (in /usr/lib/system/libsystem_c.dylib)
==26337==    by 0x10000DB77: ??? (in /bin/sh)
==26337==    by 0x100021C8F: ??? (in /bin/sh)
==26337==    by 0x1000206F7: ??? (in /bin/sh)
==26337==    by 0x10001D3B9: ??? (in /bin/sh)
==26337==    by 0x10001F9E3: ??? (in /bin/sh)
==26337==    by 0x100011BED: ??? (in /bin/sh)
==26337==    by 0x100040D1A: ??? (in /bin/sh)
==26337==    by 0x10003F5D9: ??? (in /bin/sh)
==26337==    by 0x10003E335: ??? (in /bin/sh)
==26337==    by 0x10003DF95: ??? (in /bin/sh)
==26337==    by 0x10003E259: ??? (in /bin/sh)
==26337==    by 0x10003D9F5: ??? (in /bin/sh)
==26337==    by 0x100041F7C: ??? (in /bin/sh)
==26337==    by 0x10001FD09: ??? (in /bin/sh)
==26337==    by 0x10001D3B9: ??? (in /bin/sh)
==26337==    by 0x10001D003: ??? (in /bin/sh)
==26337==    by 0x100001F2C: ??? (in /bin/sh)
==26337==  Address 0x10091aaa0 is 4 bytes after a block of size 28 alloc'd
==26337==    at 0x1000A2351: malloc (vg_replace_malloc.c:303)
==26337==    by 0x10004E46F: ??? (in /bin/sh)
==26337==    by 0x10000E8B3: ??? (in /bin/sh)
==26337==    by 0x10000D915: ??? (in /bin/sh)
==26337==    by 0x10000D734: ??? (in /bin/sh)
==26337==    by 0x100021C8F: ??? (in /bin/sh)
==26337==    by 0x1000206F7: ??? (in /bin/sh)
==26337==    by 0x10001D3B9: ??? (in /bin/sh)
==26337==    by 0x10001F955: ??? (in /bin/sh)
==26337==    by 0x100011BED: ??? (in /bin/sh)
==26337==    by 0x100040D1A: ??? (in /bin/sh)
==26337==    by 0x10003F5D9: ??? (in /bin/sh)
==26337==    by 0x10003E335: ??? (in /bin/sh)
==26337==    by 0x10003DF95: ??? (in /bin/sh)
==26337==    by 0x10003E259: ??? (in /bin/sh)
==26337==    by 0x10003D9F5: ??? (in /bin/sh)
==26337==    by 0x100041F7C: ??? (in /bin/sh)
==26337==    by 0x10001FD09: ??? (in /bin/sh)
==26337==    by 0x10001D3B9: ??? (in /bin/sh)
==26337==    by 0x10001D003: ??? (in /bin/sh)
==26337== 
==26337== Conditional jump or move depends on uninitialised value(s)
==26337==    at 0x1004D9C3F: _platform_memchr$VARIANT$Haswell (in /usr/lib/system/libsystem_platform.dylib)
==26337==    by 0x1002CDB96: __sfvwrite (in /usr/lib/system/libsystem_c.dylib)
==26337==    by 0x1002D1C9A: puts (in /usr/lib/system/libsystem_c.dylib)
==26337==    by 0x10000DB77: ??? (in /bin/sh)
==26337==    by 0x100021C8F: ??? (in /bin/sh)
==26337==    by 0x1000206F7: ??? (in /bin/sh)
==26337==    by 0x10001D3B9: ??? (in /bin/sh)
==26337==    by 0x10001F9E3: ??? (in /bin/sh)
==26337==    by 0x100011BED: ??? (in /bin/sh)
==26337==    by 0x100040D1A: ??? (in /bin/sh)
==26337==    by 0x10003F5D9: ??? (in /bin/sh)
==26337==    by 0x10003E335: ??? (in /bin/sh)
==26337==    by 0x10003DF95: ??? (in /bin/sh)
==26337==    by 0x10003E259: ??? (in /bin/sh)
==26337==    by 0x10003D9F5: ??? (in /bin/sh)
==26337==    by 0x100041F7C: ??? (in /bin/sh)
==26337==    by 0x10001FD09: ??? (in /bin/sh)
==26337==    by 0x10001D3B9: ??? (in /bin/sh)
==26337==    by 0x10001D003: ??? (in /bin/sh)
==26337==    by 0x100001F2C: ??? (in /bin/sh)
==26337== 
==26337== 19 bytes in 1 blocks are definitely lost in loss record 126 of 355
==26337==    at 0x1000A2351: malloc (vg_replace_malloc.c:303)
==26337==    by 0x10004E46F: ??? (in /bin/sh)
==26337==    by 0x10004DE42: ??? (in /bin/sh)
==26337==    by 0x10004CBB9: ??? (in /bin/sh)
==26337==    by 0x100029E74: ??? (in /bin/sh)
==26337==    by 0x100029E1C: ??? (in /bin/sh)
==26337==    by 0x10002A006: ??? (in /bin/sh)
==26337==    by 0x100001705: ??? (in /bin/sh)
==26337==    by 0x10023B5C8: start (in /usr/lib/system/libdyld.dylib)
==26337==    by 0x3: ???
==26337==    by 0x10809C8EE: ???
==26337==    by 0x10809C8F6: ???
==26337==    by 0x10809C904: ???
==26337==    by 0x10809C919: ???
==26337== 
==26337== 231 bytes in 1 blocks are definitely lost in loss record 311 of 355
==26337==    at 0x1000A2351: malloc (vg_replace_malloc.c:303)
==26337==    by 0x1002C48C8: currentlocale (in /usr/lib/system/libsystem_c.dylib)
==26337==    by 0x100029914: ??? (in /bin/sh)
==26337==    by 0x100000B4B: ??? (in /bin/sh)
==26337==    by 0x10023B5C8: start (in /usr/lib/system/libdyld.dylib)
==26337==    by 0x3: ???
==26337==    by 0x10809C8EE: ???
==26337==    by 0x10809C8F6: ???
==26337==    by 0x10809C904: ???
==26337==    by 0x10809C919: ???
==26337== 
==26338== 231 bytes in 1 blocks are definitely lost in loss record 57 of 81
==26338==    at 0x100008351: malloc (vg_replace_malloc.c:303)
==26338==    by 0x1001E98C8: currentlocale (in /usr/lib/system/libsystem_c.dylib)
==26338==    by 0x100000AC9: ??? (in /usr/bin/uname)
==26338==    by 0x1001605C8: start (in /usr/lib/system/libdyld.dylib)
==26338==    by 0x1: ???
==26338==    by 0x10800287A: ???
==26338==    by 0x108002889: ???
==26338== 
--26334:0:syswrap- WARNING: Ignoring sigreturn( ..., UC_RESET_ALT_STACK );
--26334:0:syswrap- WARNING: Ignoring sigreturn( ..., UC_RESET_ALT_STACK );
--26334:0:syswrap- WARNING: Ignoring sigreturn( ..., UC_RESET_ALT_STACK );
--26334:0:syswrap- WARNING: Ignoring sigreturn( ..., UC_RESET_ALT_STACK );
==26334== Invalid read of size 32
==26334==    at 0x1004D9C21: _platform_memchr$VARIANT$Haswell (in /usr/lib/system/libsystem_platform.dylib)
==26334==    by 0x1002CDB96: __sfvwrite (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002D7FE5: __vfprintf (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002FD9AE: __v2printf (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002FDC80: __xvprintf (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002D3B71: vfprintf_l (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002CC5FF: fprintf (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x10001C8AA: ??? (in /bin/sh)
==26334==    by 0x100021491: ??? (in /bin/sh)
==26334==    by 0x100011F4C: ??? (in /bin/sh)
==26334==    by 0x100021C8F: ??? (in /bin/sh)
==26334==    by 0x1000206F7: ??? (in /bin/sh)
==26334==    by 0x10001D3B9: ??? (in /bin/sh)
==26334==    by 0x10001D003: ??? (in /bin/sh)
==26334==    by 0x100001F2C: ??? (in /bin/sh)
==26334==    by 0x10023B5C8: start (in /usr/lib/system/libdyld.dylib)
==26334==    by 0x3: ???
==26334==    by 0x10809C8EE: ???
==26334==    by 0x10809C8F6: ???
==26334==    by 0x10809C904: ???
==26334==  Address 0x10090b220 is 2 bytes after a block of size 14 alloc'd
==26334==    at 0x1000A2351: malloc (vg_replace_malloc.c:303)
==26334==    by 0x10004E46F: ??? (in /bin/sh)
==26334==    by 0x100004435: ??? (in /bin/sh)
==26334==    by 0x1000047C0: ??? (in /bin/sh)
==26334==    by 0x100001F52: ??? (in /bin/sh)
==26334==    by 0x10023B5C8: start (in /usr/lib/system/libdyld.dylib)
==26334==    by 0x3: ???
==26334==    by 0x10809C8EE: ???
==26334==    by 0x10809C8F6: ???
==26334==    by 0x10809C904: ???
==26334==    by 0x10809C919: ???
==26334== 
==26334== Conditional jump or move depends on uninitialised value(s)
==26334==    at 0x1004D9C3F: _platform_memchr$VARIANT$Haswell (in /usr/lib/system/libsystem_platform.dylib)
==26334==    by 0x1002CDB96: __sfvwrite (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002D7FE5: __vfprintf (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002FD9AE: __v2printf (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002FDC80: __xvprintf (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002D3B71: vfprintf_l (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002CC5FF: fprintf (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x10001C8AA: ??? (in /bin/sh)
==26334==    by 0x100021491: ??? (in /bin/sh)
==26334==    by 0x100011F4C: ??? (in /bin/sh)
==26334==    by 0x100021C8F: ??? (in /bin/sh)
==26334==    by 0x1000206F7: ??? (in /bin/sh)
==26334==    by 0x10001D3B9: ??? (in /bin/sh)
==26334==    by 0x10001D003: ??? (in /bin/sh)
==26334==    by 0x100001F2C: ??? (in /bin/sh)
==26334==    by 0x10023B5C8: start (in /usr/lib/system/libdyld.dylib)
==26334==    by 0x3: ???
==26334==    by 0x10809C8EE: ???
==26334==    by 0x10809C8F6: ???
==26334==    by 0x10809C904: ???
==26334== 
../../../wine: line 107: /Users/austin/wine-valgrind/loader/wine: cannot execute binary file
==26334== Invalid read of size 32
==26334==    at 0x1004D9C1D: _platform_memchr$VARIANT$Haswell (in /usr/lib/system/libsystem_platform.dylib)
==26334==    by 0x1002CDB96: __sfvwrite (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002D7FE5: __vfprintf (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002FD9AE: __v2printf (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002FDC80: __xvprintf (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x1002D3BD1: vfprintf (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x10001C577: ??? (in /bin/sh)
==26334==    by 0x100011F6F: ??? (in /bin/sh)
==26334==    by 0x100021C8F: ??? (in /bin/sh)
==26334==    by 0x1000206F7: ??? (in /bin/sh)
==26334==    by 0x10001D3B9: ??? (in /bin/sh)
==26334==    by 0x10001D003: ??? (in /bin/sh)
==26334==    by 0x100001F2C: ??? (in /bin/sh)
==26334==    by 0x10023B5C8: start (in /usr/lib/system/libdyld.dylib)
==26334==    by 0x3: ???
==26334==    by 0x10809C8EE: ???
==26334==    by 0x10809C8F6: ???
==26334==    by 0x10809C904: ???
==26334==    by 0x10809C919: ???
==26334==  Address 0x100928cc0 is 16 bytes after a block of size 16 in arena "client"
==26334== 
../../../wine: line 107: /Users/austin/wine-valgrind/loader/wine: Undefined error: 0
==26334== 98 (32 direct, 66 indirect) bytes in 1 blocks are definitely lost in loss record 296 of 358
==26334==    at 0x1000A2351: malloc (vg_replace_malloc.c:303)
==26334==    by 0x10004E46F: ??? (in /bin/sh)
==26334==    by 0x10006D567: ??? (in /bin/sh)
==26334==    by 0x100011E31: ??? (in /bin/sh)
==26334==    by 0x100021C8F: ??? (in /bin/sh)
==26334==    by 0x1000206F7: ??? (in /bin/sh)
==26334==    by 0x10001D3B9: ??? (in /bin/sh)
==26334==    by 0x10001D003: ??? (in /bin/sh)
==26334==    by 0x100001F2C: ??? (in /bin/sh)
==26334==    by 0x10023B5C8: start (in /usr/lib/system/libdyld.dylib)
==26334==    by 0x3: ???
==26334==    by 0x10809C8EE: ???
==26334==    by 0x10809C8F6: ???
==26334==    by 0x10809C904: ???
==26334==    by 0x10809C919: ???
==26334== 
==26334== 231 bytes in 1 blocks are definitely lost in loss record 313 of 358
==26334==    at 0x1000A2351: malloc (vg_replace_malloc.c:303)
==26334==    by 0x1002C48C8: currentlocale (in /usr/lib/system/libsystem_c.dylib)
==26334==    by 0x100029914: ??? (in /bin/sh)
==26334==    by 0x100000B4B: ??? (in /bin/sh)
==26334==    by 0x10023B5C8: start (in /usr/lib/system/libdyld.dylib)
==26334==    by 0x3: ???
==26334==    by 0x10809C8EE: ???
==26334==    by 0x10809C8F6: ???
==26334==    by 0x10809C904: ???
==26334==    by 0x10809C919: ???
==26334== 
make[1]: *** [cred.ok] Error 1
Comment 8 Austin English 2015-06-30 21:02:10 UTC
Patch was applied on top of:
Austins-Mac-mini:valgrind austin$ svn info
Path: .
Working Copy Root Path: /Users/austin/src/valgrind
URL: svn://svn.valgrind.org/valgrind/trunk
Repository Root: svn://svn.valgrind.org/valgrind
Repository UUID: a5019735-40e9-0310-863c-91ae7b9d1cf9
Revision: 15387
Node Kind: directory
Schedule: normal
Last Changed Author: bart
Last Changed Rev: 15387
Last Changed Date: 2015-06-28 12:06:14 -0500 (Sun, 28 Jun 2015)
Comment 9 Rhys Kidd 2015-07-01 23:06:23 UTC
Resolved in 15391.
Austin, do you mind opening a new bug report for that subsequent error? I am also going to make bz#339017 a meta bug for all these Wine reported issues.
Comment 10 Austin English 2015-07-01 23:54:57 UTC
(In reply to Rhys Kidd from comment #9)
> Resolved in 15391.
> Austin, do you mind opening a new bug report for that subsequent error? I am
> also going to make bz#339017 a meta bug for all these Wine reported issues.

Sure, bug 349804.