Bug 347648 - KCalc no longer reacts to inputs from keyboard numpad
Summary: KCalc no longer reacts to inputs from keyboard numpad
Status: RESOLVED DUPLICATE of bug 344638
Alias: None
Product: kcalc
Classification: Unclassified
Component: general (show other bugs)
Version: 2.13
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Evan Teran
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-13 06:01 UTC by h.k.ghost
Modified: 2015-05-13 10:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description h.k.ghost 2015-05-13 06:01:18 UTC
When using KCalc, using the numpad (right side of arrow keys) has no effect. The inputs must be either entered by using the mouse or by using the row of number on top of the QWERTY side of the keyboard.

The state of numlock was confirmed to be on/set.

Reproducible: Always

Steps to Reproduce:
1. Open instance of KCalc
2. Try to use the numpad keys to perform normal operations
3.

Actual Results:  
Nothing happens

Expected Results:  
Digits and arithmetic operations would be entered and KCalc's user interface displays the current state (e.g. pressing 7, 8, 9 on the numpad would show the number 789 on KCalc's display).

I tried this in all modes (e.g. simple, scientific, statistical, etc).
Comment 1 revilo77 2015-05-13 09:14:45 UTC
I can reproduce this bug on Archlinux:
KDE Apps 15.04.1
Qt 5.4.1
KDE Frameworks 5.10
Comment 2 Christoph Feck 2015-05-13 10:28:57 UTC

*** This bug has been marked as a duplicate of bug 344638 ***