Bug 347609 - KCalc does not recognize Numpad . (period)
Summary: KCalc does not recognize Numpad . (period)
Status: RESOLVED DUPLICATE of bug 344638
Alias: None
Product: kcalc
Classification: Unclassified
Component: general (show other bugs)
Version: 2.13
Platform: Other Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: Evan Teran
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-12 13:21 UTC by Jonathan Joseph Chiarella
Modified: 2015-05-12 13:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Joseph Chiarella 2015-05-12 13:21:49 UTC
KCalc does not recognize Numpad . (period)

with numpad on, or with numpad off and shift held down, the . does not have any effect in KCalc. (This is the key that is numpad-delete when numlock is off and numpad period/full-stop when numlock is on)

The key works in every other program. Kcalc 2.13 Kframeworks 5.6 plasma 5.2 manjaro stable open-rc/eudev/consolekit on x86-64 hardware running x86-32. BIOS-only hardware. usb keypad hooked up. N-key rollover is 6 on the numpad. good hardware. it is separate from the mini keyboard.

Reproducible: Always

Steps to Reproduce:
1. Load KCalc
2. Turn on numlock or hold shift key
3. press the numpad del/period(full stop) key

Actual Results:  
nothing happens. If  enter a value of 1.12 it comes out as 112

Expected Results:  
a period (full stop) should get entered.
Comment 1 Christoph Feck 2015-05-12 13:40:35 UTC

*** This bug has been marked as a duplicate of bug 344638 ***