Bug 347536 - UTM needs lon *and* lat to obtain its correct values. ToString functions only receive one of them.
Summary: UTM needs lon *and* lat to obtain its correct values. ToString functions only...
Status: RESOLVED UNMAINTAINED
Alias: None
Product: marble
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Alejandro García Montoro
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-10 23:57 UTC by Alejandro García Montoro
Modified: 2021-03-10 10:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of one of the consequences the bug produces. (174.66 KB, image/png)
2015-05-10 23:59 UTC, Alejandro García Montoro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro García Montoro 2015-05-10 23:57:48 UTC
Public static functions lonToString() and latToString() from GeoDataCoordinates.cpp receive only longitude or latitude values, respectively.
UTM functions need both values to obtain any of its components: zone, latitude band, easting or northing.
Hence, a refactoring is needed in order to cope with the different coordinate systems used.

Reproducible: Always

Steps to Reproduce:
This can be done in any non-standard zones and with any module/plugin that uses lonToString or latTostring. The problem showed now is just an example (in Bergen and making use of the MarbleWidgetPopupMenu):

1. Add a bookmark in Bergen, southwest Norway (or in any other non-standard zone).
2. Click on the created bookmark.

Actual Results:  
The zone displayed is 31

Expected Results:  
The zone displayed should be 32
Comment 1 Alejandro García Montoro 2015-05-10 23:59:50 UTC
Created attachment 92531 [details]
Screenshot of one of the consequences the bug produces.
Comment 2 Justin Zobel 2021-03-09 22:51:30 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.
Comment 3 Alejandro García Montoro 2021-03-10 10:36:21 UTC
Thank you for reaching out, Justin. I have not contributed to Marble, nor used it, since then, so I don't really know if this issue still persists. I'm changing the status to resolved, a new one can be opened if needed.