Bug 347480 - KDE Frameworks 5 Kwin crashed after installing a theme downloaded
Summary: KDE Frameworks 5 Kwin crashed after installing a theme downloaded
Status: RESOLVED DUPLICATE of bug 345660
Alias: None
Product: kwin
Classification: Plasma
Component: decorations (show other bugs)
Version: 5.3.0
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: 5
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-09 17:37 UTC by Shawn Starr
Modified: 2015-05-09 18:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shawn Starr 2015-05-09 17:37:33 UTC
Application: systemsettings5 (5.3.0)

Qt Version: 5.4.1
Operating System: Linux 4.1.0-0.rc2.git3.2.fc23.x86_64 x86_64
Distribution: "Fedora release 22 (Twenty Two)"

-- Information about the crash:
I installed some themes from GetHotNewStuff for Kwin decorations and then it crashed, now kwin won't let me remove the broken theme.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1e1e65a840 (LWP 22702))]

Thread 4 (Thread 0x7f1e169f5700 (LWP 22703)):
#0  0x000000388d2f666d in poll () at /lib64/libc.so.6
#1  0x000000389060a182 in _xcb_conn_wait () at /lib64/libxcb.so.1
#2  0x000000389060bcff in xcb_wait_for_event () at /lib64/libxcb.so.1
#3  0x00007f1e17d135e9 in QXcbEventReader::run() () at /usr/lib64/qt5/plugins/platforms/libqxcb.so
#4  0x00000038a16a045e in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#5  0x000000388ce07555 in start_thread () at /lib64/libpthread.so.0
#6  0x000000388d301f3d in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7f1e095b6700 (LWP 22705)):
#0  0x000000388d2f666d in poll () at /lib64/libc.so.6
#1  0x000000388fa4a3ec in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#2  0x000000388fa4a4fc in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#3  0x00000038a18cf4eb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#4  0x00000038a187627a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#5  0x00000038a169b494 in QThread::exec() () at /lib64/libQt5Core.so.5
#6  0x00000038b48c3935 in QQmlThreadPrivate::run() () at /lib64/libQt5Qml.so.5
#7  0x00000038a16a045e in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#8  0x000000388ce07555 in start_thread () at /lib64/libpthread.so.0
#9  0x000000388d301f3d in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7f1e0274f700 (LWP 22706)):
#0  0x000000388d2f666d in poll () at /lib64/libc.so.6
#1  0x000000388fa4a3ec in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#2  0x000000388fa4a4fc in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#3  0x00000038a18cf4eb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#4  0x00000038a187627a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#5  0x00000038a169b494 in QThread::exec() () at /lib64/libQt5Core.so.5
#6  0x00000038b48c3935 in QQmlThreadPrivate::run() () at /lib64/libQt5Qml.so.5
#7  0x00000038a16a045e in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#8  0x000000388ce07555 in start_thread () at /lib64/libpthread.so.0
#9  0x000000388d301f3d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f1e1e65a840 (LWP 22702)):
[KCrash Handler]
#5  0x0000006500000065 in  ()
#6  0x00000038a913e375 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () at /lib64/libQt5Quick.so.5
#7  0x00000038a913da3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () at /lib64/libQt5Quick.so.5
#8  0x00007f1e03752302 in Plasma::FrameSvgItem::updatePaintNode(QSGNode*, QQuickItem::UpdatePaintNodeData*) () at /usr/lib64/qt5/qml/org/kde/plasma/core/libcorebindingsplugin.so
#9  0x00000038a918f5e7 in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () at /lib64/libQt5Quick.so.5
#10 0x00000038a919008b in QQuickWindowPrivate::updateDirtyNodes() () at /lib64/libQt5Quick.so.5
#11 0x00000038a91906fe in QQuickWindowPrivate::syncSceneGraph() () at /lib64/libQt5Quick.so.5
#12 0x00000038a9161350 in QSGGuiThreadRenderLoop::renderWindow(QQuickWindow*) () at /lib64/libQt5Quick.so.5
#13 0x00000038a9161de1 in QSGGuiThreadRenderLoop::event(QEvent*) () at /lib64/libQt5Quick.so.5
#14 0x00000038a4351dec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#15 0x00000038a4357370 in QApplication::notify(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#16 0x00000038a18787fb in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /lib64/libQt5Core.so.5
#17 0x00000038a18ce2ed in QTimerInfoList::activateTimers() () at /lib64/libQt5Core.so.5
#18 0x00000038a18ce7f1 in timerSourceDispatch(_GSource*, int (*)(void*), void*) () at /lib64/libQt5Core.so.5
#19 0x000000388fa4a0ba in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#20 0x000000388fa4a450 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#21 0x000000388fa4a4fc in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#22 0x00000038a18cf4cf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#23 0x00000038a187627a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#24 0x00000038a187dcdc in QCoreApplication::exec() () at /lib64/libQt5Core.so.5
#25 0x000000000040eb2c in main ()

Reported using DrKonqi
Comment 1 Shawn Starr 2015-05-09 17:44:40 UTC
The theme 'win7-bright' caused crash
Comment 2 Thomas Lübking 2015-05-09 18:24:28 UTC

*** This bug has been marked as a duplicate of bug 345660 ***