Bug 347324 - Adding network monitor widget makes plasmashell hog CPU
Summary: Adding network monitor widget makes plasmashell hog CPU
Status: RESOLVED DUPLICATE of bug 345696
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.3.0
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-06 16:13 UTC by Lastique
Modified: 2015-05-07 22:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lastique 2015-05-06 16:13:18 UTC
Adding a "Network Monitor" widget to a panel results in a constant high CPU usage by the plasmashell process.

Reproducible: Always

Steps to Reproduce:
1. Add a "Network Monitor" widget to a panel. In my case I have two panels and two network interfaces (ethernet and wi-fi).
2. Open System Monitor and look at the plasmashell process CPU consumption.


Actual Results:  
plasmashell constantly hogs ~75% CPU core.

Expected Results:  
The process should not consume that much CPU.

I'm using Kubuntu 15.04 x86_64, KDE packages installed from ppa:kubuntu-ppa/backports. There are two panels: one with the task manager, the other is with the app launcher, a few application icons, spacer, System Load Viewer and the system tray. No other widgets on the desktop.
Comment 1 David Edmundson 2015-05-07 22:00:58 UTC

*** This bug has been marked as a duplicate of bug 345696 ***