Bug 347194 - Export to Facebook fails with "Facebook Call Failed"
Summary: Export to Facebook fails with "Facebook Call Failed"
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Plugin-WebService-Facebook (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR major with 138 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 298135 347452 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-04 22:39 UTC by pbhj
Modified: 2018-01-30 21:31 UTC (History)
19 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.12.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pbhj 2015-05-04 22:39:08 UTC
When attempting to export, even using the fix of inputting the correct URI from the browsers history list, the Export to Facebook kipi plugin responds with "Facebook Call Failed: User must specify a valid extended permission or data permission (100)" and the plugin will not allow one to continue with the upload (presumably it can't get authenicated and so actually can't continue).

Reproducible: Always

Steps to Reproduce:
1. Open digikam
2. Select an image
3. Alt+Shift+F (or Export>Export to Facebook)
4. Copy previous URI from browser history to give kipi Facebook plugin the correct token for account access.


Actual Results:  
5. "Facebook Call Failed: User must specify a valid extended permission or data permission (100)" prevents further use of plugin.

Expected Results:  
Plugin allows upload of pics as normal.

I'm using this repos https://launchpad.net/~philip5/+archive/ubuntu/extra.

http://superuser.com/questions/908756/digikam-facebook-upload-fails-upon-change-account-user-must-specify-a-valid-ex#comment1223135_908756 relates to this bug.
Comment 1 esby 2015-05-08 22:43:12 UTC
Confirming the issue.

Using kipi-plugin 4.4.0 
under gwenview 4.14.0 pre 
under Debian testing / unstabled - Linux (x86_64) release 3.16.0-4-amd64

Seems something changed (again) on facebook end....
Comment 2 Michael 2015-05-10 14:39:19 UTC
I have the same issue since one or two weeks.
I'm using digiKam 3.5.0 with Ubuntu 14.04 from the official Ubuntu repository
Comment 3 tps 2015-05-16 11:02:42 UTC
*** Bug 347452 has been marked as a duplicate of this bug. ***
Comment 4 tps 2015-05-16 11:09:44 UTC
Same for digikam 1.0~digikam4.10.0-trusty~ppa3kde41, kipiplugins 4:4.10.0-trusty~ppa3kde414 (but doesn't work on fedora or windows either).
Comment 5 tps 2015-05-16 11:11:14 UTC
Marked as duplicate #347452
Comment 6 caulier.gilles 2015-05-19 11:15:21 UTC
*** Bug 298135 has been marked as a duplicate of this bug. ***
Comment 7 Vincent Tassy 2015-05-19 14:16:09 UTC
Same behaviour here with digikam 4.9.0 and kipi-plugins-4.9.0 on Fedora 21
Comment 8 Kevin Wilson 2015-05-20 18:59:41 UTC
Same behavior on Gentoo with gwenview-4.14.3 and kipi-plugins-4.{9,10}.0
Comment 9 Cormul 2015-06-03 16:17:38 UTC
Same behaviour with kipi-plugin 4.9.0 and digikam 4.9.0 on archlinux with a non-kde desktop environment. The error is the same either trying to export or to import.
Comment 10 Norbert 2015-06-04 20:05:25 UTC
Same with kipi-plugins-4.4.0 and digikam-4.4.0 on Gentoo
Comment 11 pjansen_38555 2015-06-06 19:02:27 UTC
I just tried using this today with digikam-4.9.0 and kipi-plugins-4.9.0.  What I noticed was when initially setting up the app on facebook, the box comes up which says the permissions the app has.  The only permission the app is asking for (or at least is being given by facebook) is to read the user's profile.  The app is not getting permission to post.
Comment 12 Laurence Perkins 2015-06-07 21:25:25 UTC
Looks like import fails with the same error.  And removing and readding the app results in it not getting download or post permissions.

Could this be like the references I found to the last time the app stopped working where Facebook decided it wasn't secure enough and disabled it?  Who maintains the Facebook app and how do we get their attention?  It's been a month since it stopped working...
Comment 13 Marius Orcsik 2015-06-08 08:09:02 UTC
As far as I know Facebook reimplemented the permissions side of their API and all applications need to submit a request for them.

After the request is granted it might work again.
Comment 14 Hernan 2015-06-09 20:22:43 UTC
*** This bug has been confirmed by popular vote. ***
Comment 15 tps 2015-07-03 09:49:24 UTC
Same for 4.11.0: "User must specify a valid extended permission or data permission (100)"
Comment 16 Laurence Perkins 2015-07-08 06:39:08 UTC
Removing and re-adding the Facebook app doesn't seem to make it get the right permissions either.  It does request some, but not permission to upload pictures.  I'm guessing something needs updating on the app side of things, but that's just a guess, I don't actually know all that much about the Facebook framework.
Comment 17 Sergei S. Rublёv 2015-07-14 13:13:25 UTC
Yes, I have suffered from this too. I also can't upload anymore to Wikimedia Commons via Commons KIPI plugin. Versions are all-newest on Fedora.
Comment 18 Shourya Singh Gupta 2015-07-21 10:38:08 UTC
Git commit 946a4ed104c954f532efc27061a740b9904e317d by Shourya Singh Gupta.
Committed on 21/07/2015 at 10:37.
Pushed by shouryasinghgupta into branch 'master'.

Facebook up and running now
Related: bug 319252, bug 240254, bug 289256
FIXED-IN: 4.12.0

A  +638  -0    0001-Testing-Youtube-integration.patch
M  +4    -1    facebook/fbwindow.cpp

http://commits.kde.org/kipi-plugins/946a4ed104c954f532efc27061a740b9904e317d
Comment 19 Shourya Singh Gupta 2015-07-21 10:43:07 UTC
Unwanted file 0001-Testing-Youtube-integration.patch that got added in this commit was removed in the next commit.
Comment 20 lucioarjona 2015-08-16 16:40:15 UTC
I am having that same problem under version 4.14.2 (Mint 17.2). Might want to consider reopening this bug.
Comment 21 Shourya Singh Gupta 2015-08-17 03:29:06 UTC
(In reply to lucioarjona from comment #20)
> I am having that same problem under version 4.14.2 (Mint 17.2). Might want
> to consider reopening this bug.

Gilles,

Is this problem reproducible for you too ?

Shourya
Comment 22 caulier.gilles 2015-08-17 09:25:07 UTC
I just tested. The Facebook pages displayed by Browser hide the link to copy and paste to the tool, when assistant is completed. I need to go back one time with browser history to copy and paste right url.

After that, all work fine.

PS : Facebook for me look really weird time to time step by step. It's puzzle network, not a social network. I never use it since a while. G+ is so far better in all of points.

Gilles