Bug 347148 - Network Monitor widget causes high CPU load
Summary: Network Monitor widget causes high CPU load
Status: RESOLVED DUPLICATE of bug 345696
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.3.0
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-04 10:36 UTC by Kien Truong
Modified: 2015-10-12 12:11 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kien Truong 2015-05-04 10:36:51 UTC
Adding a Network Monitor widget to the desktop makes plasmashell CPU's usage steadily increase and it shortly reaches 100 %.

Reproducible: Always

Steps to Reproduce:
1. Add a Network Monitor widget to the desktop
2. Do something that include network usage, like web browsing, etc...
3. Monitor the CPU usage

Actual Results:  
CPU usage of plasmashell steadily increases to 100%

Expected Results:  
Plasmashell CPU usage remains low, or at least stay at constant level.
Comment 1 David Edmundson 2015-05-04 15:43:28 UTC

*** This bug has been marked as a duplicate of bug 345696 ***
Comment 2 ben van 't ende 2015-10-12 12:11:31 UTC
Just to confirm thay I had the same problem with Plasma Shell hitting 138%. Removing the widget solved the highload.