Bug 346883 - KInfoCentre crashed
Summary: KInfoCentre crashed
Status: RESOLVED DUPLICATE of bug 344971
Alias: None
Product: kinfocenter
Classification: Applications
Component: general (show other bugs)
Version: 5.2.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Hubner
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-29 02:55 UTC by kajalsinha
Modified: 2015-05-02 22:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (9.63 KB, text/plain)
2015-04-29 02:57 UTC, kajalsinha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kajalsinha 2015-04-29 02:55:18 UTC
Application: kinfocenter (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:

I clicked a few of the nodes in KInfoCentre. Checked processor information then moved on to see the graphical information. The KInfoCentre crashed right then. I am using KUbuntu distro 15.04 on Thinkpad Carbon X1 gen 3. 

One more thing: I really like this new KDE Plasma  5.2, You guys are awesome!!!

Regards
Kajal

-- Backtrace:
Application: KDE Info Center (kinfocenter), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x00007ff02e2e6af0 in _xend () at ../sysdeps/unix/sysv/linux/x86/elision-unlock.c:33
#7  __lll_unlock_elision (lock=0x1790450, private=0) at ../sysdeps/unix/sysv/linux/x86/elision-unlock.c:29
#8  0x00007ff02b47f7e5 in _XError (dpy=dpy@entry=0xf062b0, rep=rep@entry=0x7fff910c2770) at ../../src/XlibInt.c:1461
#9  0x00007ff0299bcd67 in __glXGenerateError (resource=0, errorCode=0 '\000', minorCode=26, dpy=0xf062b0) at ../../../../src/glx/glxcurrent.c:195
#10 MakeContextCurrent (dpy=0xf062b0, draw=104857605, read=104857605, gc_user=0x1c075e0) at ../../../../src/glx/glxcurrent.c:246
#11 0x00007ff0129fad5c in get_gl_info_glx (dpy=dpy@entry=0xf062b0, allowDirect=allowDirect@entry=0, l1=l1@entry=0xfef000, after=after@entry=0x100a4e0, scrnum=0) at ../../../Modules/opengl/opengl.cpp:708
#12 0x00007ff0129fc5c8 in GetInfo_OpenGL (treeWidget=0x10cfdb0) at ../../../Modules/opengl/opengl.cpp:937
#13 0x00007ff0129fcf31 in KCMOpenGL::KCMOpenGL (this=this@entry=0xf3dd10, parent=parent@entry=0xeca250) at ../../../Modules/opengl/opengl.cpp:80
#14 0x00007ff0129fe04b in KPluginFactory::createInstance<KCMOpenGL, QWidget> (parentWidget=<optimized out>, parent=<optimized out>, args=...) at /usr/include/KF5/KCoreAddons/kpluginfactory.h:477
#15 0x00007ff031ba9608 in KPluginFactory::create (this=this@entry=0x10684c0, iface=0x7ff031e32e68 "KCModule", parentWidget=parentWidget@entry=0x0, parent=parent@entry=0xeca250, args=..., keyword=...) at ../../../src/lib/plugin/kpluginfactory.cpp:145
#16 0x00007ff0314ff828 in create<KCModule> (args=..., keyword=..., parent=0xeca250, parentWidget=0x0, this=0x10684c0) at /usr/include/KF5/KCoreAddons/kpluginfactory.h:519
#17 createInstance<KCModule> (error=0x7fff910c2d80, args=..., parent=0xeca250, parentWidget=0x0, this=0xe96a70) at /usr/include/KF5/KService/kservice.h:526
#18 createInstance<KCModule> (error=0x7fff910c2d80, args=..., parent=0xeca250, this=0xe96a70) at /usr/include/KF5/KService/kservice.h:501
#19 KCModuleLoader::loadModule (mod=..., report=report@entry=KCModuleLoader::Inline, parent=0xeca250, args=...) at ../../src/kcmoduleloader.cpp:92
#20 0x00007ff03150638f in KCModuleProxyPrivate::loadModule (this=this@entry=0x1794db0) at ../../src/kcmoduleproxy.cpp:109
#21 0x00007ff031506f85 in KCModuleProxy::realModule (this=this@entry=0xeca250) at ../../src/kcmoduleproxy.cpp:82
#22 0x00007ff031507404 in KCModuleProxy::quickHelp (this=0xeca250) at ../../src/kcmoduleproxy.cpp:287
#23 0x000000000041679b in KcmContainer::setKcm (this=0xe967e0, info=...) at ../kcmcontainer.cpp:86
#24 0x00000000004141ce in KInfoCenter::setKcm (this=0xd74b40, kcmItem=<optimized out>) at ../infocenter.cpp:211
#25 0x0000000000414280 in KInfoCenter::itemClickedSlot (this=<optimized out>, item=<optimized out>) at ../infocenter.cpp:205
#26 0x000000000041a08c in KInfoCenter::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at moc_infocenter.cpp:88
#27 0x00007ff02f9c49c9 in QMetaObject::activate (sender=0xe30aa0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff910c3260) at kernel/qobject.cpp:3716
#28 0x00007ff02f9c5057 in QMetaObject::activate (sender=<optimized out>, m=m@entry=0x61fba0 <SidePanel::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff910c3260) at kernel/qobject.cpp:3582
#29 0x0000000000419e5f in SidePanel::clicked (this=<optimized out>, _t1=0xea8ee0, _t1@entry=0x7fff910c3258) at moc_sidepanel.cpp:152
#30 0x0000000000415bb1 in SidePanel::clickedSlot (this=<optimized out>, index=...) at ../sidepanel.cpp:66
#31 0x0000000000419f79 in SidePanel::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at moc_sidepanel.cpp:93
#32 0x00007ff02f9c49c9 in QMetaObject::activate (sender=sender@entry=0xe30aa0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fff910c33d0) at kernel/qobject.cpp:3716
#33 0x00007ff02f9c5057 in QMetaObject::activate (sender=sender@entry=0xe30aa0, m=m@entry=0x7ff0307cc8e0 <QAbstractItemView::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fff910c33d0) at kernel/qobject.cpp:3582
#34 0x00007ff0304fdbb5 in QAbstractItemView::clicked (this=this@entry=0xe30aa0, _t1=...) at .moc/moc_qabstractitemview.cpp:590
#35 0x00007ff030506813 in QAbstractItemView::mouseReleaseEvent (this=this@entry=0xe30aa0, event=event@entry=0x7fff910c3c20) at itemviews/qabstractitemview.cpp:1860
#36 0x00007ff03054e0db in QTreeView::mouseReleaseEvent (this=0xe30aa0, event=0x7fff910c3c20) at itemviews/qtreeview.cpp:1914
#37 0x00007ff0302e11e8 in QWidget::event (this=this@entry=0xe30aa0, event=event@entry=0x7fff910c3c20) at kernel/qwidget.cpp:9022
#38 0x00007ff0303df93e in QFrame::event (this=0xe30aa0, e=0x7fff910c3c20) at widgets/qframe.cpp:526
#39 0x00007ff03050cd5b in QAbstractItemView::viewportEvent (this=this@entry=0xe30aa0, event=event@entry=0x7fff910c3c20) at itemviews/qabstractitemview.cpp:1689
#40 0x00007ff03054d6e0 in QTreeView::viewportEvent (this=0xe30aa0, event=0x7fff910c3c20) at itemviews/qtreeview.cpp:1306
#41 0x00007ff02f993a14 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=this@entry=0xd1c5d0, receiver=receiver@entry=0xe448b0, event=event@entry=0x7fff910c3c20) at kernel/qcoreapplication.cpp:1031
#42 0x00007ff03029db0c in QApplicationPrivate::notify_helper (this=0xd1c5d0, receiver=0xe448b0, e=0x7fff910c3c20) at kernel/qapplication.cpp:3716
#43 0x00007ff0302a38eb in QApplication::notify (this=0x7fff910c3960, receiver=0x7fff910c3980, e=0x7fff910c3c20) at kernel/qapplication.cpp:3280
#44 0x00007ff02f993c2b in QCoreApplication::notifyInternal (this=0x7fff910c44e0, receiver=receiver@entry=0xe448b0, event=event@entry=0x7fff910c3c20) at kernel/qcoreapplication.cpp:935
#45 0x00007ff0302a23da in sendSpontaneousEvent (event=0x7fff910c3c20, receiver=0xe448b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#46 QApplicationPrivate::sendMouseEvent (receiver=0xe448b0, event=0x7fff910c3c20, alienWidget=0xe448b0, nativeWidget=0xd74b40, buttonDown=<optimized out>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:2751
#47 0x00007ff0302f9cc0 in QWidgetWindow::handleMouseEvent (this=0xf84f60, event=0x7fff910c4030) at kernel/qwidgetwindow.cpp:543
#48 0x00007ff0302fbe33 in QWidgetWindow::event (this=0xf84f60, event=0x7fff910c4030) at kernel/qwidgetwindow.cpp:210
#49 0x00007ff03029db2c in QApplicationPrivate::notify_helper (this=0xd1c5d0, receiver=0xf84f60, e=0x7fff910c4030) at kernel/qapplication.cpp:3720
#50 0x00007ff0302a3000 in QApplication::notify (this=0x7fff910c44e0, receiver=0xf84f60, e=0x7fff910c4030) at kernel/qapplication.cpp:3503
#51 0x00007ff02f993c2b in QCoreApplication::notifyInternal (this=0x7fff910c44e0, receiver=0xf84f60, event=0x7fff910c4030) at kernel/qcoreapplication.cpp:935
#52 0x00007ff02fce0f82 in sendSpontaneousEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#53 QGuiApplicationPrivate::processMouseEvent (e=0xf2f990) at kernel/qguiapplication.cpp:1774
#54 0x00007ff02fce2b45 in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0xf2f990) at kernel/qguiapplication.cpp:1576
#55 0x00007ff02fcc734f in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:572
#56 0x00007ff01fdf6590 in userEventSourceDispatch (source=<optimized out>) at eventdispatchers/qeventdispatcher_glib.cpp:70
#57 0x00007ff02a31bc3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#58 0x00007ff02a31bf20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#59 0x00007ff02a31bfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#60 0x00007ff02f9ecc57 in QEventDispatcherGlib::processEvents (this=0xd589a0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#61 0x00007ff02f9913e2 in QEventLoop::exec (this=this@entry=0x7fff910c43d0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#62 0x00007ff02f99902c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#63 0x00007ff02fcd831c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#64 0x00007ff0302997a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#65 0x0000000000413032 in main (argc=1, argv=0x7fff910c4618) at ../main.cpp:72

Reported using DrKonqi
Comment 1 kajalsinha 2015-04-29 02:57:50 UTC
Created attachment 92313 [details]
New crash information added by DrKonqi

kinfocenter (5.2.2) using Qt 5.4.1

- What I was doing when the application crashed:

The KInfoCentre application crashes right when I navigate from Graphical Information > OpenGL 
As soon as I click on OpenGL it crashes!

Regards

-- Backtrace (Reduced):
#6  0x00007f775ab5caf0 in _xend () at ../sysdeps/unix/sysv/linux/x86/elision-unlock.c:33
#7  __lll_unlock_elision (lock=0x2d2d380, private=0) at ../sysdeps/unix/sysv/linux/x86/elision-unlock.c:29
#8  0x00007f7757cf57e5 in _XError (dpy=dpy@entry=0x289d3b0, rep=rep@entry=0x7ffd0ba8f320) at ../../src/XlibInt.c:1461
#9  0x00007f7756232d67 in __glXGenerateError (resource=0, errorCode=0 '\000', minorCode=26, dpy=0x289d3b0) at ../../../../src/glx/glxcurrent.c:195
#10 MakeContextCurrent (dpy=0x289d3b0, draw=106954757, read=106954757, gc_user=0x33ee620) at ../../../../src/glx/glxcurrent.c:246
Comment 2 Christoph Feck 2015-05-02 22:06:12 UTC

*** This bug has been marked as a duplicate of bug 344971 ***