Bug 346502 - Shift-click to extend selection change the start of the selection when entire line selected with triple click as a start
Summary: Shift-click to extend selection change the start of the selection when entire...
Status: RESOLVED DUPLICATE of bug 374454
Alias: None
Product: konsole
Classification: Unclassified
Component: copy-paste (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords: investigated, triaged
Depends on:
Blocks:
 
Reported: 2015-04-23 08:57 UTC by lonesome.zoro
Modified: 2018-10-30 22:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lonesome.zoro 2015-04-23 08:57:18 UTC
Start by selecting an entire line with a triple-click.
Move down, then do a shift-click to extend the selection: the start of the selection is moved one line doen.

Reproducible: Always

Steps to Reproduce:
1. Triple click to select one entire line
2. Shift click somewhere below in konsole
3. See how the start of selection moves one line down

Actual Results:  
Selection doesn't contain the first line you selected

Expected Results:  
The selection should start with the line selected in the first place
Comment 1 Sebastian 2018-10-30 22:21:03 UTC
Note: I am no maintainer but from the bugsquad.

Hello,

although this is not totally a duplicate, the reason is the same as in bug #374454

I will close this report here, because the other in 374454 sent a fix that resolves both issues.

I will try to push it to the repo.

System Information:
konsole 17.12.3
kde-plasma-version: 5.12.6
kde-frameworks-version: 5.44.0
qt-version: 5.9.5
Comment 2 Sebastian 2018-10-30 22:21:10 UTC

*** This bug has been marked as a duplicate of bug 374454 ***