Bug 345882 - deco kcm segfaults in ~ManagedTextureNode()
Summary: deco kcm segfaults in ~ManagedTextureNode()
Status: RESOLVED DUPLICATE of bug 345508
Alias: None
Product: kwin
Classification: Plasma
Component: decorations (show other bugs)
Version: 5.2.2
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
: 346598 346919 347089 348679 349036 349623 350508 350677 351087 352716 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-05 08:15 UTC by tolis
Modified: 2016-08-29 07:03 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tolis 2015-04-05 08:15:50 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-12-generic x86_64
Distribution: Ubuntu Vivid Vervet (development branch)

-- Information about the crash:
- What I was doing when the application crashed: was trying to select a window decoration in the system settings. Before i had selected and installed a few new ones from within the app itself and after i installed the new ones and selected one of the new ones to use, when i try to choose another one, when i try to either scroll or click on the window to select a new one the app crashes

- Unusual behavior I noticed:

- Custom settings of the application:

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb741a8d780 (LWP 3766))]

Thread 3 (Thread 0x7fb721038700 (LWP 3769)):
#0  0x00007fb73b987789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fb73b942409 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb73b942de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb73b942fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fb73eb1ac6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fb73eabf3e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fb73e87eb44 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fb721b84f45 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007fb73e883b0e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007fb73be616aa in start_thread (arg=0x7fb721038700) at pthread_create.c:333
#10 0x00007fb73e20deed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fb71994b700 (LWP 3770)):
#0  0x00007fb73e2028dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb73b942ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb73b942fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb73eb1ac6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fb73eabf3e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fb73e87eb44 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fb721b84f45 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fb73e883b0e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007fb73be616aa in start_thread (arg=0x7fb71994b700) at pthread_create.c:333
#9  0x00007fb73e20deed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fb741a8d780 (LWP 3766)):
[KCrash Handler]
#6  0x00007fb71b7bfeec in ?? () from /usr/lib/x86_64-linux-gnu/libKF5QuickAddons.so.5
#7  0x00007fb71b7c0366 in ManagedTextureNode::~ManagedTextureNode() () from /usr/lib/x86_64-linux-gnu/libKF5QuickAddons.so.5
#8  0x00007fb7222c7c13 in QSGNode::destroy() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fb7222c7c47 in QSGNode::~QSGNode() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007fb7222c7c79 in QSGNode::~QSGNode() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fb7222c7c13 in QSGNode::destroy() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fb7222c7c47 in QSGNode::~QSGNode() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fb7222c7df9 in QSGOpacityNode::~QSGOpacityNode() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fb7222c7c13 in QSGNode::destroy() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fb7222c7c47 in QSGNode::~QSGNode() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007fb7222c7db9 in QSGTransformNode::~QSGTransformNode() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#17 0x00007fb7223253c4 in QQuickWindowPrivate::cleanupNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#18 0x00007fb72232545e in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#19 0x00007fb722325d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#20 0x00007fb7222f4f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#21 0x00007fb7222f5979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#22 0x00007fb73f8acb2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#23 0x00007fb73f8b2000 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#24 0x00007fb73eac1c2b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#25 0x00007fb73eb19ae5 in QTimerInfoList::activateTimers() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007fb73eb19f61 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007fb73b942c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fb73b942f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fb73b942fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fb73eb1ac57 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#31 0x00007fb73eabf3e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#32 0x00007fb73eac702c in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#33 0x000000000040eebc in main ()

Reported using DrKonqi
Comment 1 Thomas Lübking 2015-04-16 20:18:41 UTC
Most likely dupe of bug #345508, ManagedTextureNode::~ManagedTextureNode() in the active thread, though.
Comment 2 Christoph Feck 2015-04-25 09:00:47 UTC
*** Bug 346598 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2015-05-02 23:57:51 UTC
*** Bug 346919 has been marked as a duplicate of this bug. ***
Comment 4 Thomas Lübking 2015-05-03 09:13:08 UTC
*very* likely a dupe of bug #345660
Comment 5 Christoph Feck 2015-05-09 19:19:20 UTC
*** Bug 347089 has been marked as a duplicate of this bug. ***
Comment 6 Christoph Feck 2015-06-07 10:20:38 UTC
*** Bug 348679 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Feck 2015-06-16 17:32:59 UTC
*** Bug 349036 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Feck 2015-07-10 14:30:52 UTC
*** Bug 349623 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Feck 2015-07-28 11:56:16 UTC
*** Bug 350508 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Feck 2015-07-28 11:56:33 UTC
*** Bug 350677 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2015-08-13 00:20:26 UTC
*** Bug 351087 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Feck 2015-09-23 14:54:16 UTC
*** Bug 352716 has been marked as a duplicate of this bug. ***
Comment 13 Martin Flöser 2016-08-29 07:03:09 UTC
As we didn't get any duplicates any more, I assume it was bug 345508

*** This bug has been marked as a duplicate of bug 345508 ***