Bug 345636 - Gwenview
Summary: Gwenview
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-03-29 03:15 UTC by sde1417
Modified: 2015-03-30 19:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
attachment-3997-0.html (1.52 KB, text/html)
2015-03-30 12:57 UTC, sde1417
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sde1417 2015-03-29 03:15:48 UTC
Application: gwenview (4.14.0 pre)
KDE Platform Version: 4.14.6
Qt Version: 4.8.6
Operating System: Linux 3.19.2-1-desktop x86_64
Distribution: "openSUSE 20150327 (Tumbleweed) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Opening small image files, png and jpeg.
When closing program it crashes every time.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa19be00940 (LWP 7004))]

Thread 2 (Thread 0x7fa182993700 (LWP 7005)):
#0  0x00007fa1988934cd in poll () at /lib64/libc.so.6
#1  0x00007fa195794be4 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fa195794cec in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fa19b39601e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#4  0x00007fa19b367daf in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#5  0x00007fa19b3680a5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#6  0x00007fa19b26549f in QThread::exec() () at /usr/lib64/libQtCore.so.4
#7  0x00007fa19b3496b3 in  () at /usr/lib64/libQtCore.so.4
#8  0x00007fa19b267b7f in  () at /usr/lib64/libQtCore.so.4
#9  0x00007fa195c634b4 in start_thread () at /lib64/libpthread.so.0
#10 0x00007fa19889ba4d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7fa19be00940 (LWP 7004)):
[KCrash Handler]
#5  0x00007fa1996f1ea9 in QRasterWindowSurface::~QRasterWindowSurface() () at /usr/lib64/libQtGui.so.4
#6  0x00007fa1996f1f29 in QRasterWindowSurface::~QRasterWindowSurface() () at /usr/lib64/libQtGui.so.4
#7  0x00007fa19970a21c in  () at /usr/lib64/libQtGui.so.4
#8  0x00007fa1995467a9 in  () at /usr/lib64/libQtGui.so.4
#9  0x00007fa199546949 in QWidgetPrivate::deleteExtra() () at /usr/lib64/libQtGui.so.4
#10 0x00007fa199546b5d in QWidgetPrivate::~QWidgetPrivate() () at /usr/lib64/libQtGui.so.4
#11 0x00007fa199546de9 in QWidgetPrivate::~QWidgetPrivate() () at /usr/lib64/libQtGui.so.4
#12 0x00007fa19b381ff5 in QObject::~QObject() () at /usr/lib64/libQtCore.so.4
#13 0x00007fa19954f56c in QWidget::~QWidget() () at /usr/lib64/libQtGui.so.4
#14 0x00007fa19954f7e9 in QWidget::~QWidget() () at /usr/lib64/libQtGui.so.4
#15 0x00007fa199a9a325 in  () at /usr/lib64/libQtGui.so.4
#16 0x00007fa1987eac39 in __run_exit_handlers () at /lib64/libc.so.6
#17 0x00007fa1987eac85 in  () at /lib64/libc.so.6
#18 0x00007fa1987d58cc in __libc_start_main () at /lib64/libc.so.6
#19 0x000000000042a092 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2015-03-29 10:07:37 UTC
Are you using oxygen-transparent or bespin widget style?
Comment 2 sde1417 2015-03-30 12:57:05 UTC
Created attachment 91819 [details]
attachment-3997-0.html

Yes this was indeed caused by oxygen-transparent windows decorator theme.
I figured it out just before i read this email. I should have thought of
this before i sent the bug report.
I had forgotten that themes can cause errors like this. From now on i will
always reset to defaults before reporting bugs.

KDE is great by the way, thanks!

2015-03-29 12:07 GMT+02:00 Christoph Feck <cfeck@kde.org>:

> https://bugs.kde.org/show_bug.cgi?id=345636
>
> Christoph Feck <cfeck@kde.org> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                  CC|                            |cfeck@kde.org
>
> --- Comment #1 from Christoph Feck <cfeck@kde.org> ---
> Are you using oxygen-transparent or bespin widget style?
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 3 Christoph Feck 2015-03-30 19:01:10 UTC

*** This bug has been marked as a duplicate of bug 261539 ***