Bug 345386 - Impossibility to interact with some windows of Java based applications when current layout is not the first in the list of kxkbrc
Summary: Impossibility to interact with some windows of Java based applications when c...
Status: RESOLVED WORKSFORME
Alias: None
Product: kxkb
Classification: Miscellaneous
Component: general (show other bugs)
Version: 3.0
Platform: Other Linux
: NOR major
Target Milestone: ---
Assignee: Andriy Rysin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-21 09:08 UTC by Simone Gaiarin
Modified: 2021-03-10 06:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simone Gaiarin 2015-03-21 09:08:13 UTC
Assuming the following kxkbrc file:
[Layout]
DisplayNames=,
LayoutList=us,de(nodeadkeys)

When the current used keyboard layout is not the first in the list of the available layouts e.g 'de' in the example, some windows of running java based applications (i.e. josm, MATLAB) become transparent to the mouse, so that it's impossible to interact with them.

Right clicking on the parent window makes them active again for a while.

See:
https://josm.openstreetmap.de/ticket/10430 (comment 16 found the cause of the problem)
http://se.mathworks.com/matlabcentral/newsreader/view_thread/338444#929361
http://se.mathworks.com/matlabcentral/answers/160294-how-can-i-resolve-gui-issues-under-debian-linux-unable-to-open-menus-nor-use-buttons-on-graphics

Reproducible: Always
Comment 1 gabriel.rilling 2015-07-20 10:56:05 UTC
According to user Self-Perfection at https://josm.openstreetmap.de/ticket/10430, this bug appears in XFCE too. Could it be a XIM-related bug rather than KDE?
Comment 2 Markus Heidelberg 2015-07-20 21:08:58 UTC
I just installed Xfce with the XKB plugin and can verify this myself.

A little difference: There the bug does not occur if I first click on the popup, then on the parent window and then on the popup again. I first have to click on the parent and then on the popup to trigger the bug. In KDE both procedures trigger the bug.
Note: with "click" I always mean the left mouse button.
Comment 3 Simone Gaiarin 2015-07-30 08:55:56 UTC
This other bug might be related:
https://bugs.kde.org/show_bug.cgi?id=347964
Comment 4 Justin Zobel 2021-03-10 00:12:31 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.
Comment 5 Simone Gaiarin 2021-03-10 06:24:10 UTC
Tested with JOSM and seems to be fixed. I cannot test with MATLAB at the moment. If the others still have the bug, please reopen it.