Bug 345227 - Desktop turns black and plasmoids disappear when docking notebook
Summary: Desktop turns black and plasmoids disappear when docking notebook
Alias: None
Product: KScreen
Classification: Plasma
Component: common (show other bugs)
Version: 1.0.2
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Daniel Vrátil
Depends on:
Reported: 2015-03-16 18:02 UTC by Simone Gaiarin
Modified: 2018-02-24 21:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Note You need to log in before you can comment on or make changes to this bug.
Description Simone Gaiarin 2015-03-16 18:02:17 UTC
Sometimes when I dock the notebook to a docking station with two external monitors attached the desktop of the two external monitors turns black and the plasmoid disappear, while the mouse is visible. (If I'm not wrong also the other activities disappear)

Then going to System Settings > Power Managment and clicking on the activity tab the desktops reappear as they were.

It seems that when contacting the Activity dataengine (maybe) something is triggered and everything goes back to normal state.

Reproducible: Sometimes

Steps to Reproduce:
1.Dock the notebook to a docking station

Actual Results:  
Black desktop on external screens and no plasmoids

Expected Results:  
Screens turn on showing normal desktops

My configuration:
Dell E7440 notebook connected to a docking station where two other monitors are connected

May be related: https://bugs.kde.org/show_bug.cgi?id=345225
Comment 1 Daniel Vrátil 2015-03-18 10:00:11 UTC
Sounds to me like Plasma not correctly detecting screen changes (i.e. we turn the screens on, but Plasma won't create background and panels on those screens).

Can you test this with Plasma 5?
Comment 2 Simone Gaiarin 2015-03-18 21:07:07 UTC
I'll see if I can try a live plasma 5 image to test it in the next days.
Comment 3 Christoph Feck 2015-05-02 19:30:57 UTC
Simone, any update?
Comment 4 Simone Gaiarin 2015-05-03 13:10:36 UTC
I've tried briefly with an image of Plasma 5 and it was not happening, but it's not a conclusive result since the problem appear rarely and I didn't find a pattern to reproduce it yet. I'll update to Plasma 5 soon, so I can carry out more extensive testing.
Comment 6 Simone Gaiarin 2016-01-10 10:48:28 UTC
I'm using Plasma 5 since few versions now, and even tough the multimonitor support is still completely broken both from KScreen and Plasma side unfortunately, this specific problem haven't happened anymore.
Comment 7 Simone Gaiarin 2016-07-28 17:44:52 UTC
This problem appeared again in a different form. Sometimes after boot, the external monitor is black without plasmoids, without the right click menu, but the mouse cursor is visible. Moreover the panel that should be in this screen is in the laptop screen.

Restarting plasma solves the problem.

It seems that the external monitor is not detected by plasma and kscreen.
Comment 8 Simone Gaiarin 2018-02-24 21:29:35 UTC
Didn't happen in a long time. I mark it as solved.