Bug 344989 - Please add cyrillic glyphs to Oxygen fonts
Summary: Please add cyrillic glyphs to Oxygen fonts
Status: RESOLVED UNMAINTAINED
Alias: None
Product: Oxygen
Classification: Unclassified
Component: fonts (show other bugs)
Version: 5.2.1
Platform: Kubuntu Packages Linux
: NOR wishlist with 61 votes (vote)
Target Milestone: ---
Assignee: vernon adams
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-09 20:46 UTC by Kyrylo Bohdanenko
Modified: 2016-03-07 18:02 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
How fonts look now: mixed Oxygen and DejaVu Sans (59.63 KB, image/png)
2015-03-09 20:47 UTC, Kyrylo Bohdanenko
Details
Patch for merging latinic fonts from Plasma 5.2 to 'vernon-adams' branch (1.87 KB, patch)
2015-05-13 21:20 UTC, Kyrylo Bohdanenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kyrylo Bohdanenko 2015-03-09 20:46:29 UTC
Hi,

It's been a while since Oxygen Fonts 0.4 release and still cyrillic charaters are missing. I am using russian locale and sometimes the picture 

Reproducible: Always

Steps to Reproduce:
1. Switch KDE to locale which uses cyrillic symbols (e.g. ukrainian, bulgarian, russian, ...) 

Actual Results:  
Cyrillic glyphs are drawn with other font (configured as fallback).

Expected Results:  
Cyrillic glyphs should be present in Oxygen fonts.
Comment 1 Kyrylo Bohdanenko 2015-03-09 20:47:27 UTC
Created attachment 91513 [details]
How fonts look now: mixed Oxygen and DejaVu Sans
Comment 2 Eugene 2015-05-13 18:42:42 UTC
Yes, they're looks really bad.
The same report on launchpad: https://bugs.launchpad.net/ubuntu/+source/oxygen-fonts/+bug/1454672
Comment 3 Kyrylo Bohdanenko 2015-05-13 21:15:05 UTC
Also, in git branch 'vernon-adams' there are already some draft versions. So why not at least merge the into master?
Comment 4 Kyrylo Bohdanenko 2015-05-13 21:20:28 UTC
Created attachment 92582 [details]
Patch for merging latinic fonts from Plasma 5.2 to 'vernon-adams' branch

On my system I dowloaded code from git://anongit.kde.org/oxygen-fonts, switched to 'vernon-adams' branch and applied the attached patch (i.e. merged latinic glyphs  from master).
Comment 5 Jacobtey 2015-05-16 14:23:40 UTC
Comme is the new name for the Oxygen Font family https://github.com/vernnobile/commeFont
Comment 6 Tom 2015-07-28 01:25:10 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Kai Uwe Broulik 2016-03-07 18:02:05 UTC
Thanks for your bug report.

Unfortunately we do not have the resources to maintain this font anymore and moved upstream to using the Noto font [1] which also provides much better glyph coverage. We advise you do the same. Sorry.

[1] https://www.google.com/get/noto/