Bug 344620 - Dropbox and Copy Agent do not show up in systray
Summary: Dropbox and Copy Agent do not show up in systray
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: System Tray (show other bugs)
Version: 5.2.0
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-27 09:10 UTC by vanboxem.ruben
Modified: 2016-05-25 10:42 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vanboxem.ruben 2015-02-27 09:10:27 UTC
In a KDE4 workspace, both the Dropbox and Copy Agent icons show up in the system tray. This is useful to know if my documents are being synced and my work is properly backed up to the cloud.

They do not show up in the Plasma 5 systray plasmoid, although the applications are running and syncing. They even autostart (I know this because Copy Agent always pops up its window on boot).

Reproducible: Always

Steps to Reproduce:
1. Install Copy Agent (copy.com) or Dropbox (dropbox.com).
2. Start either or both

Actual Results:  
No icons in the systray

Expected Results:  
Icons in the systray
Comment 1 David Edmundson 2015-02-27 09:15:38 UTC
Please see http://blog.martin-graesslin.com/blog/2014/06/where-are-my-systray-icons/ .

Sorry there's not much we can do, but hope dropbox upgrade their internal Qt quickly and stop using super legacy protocols
Comment 2 vanboxem.ruben 2015-02-27 09:45:53 UTC
I have reported this to both the dropbox community: https://www.dropboxforum.com/hc/communities/public/questions/201908279-Systray-icon-not-showing-in-KDE-Plasma-5-2
and the copy support (you'll need a login): https://copy.zendesk.com/requests/62227

Let's hope they respond as quickly as KDE devs ;)
Comment 3 Stefan Müller 2015-06-04 02:42:09 UTC
Why KDE can not resolve this problem? I use openSuse Thumbleweed with GNOME and all system trays icons work fine, like dropbox, mikogo, skype etc. With new Plasma 5 I can not use these old software! I need an external solution like wmsystemtray! I have a brand-new Plasma 5 interface and must arrange the icons in a separate absolutely ugly window. Im not a power user and have problems to resolve this. I am excited about plasma 5, but the desktop environment should be based on the user and not vice versa. Many users like me will be angry needlessly about such things. I understand the new standards are to be enforced, but not at the expense of the user. Sorry Guys, but i go back to GNOME, cause the old software programs are no longer usable. Why should I change to plasma when I can not use my programs as usual?
Comment 4 Albert Vaca 2016-02-16 13:55:00 UTC
Support for xembed has been added in the past months :)
Comment 5 Wulf 2016-02-20 14:15:16 UTC
since some days dropbox-systray-icon is broken again
I have this issue with Arch and Opensuse Tumbleweed (both uptodate)
Comment 6 Albert Vaca 2016-02-20 14:59:10 UTC
Make sure your problem is not related to the systemd boot script:

https://wiki.archlinux.org/index.php/Dropbox#Starting_on_boot_with_systemd
Comment 7 Wulf 2016-02-20 15:09:46 UTC
Hi Albert,

thanks, but I do not use systemd to start dropbox.

Weird; on both Arch and Opensuse, icon reappears after logoff and relogin
Comment 8 Wulf 2016-02-23 09:22:39 UTC
new dropbox version 3.14.7 re-resolved it for me
Comment 9 Benedikt Winder 2016-05-10 10:34:56 UTC
Same Problem for me. Archlinux and Plasma 5.6. Dropbox Version 3.20.1-1 from AUR.
Comment 10 Benedikt Winder 2016-05-10 10:58:46 UTC
I've got it to work under Archlinux. First of all uninstall Dropbox.

sudo pacman -Rsn dropbox

Delete User Config:

rm -Rf .dropbox*

Install libappindicator-gtk3 (I don't know if this is needed)

yaourt libappindicator-gtk3

Then install dropbox again.

yaourt dropbox

And now this was for me the important part. Don't start Dropbox now! Now we create a User Service.

systemctl --user edit dropbox

Fill the file with following:

[Service]
Environment=DISPLAY=:0

After this reboot the computer. After next login the Dropbox Wizard shows up and the Systray Icon is available.

Sources:
https://wiki.archlinux.org/index.php/Dropbox#Starting_on_boot_with_systemd
Comment 11 EMR_Kde 2016-05-25 10:42:44 UTC
I don't know if this is fixed because Evolution (evolution-alarm-notify) and Java (davmail, vuze, etc) apps "show up" but you cannot click on them. For example, Pidgin works OK (right-click has context menu, left-click brings the window up).