Bug 344504 - Cursor and view positions not correctly saved/restored when using a split view
Summary: Cursor and view positions not correctly saved/restored when using a split view
Status: RESOLVED DUPLICATE of bug 353852
Alias: None
Product: kate
Classification: Unclassified
Component: sessions (show other bugs)
Version: 5.0.0
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-23 20:41 UTC by syll
Modified: 2016-06-12 18:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description syll 2015-02-23 20:41:25 UTC
Cursor and view positions are not correctly restored when using split view. Different cases working partially or not at all.

Option Session management -> "including window configuration" is checked.


Reproducible: Always

Steps to Reproduce:
Closing/opening kate :
1. Display a vertically splitted view.
2. Open 2 quite large files in the 2 frames and scroll to the middle of the files.
3. Click there in the 2 files.
4. Close Kate.
5. Open Kate.

Changing session :
1. Use a named session.
2. Display a vertically splitted view.
3. Open 2 quite large files in the 2 frames and scroll to the middle of the files.
4. Click there in the 2 files.
5. Open another session.
6. Open the first session again.


Actual Results:  
Cursor and view positions in the right frame are lost.

Cursor and view positions in the left frame are lost if this frame was the last you clicked in or if you close/open kate (or change session and return) a second time. If you click in the left frame then in the right frame and then close/open kate (or change session and return), cursor and view positions in the left frame are restored the first time.

When positions are lost, the documents explorer does not display the current file (when opening kate, file hierarchy is folded while the document is open).

All of this does work correctly with a non-split view.

Positions are saved and restored for the files not displayed by a frame (display a third document, click in the middle, display the first document in the frame, close and open kate, display the third document again : positions have been restored correctly).


Expected Results:  
Positions should be saved and restored.
File hierarchy should be unfold and display current document.
Comment 1 Dominik Haumann 2016-06-12 18:23:31 UTC
Correct, this does not work. There is a fix which is about to be committed for the Kate Applications 16.04.x release, see https://git.reviewboard.kde.org/r/128163/.

*** This bug has been marked as a duplicate of bug 353852 ***