Bug 344425 - Cannot select fields using the mouse
Summary: Cannot select fields using the mouse
Status: RESOLVED FIXED
Alias: None
Product: Breeze
Classification: Unclassified
Component: QStyle (show other bugs)
Version: 5.4.2
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-21 16:29 UTC by André Marcelo Alvarenga
Modified: 2016-01-09 12:14 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description André Marcelo Alvarenga 2015-02-21 16:29:55 UTC
1) Click on "Add" button, to add a conection
2) Choose "Bond" connection type
3) In "Bond" tab click on "Add" and choose Ethernet or Infiniband.
4) Try select any field in opened dialog

This also happens with "Bridge" connection type.

Reproducible: Always
Comment 1 Jan Grulich 2015-02-21 18:56:24 UTC
That's weird. I'm not able to reproduce it, I can select any field I want.
Comment 2 Jan Grulich 2015-02-21 18:58:53 UTC
What is your qt version? Is it reproducible with other connections? Could you please try to add vpnc vpn connection and go to advaced configuration and check whether you can select fields in this dialog?
Comment 3 André Marcelo Alvarenga 2015-02-21 23:18:08 UTC
(In reply to Jan Grulich from comment #2)
> What is your qt version?
5.4 (Plasma 5.2.90)

> Is it reproducible with other connections?
Just with Bond and Bridge connetions, but not with all dialogs. 

> Could youplease try to add vpnc vpn connection and go to advaced configuration and check
whether you can select fields in this dialog?
Yes, I can select fields here.

I record a screencast with the issue. http://youtu.be/vUDthNRhytE

0:06 -> this dialog works. I can select any fields and change then.
0:10 -> the problem occurs when you open a dialog with this [+ Add...] button 
0:12 -> I can only change 'Connetion name:' field
0:19 -> trying to select fields

PS.: I can change the fields if I use TAB key.
Tested with  http://files.kde.org/snapshots/  and   http://pub.dvratil.cz/plasma/iso/ images.
Comment 4 Jan Grulich 2015-02-22 15:05:28 UTC
Ok, I was able to reproduce it on live image from http://pub.dvratil.cz/plasma/iso/, which is based on Fedora 21. I have Fedora 21 installed on my laptop and I'm not able to reproduce it here so it must be issue somewhere else, probably in Qt. I'll try to investigate this further.
Comment 5 Jan Grulich 2015-07-28 10:03:54 UTC
Is this reproducible on a bare metal machine with installed and fully updated system? I was able to reproduce this only on a live image used in VM, but not on any installed system using Fedora 21 or Fedora 22.
Comment 6 André Marcelo Alvarenga 2015-07-29 01:15:50 UTC
(In reply to Jan Grulich from comment #5)
> Is this reproducible on a bare metal machine with installed and fully
> updated system? I was able to reproduce this only on a live image used in
> VM, but not on any installed system using Fedora 21 or Fedora 22.

Hi Jan.

This bug is still present on a fresh installation of Fedora 22 with updated packages.
I can reproduce this bug in a VM too. (latest Fedora and Kubuntu in my two notebooks)

Plasma 5.3.2
Qt Version 5.4.2
Frameworks 5.12
Comment 7 Jan Grulich 2015-07-30 12:58:31 UTC
That's weird, I'm still not sure whether this is a bug in plasma-nm, it might be also a bug in Qt related to graphic drivers. What graphic card/driver do you use?
Comment 8 André Marcelo Alvarenga 2015-07-30 18:11:36 UTC
(In reply to Jan Grulich from comment #7)
> That's weird, I'm still not sure whether this is a bug in plasma-nm, it
> might be also a bug in Qt related to graphic drivers. What graphic
> card/driver do you use?

GeForce 9400M

03:00.0 VGA compatible controller: NVIDIA Corporation C79 [GeForce 9400M G] (rev b1) (prog-if 00 [VGA controller])
        Subsystem: Dell Device 0271
        Flags: bus master, fast devsel, latency 0, IRQ 25
        Memory at cc000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Memory at ce000000 (64-bit, prefetchable) [size=32M]
        I/O ports at 4000 [size=128]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: nouveau
        Kernel modules: nouveau

Intel HD (problably 3000 model)

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: COMPAL Electronics Inc Device 0065
        Flags: bus master, fast devsel, latency 0, IRQ 43
        Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
        Memory at b0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 3000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: i915
Comment 9 André Marcelo Alvarenga 2015-09-06 02:39:25 UTC
Same problem with Manjaro Linux (Arch Linux packages). (both local and VM installations)
Plasma 5.4.0 and Qt 5.5.0.
Comment 10 Jan Grulich 2015-10-13 12:02:11 UTC
It looks that this is related to Breeze widget style because I wasn't able to reproduce it when I switched to Oxygen widget style and switching back to Breeze breaks this again.
Comment 11 André Marcelo Alvarenga 2015-10-18 02:11:15 UTC
(In reply to Jan Grulich from comment #10)
> It looks that this is related to Breeze widget style because I wasn't able
> to reproduce it when I switched to Oxygen widget style and switching back to
> Breeze breaks this again.

Yes, I can confirm. This not happens with Oxygen widget.
Comment 12 Hugo Pereira Da Costa 2015-10-18 09:16:21 UTC
What is the actual application for which the issue appear ? 
Can you post a screenshot of the dialog which fails ? 
When you "switch to oxygen" is it the widget style ? or the plasma style ? (screenshot would tell).

Thanks,

Hugo
Comment 13 Hugo Pereira Da Costa 2015-10-18 09:19:54 UTC
ok. Seems to be plasma-nm. (sorry I missed the video the first time)
Can you also try when using "fusion" as widget style (that is the native Qt one) ?
Comment 14 Hugo Pereira Da Costa 2015-10-18 09:36:22 UTC
ok. Can reproduce (also with latest git). ignore comments 12 and 13. Working on it.
Comment 15 Hugo Pereira Da Costa 2015-10-18 15:55:59 UTC
Git commit 6d852f30a1f2c1988359d4e0cdb21e2f1714a6bd by Hugo Pereira Da Costa.
Committed on 18/10/2015 at 15:55.
Pushed by hpereiradacosta into branch 'master'.

Delay update of widget's palette to after polish is completed, because setPalette messes up with the
event queue otherwise, resulting with some input chains being broken.

M  +57   -4    kstyle/breezepalettehelper.cpp
M  +11   -0    kstyle/breezepalettehelper.h

http://commits.kde.org/breeze/6d852f30a1f2c1988359d4e0cdb21e2f1714a6bd
Comment 16 Hugo Pereira Da Costa 2015-10-18 16:01:18 UTC
Patch above fixes it here.
However, since it is potentially dangerous, I'll wait a couple of days before backporting to 5.4 branch.
Comment 17 Peter Wu 2015-12-12 15:01:16 UTC
This patch causes a performance and rendering regression, see bug 356561
Comment 18 Sandro Andrade 2015-12-16 18:25:01 UTC
Hi, patch 6d852f30a1f2c1988359d4e0cdb21e2f1714a6bd also causes some issues when rendering QML scenes. QtCreator welcome page doesn't show if breeze Qt style is selected. Changing widgets style to oxygen makes QtCreator works fine, but some other QML applications still don't exhibit QML content at all.
Comment 19 Hugo Pereira Da Costa 2015-12-16 18:35:49 UTC
Should now all be fixed with patch c5e48d765ab7ea71b0a4e30fe6482ed7e7be026f and c50b113d374664c44eb5e9fe0fb1243eb3b50f25
(both the original issue and the regressions)

There might be some corner-case visual regressions remaining (like wrong background color behind scrollbars) but these will get fixed when they show up.
Comment 20 André Marcelo Alvarenga 2016-01-09 00:29:34 UTC
Please, reopen this bug report.
I can reproduce this bug in Plasma 5.5.3 (Qt 5.5.1 and Frameworks 5.17).

Distro: Manjaro Linux 15.12
Comment 21 Hugo Pereira Da Costa 2016-01-09 12:14:27 UTC
(In reply to André Marcelo Alvarenga from comment #20)
> Please, reopen this bug report.
> I can reproduce this bug in Plasma 5.5.3 (Qt 5.5.1 and Frameworks 5.17).
> 
> Distro: Manjaro Linux 15.12

Yeah. The fix will appear in Plasma 5.6. No need to reopen