Bug 344344 - Black splash screen during Krita startup
Summary: Black splash screen during Krita startup
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: git master (please specify the git hash!)
Platform: Other Linux
: NOR minor
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-19 11:10 UTC by Camille Bissuel
Modified: 2015-02-20 08:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Krita bug balck splash screen on startup (1.21 MB, video/webm)
2015-02-19 11:11 UTC, Camille Bissuel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Camille Bissuel 2015-02-19 11:10:23 UTC
It's really a minor bug, but since a while (in 2.8 it was already there), the Krita splash screen is black on startup, and get correctly displayed when the main window appear.
Please see short video attached.

I tried to identify the issue, and the best clue so far is some warnings when launching form a terminal : 
---
################################### 
# Adding a tablet device: Wacom Cintiq 21UX stylus 
Device Type: "Stylus" 
# Axes limits data 
X:        0 87200 
Y:        0 65600 
Z:        0 0 
Pressure: 0 2048 
Rotation: -900 899 
T. Pres:  0 0 
################################### 
# Adding a tablet device: Wacom Cintiq 21UX eraser 
Device Type: "XFreeEraser" 
# Axes limits data 
X:        0 87200 
Y:        0 65600 
Z:        0 0 
Pressure: 0 2048 
Rotation: 0 1 
T. Pres:  0 0 
krita(2395)/koffice: Lcms2 error:  9 Wrong input color space on transform 
krita(2395)/koffice: Lcms2 error:  9 Wrong input color space on transform 
libpng warning: iCCP: too many profiles
libpng warning: iCCP: too many profiles
libpng warning: iCCP: too many profiles
libpng warning: iCCP: too many profiles
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
QCoreApplication::postEvent: Unexpected null receiver
---

Particularly the lcms2 warning.

I tried to disable color management in Gnome, to disable color management in Krita, to disable OpenGL, to delete my preference folder (~/.kde4/share/apps/krita) and kritarc file... 
And I only obtained once (deleting the preference folder and not the kritarc file) to see correctly the splash screen, but can't reproduce it anymore.

I suspect a video driver bug, because the bug is present with the KDE environment.

My video card :
ATI Radeon HD4780 (R600)

My config :
Krita 2.9 Beta 3
Antergos distrib (Arch Linux based)
Gnome 3.14
xf86-video-ati 1:7.5.0-2 (open source radeon drivers)
lcms 1.19-5 and lcms2 2.6-1
xorg-server 1.17.1-1
mesa 10.4.4-1

Reproducible: Always
Comment 1 Camille Bissuel 2015-02-19 11:11:19 UTC
Created attachment 91168 [details]
Krita bug balck splash screen on startup
Comment 2 Halla Rempt 2015-02-19 11:13:01 UTC
It's a gnome issue, I'm afraid. It works fine on windows, osx, kde and xfce, but with gnome3, the splash doesn't get painted. That's to say, not for you and me, but on Wolthera's laptop it paints!
Comment 3 Camille Bissuel 2015-02-19 11:22:37 UTC
Ok, so maybe for Gnome users with some video drivers  ;)
Tried with Gnome on Wayland, and Gnome Classique... it's the same ;p

Do you think I should report a Gnome bug ?
Comment 4 Halla Rempt 2015-02-19 11:27:29 UTC
I suspect it's a Qt bug, actually, scribus has the same issue.
Comment 5 Camille Bissuel 2015-02-19 12:52:55 UTC
So, here it is in the Qt bug tracker : https://bugreports.qt.io/browse/QTBUG-44557
Comment 6 Halla Rempt 2015-02-20 08:39:32 UTC
Git commit 1aaba92f77b1148c6f7af81c90f7f121a3bae13d by Boudewijn Rempt.
Committed on 20/02/2015 at 08:37.
Pushed by rempt into branch 'calligra/2.9'.

Gnome 3's window manager and Qt's splash screen don't work together.
Scribus, Karbon, Krita -- every application with a Qt splash shows an
empty rectangle until the main window is mapped. Is it a Qt bug? Is
it a Gnome bug? I don't know, but it looks bad, so on Gnome, don't splash
until the mainwindow is shown.

M  +2    -2    krita/ui/KisApplication.cpp

http://commits.kde.org/calligra/1aaba92f77b1148c6f7af81c90f7f121a3bae13d
Comment 7 Camille Bissuel 2015-02-20 08:52:15 UTC
Thanks, I suppose it's the best in the interval !