Bug 344271 - Kmail crash on imap-ressource (segfault)
Summary: Kmail crash on imap-ressource (segfault)
Status: RESOLVED DUPLICATE of bug 351850
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-02-17 12:44 UTC by Jan-Simon M
Modified: 2016-03-21 23:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan-Simon M 2015-02-17 12:44:20 UTC
Application: akonadi_imap_resource (4.14)
KDE Platform Version: 4.14.4
Qt Version: 4.8.6
Operating System: Linux 3.17.0-rc51-js2-00622-geae7382 x86_64
Distribution: "openSUSE 13.2 (Harlequin) (x86_64)"

-- Information about the crash:
IMAP folder refresh or synchronization. Initial sync works right after startup, but timed refresh segfaults.

Distro is openSUSE 13.2 with stock packages.

This should be the backtrace in question:
Thread 1 (Thread 0x7fe561f957c0 (LWP 5210)):
[KCrash Handler]
#6  0x00007fe55f21b64d in QByteArray (a=..., this=0x7fff7fc4bf20) at /usr/include/QtCore/qbytearray.h:439
#7  toString (this=0x0) at /usr/src/debug/kdepimlibs-4.14.4/kimap/message_p.h:42

The crash can be reproduced every time.

-- Backtrace:
Application: GMX vom Typ IMAP-E-Mail-Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe561f957c0 (LWP 5210))]

Thread 3 (Thread 0x7fe54e375700 (LWP 5212)):
#0  0x00007fe55d8fa49d in read () from /lib64/libc.so.6
#1  0x00007fe55c8c6750 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fe55c885714 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fe55c885b7b in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fe55c885cec in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007fe5615de0de in QEventDispatcherGlib::processEvents (this=0x7fe5480008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:452
#6  0x00007fe5615afe6f in QEventLoop::processEvents (this=this@entry=0x7fe54e374e20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fe5615b0165 in QEventLoop::exec (this=this@entry=0x7fe54e374e20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fe5614ad0bf in QThread::exec (this=<optimized out>) at thread/qthread.cpp:538
#9  0x00007fe5614af79f in QThreadPrivate::start (arg=0x1b3f600) at thread/qthread_unix.cpp:349
#10 0x00007fe55cf6a0a4 in start_thread () from /lib64/libpthread.so.0
#11 0x00007fe55d9067fd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fe54db74700 (LWP 5226)):
#0  0x00007fe55d8fe3cd in poll () from /lib64/libc.so.6
#1  0x00007fe55c885be4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fe55c885cec in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fe5615de0de in QEventDispatcherGlib::processEvents (this=0x7fe540003e40, flags=...) at kernel/qeventdispatcher_glib.cpp:452
#4  0x00007fe5615afe6f in QEventLoop::processEvents (this=this@entry=0x7fe54db73e20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe5615b0165 in QEventLoop::exec (this=this@entry=0x7fe54db73e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fe5614ad0bf in QThread::exec (this=<optimized out>) at thread/qthread.cpp:538
#7  0x00007fe5614af79f in QThreadPrivate::start (arg=0x1a5ced0) at thread/qthread_unix.cpp:349
#8  0x00007fe55cf6a0a4 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fe55d9067fd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fe561f957c0 (LWP 5210)):
[KCrash Handler]
#6  0x00007fe55f21b64d in QByteArray (a=..., this=0x7fff7fc4bf20) at /usr/include/QtCore/qbytearray.h:439
#7  toString (this=0x0) at /usr/src/debug/kdepimlibs-4.14.4/kimap/message_p.h:42
#8  KIMAP::SearchJob::handleResponse (this=<optimized out>, response=...) at /usr/src/debug/kdepimlibs-4.14.4/kimap/searchjob.cpp:429
#9  0x00007fe55f20bddc in KIMAP::SessionPrivate::responseReceived (this=0x1b11610, response=...) at /usr/src/debug/kdepimlibs-4.14.4/kimap/session.cpp:300
#10 0x00007fe5615c959e in QObject::event (this=0x1b11610, e=<optimized out>) at kernel/qobject.cpp:1231
#11 0x00007fe56094a76c in QApplicationPrivate::notify_helper (this=this@entry=0x1900040, receiver=receiver@entry=0x1b11610, e=e@entry=0x7fe540008970) at kernel/qapplication.cpp:4565
#12 0x00007fe560950cad in QApplication::notify (this=this@entry=0x7fff7fc4c8b0, receiver=receiver@entry=0x1b11610, e=e@entry=0x7fe540008970) at kernel/qapplication.cpp:4351
#13 0x00007fe55ea62baa in KApplication::notify (this=0x7fff7fc4c8b0, receiver=0x1b11610, event=0x7fe540008970) at /usr/src/debug/kdelibs-4.14.4/kdeui/kernel/kapplication.cpp:311
#14 0x00007fe5615b12ad in QCoreApplication::notifyInternal (this=0x7fff7fc4c8b0, receiver=receiver@entry=0x1b11610, event=event@entry=0x7fe540008970) at kernel/qcoreapplication.cpp:953
#15 0x00007fe5615b457d in sendEvent (event=0x7fe540008970, receiver=0x1b11610) at kernel/qcoreapplication.h:231
#16 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x18c5520) at kernel/qcoreapplication.cpp:1577
#17 0x00007fe5615b4a23 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#18 0x00007fe5615de8fe in sendPostedEvents () at kernel/qcoreapplication.h:236
#19 postEventSourceDispatch (s=0x18f8ed0) at kernel/qeventdispatcher_glib.cpp:300
#20 0x00007fe55c885a04 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fe55c885c48 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fe55c885cec in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fe5615de0be in QEventDispatcherGlib::processEvents (this=0x18ca9a0, flags=...) at kernel/qeventdispatcher_glib.cpp:450
#24 0x00007fe5609e7676 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007fe5615afe6f in QEventLoop::processEvents (this=this@entry=0x7fff7fc4c820, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007fe5615b0165 in QEventLoop::exec (this=this@entry=0x7fff7fc4c820, flags=...) at kernel/qeventloop.cpp:204
#27 0x00007fe5615b55b9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#28 0x00007fe560948f3c in QApplication::exec () at kernel/qapplication.cpp:3823
#29 0x00007fe561a99c43 in Akonadi::ResourceBase::init (r=0x1abab10) at /usr/src/debug/kdepimlibs-4.14.4/akonadi/resourcebase.cpp:583
#30 0x000000000041a1f3 in _start ()

Possible duplicates by query: bug 340157, bug 339395.

Reported using DrKonqi
Comment 1 Daniel Vrátil 2016-03-21 23:51:35 UTC

*** This bug has been marked as a duplicate of bug 351850 ***