Bug 344168 - there is no ksystray for plasma5
Summary: there is no ksystray for plasma5
Status: RESOLVED UNMAINTAINED
Alias: None
Product: ksystraycmd
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 337304 350136 351733 352760 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-14 18:19 UTC by illumilore
Modified: 2018-09-04 14:14 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
dialog box which asks statusnotieritem engine (13.75 KB, image/png)
2015-02-15 15:46 UTC, Laurent Montel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description illumilore 2015-02-14 18:19:57 UTC
In plasma 5 it seems like there is no ksystray package for iconifying applications.

Reproducible: Always
Comment 1 Christoph Feck 2015-02-15 14:44:15 UTC
Can someone from Plasma team please clarify if ksystraycmd is supposed to be supported on Plasma 5 and check recent bugs?
Comment 2 Eike Hein 2015-02-15 14:52:15 UTC
ksystraycmd has not been ported to SNI. It uses the legacy XEmbed tray protocol which Plasma 5 no longer supports. Opinions in the team are divided on whether ksystraycmd should be ported and bundled, with some believing it useful or necessary, and others considering it a regression vis-a-vis restricting the tray to notification use cases.
Comment 3 Laurent Montel 2015-02-15 15:05:01 UTC
Just a question about systray
What I need to have it ?
I use Plasma5 master + qt5.4.1 and I can't see konversation systray.
How it works in plasma 5  ?
I need a specific module ?
Comment 4 Eike Hein 2015-02-15 15:08:15 UTC
Just adding the System Tray widget to the panel (it's on the default panel) should be enough. Konversation uses SNI. Maybe it's not enabled in Konversation itself? Check Behavior -> General in the config dialog.
Comment 5 Laurent Montel 2015-02-15 15:29:47 UTC
I activated it in konversation but same problem.
But each time that I start plasma5 there is a dialogbox which asked to search an engine for systray.
It tries to search but didn't find.

So what is missing ?
I need to build sni for qt5 ?
Comment 6 Eike Hein 2015-02-15 15:41:02 UTC
Can you attach a screenshot of the dialog?
Comment 7 Laurent Montel 2015-02-15 15:46:25 UTC
Created attachment 91093 [details]
dialog box which asks statusnotieritem engine

Sorry it's in french but it asks an engine for statusnotifieritem.
Comment 8 Eike Hein 2015-02-15 15:50:25 UTC
Hmm, maybe plasma-workspace/dataengines/statusnotifieritem is not getting built/installed for you? My guess would be that you don't have devel packages for dbusmenu-qt5 installed.
Comment 9 Laurent Montel 2015-02-15 16:14:34 UTC
Indeed it was dbusmenu-qt5 which was missing.
It works fine now. Thanks.
Too bad that kdesrc-build doesn't install it by default.

Thanks
Regards
Comment 10 Eike Hein 2015-02-15 16:18:33 UTC
^ It used to, not sure why it was changed.
Comment 11 illumilore 2015-02-15 17:37:21 UTC
" with some believing it useful or necessary,"

It is useful for email, if you don't want it cluttering up your taskbar, but still accessible from any desktop.

"Indeed it was dbusmenu-qt5 which was missing. It works fine now. Thanks."

So it works in plasma5 then? Is it possible to include it in repos?
Comment 12 Eike Hein 2015-02-15 17:41:41 UTC
^ No, this subthread was unrelated to ksystraycmd. Laurent had problems getting the tray icon for an application using SNI to work. ksystraycmd has not been ported to SNI and thus cannot work in Plasma 5.
Comment 13 Eike Hein 2015-02-15 17:42:18 UTC
> It is useful for email, if you don't want it cluttering up your taskbar, but still accessible from any desktop.

KMail has a built-in tray icon feature; you don't need ksystraycmd for that.
Comment 14 illumilore 2015-02-15 23:15:32 UTC
Thunderbird doesn't seem have that feature.
Comment 15 Martin Flöser 2015-02-16 07:04:43 UTC
(In reply to Eike Hein from comment #12)
> ^ No, this subthread was unrelated to ksystraycmd. Laurent had problems
> getting the tray icon for an application using SNI to work. ksystraycmd has
> not been ported to SNI and thus cannot work in Plasma 5.

that's not entirely correct: through our QPT plugin it should get a SNI and with latest Qt 5.5 it should get a SNI from Qt directly.
Comment 16 Martin Flöser 2015-02-16 07:06:55 UTC
(In reply to illumilore from comment #14)
> Thunderbird doesn't seem have that feature.

for thunderbird there are also plugins available: https://launchpad.net/libnotify-mozilla
Comment 17 Bhushan Shah 2015-02-16 19:47:13 UTC
*** Bug 337304 has been marked as a duplicate of this bug. ***
Comment 18 Bhushan Shah 2015-07-12 03:44:55 UTC
*** Bug 350136 has been marked as a duplicate of this bug. ***
Comment 19 Bhushan Shah 2015-08-25 02:54:56 UTC
*** Bug 351733 has been marked as a duplicate of this bug. ***
Comment 20 ray-ven 2015-10-22 11:17:10 UTC
are people still working on this? ksystraycmd ist still missing (at least in kubuntu wily, plasma 5) but offered by k-menu, I think leaving this out of k-menu or adding ksystraycmd (or sth else) would be good.
I have to stay with kdocker at the moment - which isn't very reliable
thanks
Comment 21 Eike Hein 2015-10-22 13:52:58 UTC
There's a new proxy enabling support for legacy tray icons coming which will indirectly make ksystraycmd work again.
Comment 22 illumilore 2015-11-27 04:32:47 UTC
When is that scheduled to happen?
Comment 23 Rex Dieter 2015-11-27 05:00:25 UTC
Plasma 5.5
Comment 24 Juan Simón 2015-12-21 15:28:38 UTC
(In reply to Rex Dieter from comment #23)
> Plasma 5.5

I have installed Plasma 5.5.1 on Gentoo but ksystraycmd is in version 4.11.22
Comment 25 Rex Dieter 2015-12-21 15:31:49 UTC
Plasma 5.5 included legacy systray icon support via xembedsniproxy only.  

No work has been done to implement ksystraycmd (yet)
Comment 26 Christoph Feck 2016-02-12 13:10:48 UTC
*** Bug 352760 has been marked as a duplicate of this bug. ***
Comment 27 Andrew Crouthamel 2018-09-04 14:14:30 UTC
Hello! Sorry to be the bearer of bad news, but this project has been unmaintained for many years so I am closing this bug.