Bug 343944 - Can't shrink tray popup
Summary: Can't shrink tray popup
Status: RESOLVED DUPLICATE of bug 332512
Alias: None
Product: plasmashell
Classification: Plasma
Component: System Tray (show other bugs)
Version: 5.2.0
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-08 20:19 UTC by naraesk
Modified: 2018-03-11 20:15 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Tray popup (267.22 KB, image/jpeg)
2015-02-08 20:20 UTC, naraesk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description naraesk 2015-02-08 20:19:25 UTC
I'm talking of the detachable tray popup window (see screenshot). There are ways to increase it's size, but there is no way to shrink it.

Reproducible: Always

Steps to Reproduce:
1. Open the extended system tray
2. detach the window
3. Move the window (by pressing Alt + drag&drop) to a screen corner

Actual Results:  
The tray popup window gets maximized or big as half of the screen, depending to what screen edge you used

Expected Results:  
There is no way to skrink the window. My tray popup now always  looks like in the screenshot, it doesn't go back to normal.
Comment 1 naraesk 2015-02-08 20:20:18 UTC
Created attachment 90981 [details]
Tray popup
Comment 2 Bhushan Shah 2015-02-09 03:34:20 UTC
I can confirm this bug
Comment 3 Enrico 2015-11-06 21:50:35 UTC
Just open the tray, pin it, and use Alt+F3 to invoke kwin window menu and resize the popup (at point 3 the tray popup is resized by window snapping).

By the way, the pin icon on the top of the tray popup is *not* to detach but rather to pin it so it does not disappear, and is visible on all desktops.
The fact that in this configuration it can be resized and moved around as any other window is more of a collateral effect I'd assume, since this feature is nowhere advertised: there are no controls on the popup window.

This is not a bug really, unless one decides that there should be no way to resize the popup.
Comment 4 Nikolaos Kakouros 2017-02-10 11:57:09 UTC
This is a duplicate of bug 365217.
Comment 5 naraesk 2017-02-10 12:08:44 UTC
According to the date it's the other way around.
Comment 6 Nikolaos Kakouros 2017-02-10 12:11:46 UTC
(In reply to naraesk from comment #5)
> According to the date it's the other way around.

Ooops. Right, my bad! Looked at the modified date.. Probably someone with sufficient rights can close the other bug (although there is a scrolling issue being discussed as well there)
Comment 7 Nate Graham 2018-03-11 20:15:38 UTC

*** This bug has been marked as a duplicate of bug 332512 ***