Bug 343768 - Kmail keeps crashing
Summary: Kmail keeps crashing
Status: RESOLVED DUPLICATE of bug 351850
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-02-04 10:15 UTC by Lars Hilgenstock
Modified: 2016-03-21 23:51 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.62 KB, text/plain)
2015-02-28 12:06 UTC, Justin T. Frisch
Details
New crash information added by DrKonqi (5.05 KB, text/plain)
2015-11-16 06:37 UTC, Arek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Hilgenstock 2015-02-04 10:15:46 UTC
Application: akonadi_imap_resource (4.14)
KDE Platform Version: 4.14.4
Qt Version: 4.8.6
Operating System: Linux 3.18.5-1-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:

While setting up a new account for imap kmail keeps on crashing.

The crash can be reproduced sometimes.

-- Backtrace:
Application: unimail vom Typ IMAP-E-Mail-Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd3af020780 (LWP 4843))]

Thread 3 (Thread 0x7fd392ecf700 (LWP 5067)):
#0  0x00007fd3aa85b42d in read () from /usr/lib/libc.so.6
#1  0x00007fd3a9ebcb80 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007fd3a9e7971c in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#3  0x00007fd3a9e79c33 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0x00007fd3a9e79dac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0x00007fd3aeb2d397 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007fd3aeafcde1 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x00007fd3aeafd145 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0x00007fd3ae9f17f9 in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0x00007fd3ae9f405f in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007fd3aa567314 in start_thread () from /usr/lib/libpthread.so.0
#11 0x00007fd3aa86824d in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7fd39977f700 (LWP 5069)):
#0  0x00007fd3a9ebe034 in g_mutex_unlock () from /usr/lib/libglib-2.0.so.0
#1  0x00007fd3a9e79b3d in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007fd3a9e79dac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007fd3aeb2d397 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007fd3aeafcde1 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007fd3aeafd145 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007fd3ae9f17f9 in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007fd3ae9f405f in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007fd3aa567314 in start_thread () from /usr/lib/libpthread.so.0
#9  0x00007fd3aa86824d in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7fd3af020780 (LWP 4843)):
[KCrash Handler]
#6  0x00007fd3ad8420ed in KIMAP::SearchJob::handleResponse(KIMAP::Message const&) () from /usr/lib/libkimap.so.4
#7  0x00007fd3ad83308b in KIMAP::SessionPrivate::responseReceived(KIMAP::Message const&) () from /usr/lib/libkimap.so.4
#8  0x00007fd3aeb17491 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#9  0x00007fd3ade4f9ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#10 0x00007fd3ade56408 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#11 0x00007fd3abc951ea in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#12 0x00007fd3aeafe28d in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#13 0x00007fd3aeb01651 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#14 0x00007fd3aeb2d233 in ?? () from /usr/lib/libQtCore.so.4
#15 0x00007fd3a9e79a0d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#16 0x00007fd3a9e79cf8 in ?? () from /usr/lib/libglib-2.0.so.0
#17 0x00007fd3a9e79dac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#18 0x00007fd3aeb2d37d in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#19 0x00007fd3adef33a6 in ?? () from /usr/lib/libQtGui.so.4
#20 0x00007fd3aeafcde1 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#21 0x00007fd3aeafd145 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#22 0x00007fd3aeb026e9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#23 0x00007fd3acda23ac in Akonadi::ResourceBase::init(Akonadi::ResourceBase*) () from /usr/lib/libakonadi-kde.so.4
#24 0x0000000000418eae in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 340865.

Possible duplicates by query: bug 343057, bug 341860, bug 340865, bug 340157, bug 339395.

Reported using DrKonqi
Comment 1 Justin T. Frisch 2015-02-28 12:06:41 UTC
Created attachment 91342 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.14) on KDE Platform 4.14.5 using Qt 4.8.6

I've observed periodic crashes von kontact, it turned out that it always happens when a certain one of my imap accounts is synced (so every 5 minutes or whichever interval is selected in the account settings). with another installed imap account, it doesn't crash and on a different machine (arch linux) no account causes problems.

-- Backtrace (Reduced):
#6  0x00007f7de1dce0ed in KIMAP::SearchJob::handleResponse(KIMAP::Message const&) () from /usr/lib/libkimap.so.4
#7  0x00007f7de1dbf08b in KIMAP::SessionPrivate::responseReceived(KIMAP::Message const&) () from /usr/lib/libkimap.so.4
#8  0x00007f7de309d491 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#9  0x00007f7de23d69ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#10 0x00007f7de23dd408 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
Comment 2 Slobodan Simic 2015-03-27 09:22:21 UTC
I think it's connected with a number of messages on server.
I had same problem but when I opened my mail account thru web interface and deleted
messages from Trash and Sent folder 
KMail worked fine and error didn't show again.
Comment 3 Arek 2015-11-16 06:37:57 UTC
Created attachment 95530 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.14) on KDE Platform 4.14.13 using Qt 4.8.7

- What I was doing when the application crashed:

Just opened KMail and hit Check mail. It chrashes every time. It was not mentioned in main Bug.

-- Backtrace (Reduced):
#6  0x00007f4a89a8718d in KIMAP::SearchJob::handleResponse(KIMAP::Message const&) () from /usr/lib/libkimap.so.4
#7  0x00007f4a89a762be in KIMAP::SessionPrivate::responseReceived(KIMAP::Message const&) () from /usr/lib/libkimap.so.4
#8  0x00007f4a8ad59f61 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f4a8a0888dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#10 0x00007f4a8a08f816 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
Comment 4 Daniel Vrátil 2016-03-21 23:51:19 UTC

*** This bug has been marked as a duplicate of bug 351850 ***