Bug 343676 - custom default font for composer is ignored suddenly
Summary: custom default font for composer is ignored suddenly
Status: RESOLVED DUPLICATE of bug 337656
Alias: None
Product: kmail2
Classification: Applications
Component: composereditor-ng (show other bugs)
Version: 5.2.2
Platform: Fedora RPMs Linux
: NOR major with 10 votes (vote)
Target Milestone: ---
Assignee: Laurent Montel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-02 03:49 UTC by mark
Modified: 2017-01-20 20:22 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screen record (891.08 KB, video/x-matroska)
2015-02-03 07:08 UTC, mark
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mark 2015-02-02 03:49:06 UTC
The following settings in Settings > Configure Kmail > Appearance > Fonts > Use Custom Font > Composer > "Tahoma 11" (i.e.) is being ignored by the composer. When opening a new window for a new mail, replaying to a mail, or forwarding, the above chosen font is not selected. Instead a font is selected (in my case "DejaVu Sans Mono 10") which is not used as system default font or similar. Perhaps it is the Kmail default font? It does not seem, by general association, that it was caused by the latest system update (see below list*) nor can I trace any action (no other maintenance was performed) which changed the behaviour; it was working before with the same version of Kmail.


*device-mapper-1.02.90-1.fc21.x86_64
1.02.93-1.fc21.x86_64
device-mapper-event-1.02.90-1.fc21.x86_64
1.02.93-1.fc21.x86_64
device-mapper-event-libs-1.02.90-1.fc21.x86_64
1.02.93-1.fc21.x86_64
device-mapper-libs-1.02.90-1.fc21.x86_64
1.02.93-1.fc21.x86_64
firefox-35.0-3.fc21.x86_64
35.0-6.fc21.x86_64
hwdata-0.274-1.fc21.noarch
0.274-2.fc21.noarch
langtable-0.0.27-1.fc21.noarch
0.0.29-1.fc21.noarch
langtable-data-0.0.27-1.fc21.noarch
0.0.29-1.fc21.noarch
langtable-python-0.0.27-1.fc21.noarch
0.0.29-1.fc21.noarch
librepo-1.7.11-1.fc21.x86_64
1.7.13-1.fc21.x86_64
lvm2-2.02.111-1.fc21.x86_64
2.02.115-1.fc21.x86_64
lvm2-libs-2.02.111-1.fc21.x86_64
2.02.115-1.fc21.x86_64
nfs-utils-1:1.3.1-5.0.fc21.x86_64
1:1.3.1-6.0.fc21.x86_64
python-librepo-1.7.11-1.fc21.x86_64
1.7.13-1.fc21.x86_64
ssmtp-2.64-13.fc21.x86_64
2.64-14.fc21.x86_64
stunnel-5.07-1.fc21.x86_64
5.08-1.fc21.x86_64


Reproducible: Always

Steps to Reproduce:
1. perform above settings
2. open a new mail window (or replay, forward existing mail)
3.

Actual Results:  
The selected font in the new window is "DejaVu Sans Mono 10"

Expected Results:  
The selected font should be "Tahoma 11"

appeared from one reboot to the other without a setting change.
Comment 1 mark 2015-02-03 03:05:24 UTC
Another related occurrence was found. Whilst writing an email and opening the settings screen (Settings > Configure Kmail > change some setting or not but > press OK, the body of the composed mail chnaged back to the the bespoke default font "DejaVu Sans Mono 10". It doesn7t happen when pressing cancel on the "Configure Kmail" screen. Hence, updated this bug to Major.
Comment 2 Laurent Montel 2015-02-03 06:29:58 UTC
(In reply to mark from comment #1)
> Another related occurrence was found. Whilst writing an email and opening
> the settings screen (Settings > Configure Kmail > change some setting or not
> but > press OK, the body of the composed mail chnaged back to the the
> bespoke default font "DejaVu Sans Mono 10". It doesn7t happen when pressing
> cancel on the "Configure Kmail" screen. Hence, updated this bug to Major.

What did you do ? you changed font ?
You are in html mode or plain text mode ?
Comment 3 mark 2015-02-03 06:33:12 UTC
(In reply to Laurent Montel from comment #2)
> (In reply to mark from comment #1)
> > Another related occurrence was found. Whilst writing an email and opening
> > the settings screen (Settings > Configure Kmail > change some setting or not
> > but > press OK, the body of the composed mail chnaged back to the the
> > bespoke default font "DejaVu Sans Mono 10". It doesn7t happen when pressing
> > cancel on the "Configure Kmail" screen. Hence, updated this bug to Major.
> 
> What did you do ? you changed font ?
> You are in html mode or plain text mode ?

In HTML mode. Since my preferred font doesn't work, I change to my font and start writing. then go to the Settings..
Comment 4 mark 2015-02-03 07:08:16 UTC
Created attachment 90884 [details]
screen record
Comment 5 mark 2015-02-10 05:43:44 UTC
Same issue on reinstalled KDE/ KMAIL. Worked fine the first couple of times and then got stuck with one font (or font size). However, setting changes are actually updated to the configuration file ./.kde/share/config/kmail2rc that the setting is changed:

[~]$ egrep -a composer-font ./.kde/share/config/kmail2rc
composer-font=Tahoma,11,-1,5,50,0,0,0,0,0
[~]$ egrep -a composer-font ./.kde/share/config/kmail2rc
composer-font=STIX,11,-1,5,50,0,0,0,0,0
Comment 6 Christian Bayer 2016-03-11 16:42:23 UTC
Same here, Kontact/KMail 5.0.2 on Ubuntu 15.10 latest updates:
KDE Frameworks 5.15.0
Qt 5.4.2 (built against 5.4.2)

Font is the very same, DejaVu Sans Mono which I use nowhere. It changed one or two weeks ago after I rebooted after installing updates. Rebooting again doesn't help. I had no font overrides enabled, I was always using Oxygen Sans what is configured in the KDE global font dialog. Enabling the override is completely ignored. It always starts a reply or a new email with DejaVu Sans Mono.
Comment 7 Christian Bayer 2016-03-11 16:50:10 UTC
Also, the default font for displaying HTML emails changed to DejaVu Sans Mono as well.
Comment 8 Christian Hilberg 2016-07-20 09:45:51 UTC
Kmail 5.2.2, KDEPIM 16.04.3

Set the font in the message view / composer window to e.g. Monospace. Might need to restart Kmail2 for the change to take effect.

Then, configure within Kmail2 e.g. your identity, or mail access settings.

--> Font setting in message view / composer snaps back to some default (a non-monospace for me)
Comment 9 Christian Hilberg 2016-07-20 12:32:12 UTC
...I should add that the config values are still correct. After restarting kmail2, the message is displayed with the configured font.
Comment 10 Denis Kurz 2017-01-20 20:22:24 UTC

*** This bug has been marked as a duplicate of bug 337656 ***