Bug 343665 - Standard shortcuts for applications with same assignment on standard and alternative give error message being ambiguous in applications (e.g. Kate)
Summary: Standard shortcuts for applications with same assignment on standard and alte...
Alias: None
Product: frameworks-kxmlgui
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Arch Linux Linux
: NOR major
Target Milestone: ---
Assignee: kdelibs bugs
: 343711 345542 345807 (view as bug list)
Depends on:
Reported: 2015-02-01 20:19 UTC by Marcel
Modified: 2015-12-24 11:58 UTC (History)
33 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.4.1


Note You need to log in before you can comment on or make changes to this bug.
Description Marcel 2015-02-01 20:19:12 UTC
Standard shortcuts for applications with same assignment on standard and alternative give error message being ambiguous in applications (e.g. Kate).

This happens after a fresh install of plasma-meta 5.2 on arch linux.
Even pressing the defaults button just puts in the same 'ambiguous' assignment.
Pressing shorcuts like 'ctrl+a', 'ctrl+s' or 'ctrl+backspace' gives just an alert that the shortcut is ambiguous.

Reproducible: Always

Steps to Reproduce:
0. have plasma-meta (archlinux) 5.2 installed, and also kate or an other application which relies on the standard shortcuts for applications
1. start kate
2. press any shortcut that comes in mind and has the same assignment on standard and alternative
3. stare at the alert message...

Actual Results:  
I just get the alert for ambiguous shortcuts and that nothing has been executed.

Expected Results:  
The software should just ignore the alternative shortcut assignment if it is the same as the standard one, or should just forbid the same assignment in standard and alternative (would fix that problem in the first place, instead when pressing that shortcut)
Comment 1 Marcel 2015-02-01 20:35:06 UTC
Oh. Forgot to add:
When I remove the alternative from that ambiguous shortcut, the alert message goes away and the command is executed.
Comment 2 Martin Kostolný 2015-02-09 21:21:38 UTC
I have the same problem with my Plasma 5.2.0 on Arch Linux.

The problem is temporarily fixed by removing one of shortcut/alternative (though it does not work out every time) but it does not persist over application restart. The only workaround I've found is a creation of a new shortcut scheme (under "Details >>" button).

When I restart application (namely Kate) the new shortcut scheme has empty name in the selectbox but this is OK with me or maybe for a different bug report.
Comment 3 David Edmundson 2015-02-10 19:23:38 UTC
KHotkeys only deals with global shortcuts for launching apps.

Moving to kxmlgui which is where that error message is coming from.

I can't reproduce here; Kate isn't defaulting to having control+s as a primary and alt shortcut.

Are you saying it defaulted to that?
Comment 4 Mladen Milinkovic, Max 2015-02-10 19:30:57 UTC
*** Bug 343711 has been marked as a duplicate of this bug. ***
Comment 5 Mladen Milinkovic, Max 2015-02-10 19:40:53 UTC
I have same problem and have investigated for a bit..

After customizing shortcut with KShortcutsDialog it prepends Primary and Alternate shortcut to QList<QKeySequence> so it ends up being a pretty long list of duplicate shortcuts after awhile.
Maybe it doesn't actually prepend two to the list, but result is the same. The list has two shortcuts you defined and after it are previous or default shortcuts which cannot be edited/removed without editing the .rc file.

Have created a patch here: https://github.com/maxrd2/kxmlgui/commit/966f6ad78a4831f49e1bfb759315b7499346b9d5 (sorry not sure how to submit patch here)
Every time list is updated or read, It deletes all entries behind first two. It doesn't remove the cause, but it's temporary solution that works for me. Hope it'll help before it's fixed properly.
Comment 6 Chris 2015-03-10 04:27:44 UTC
This has been happening to me with KWrite. Most shortcuts are "ambiguous" and the problem keeps coming back. Hope this gets fixed soon.
Comment 7 Martin Kostolný 2015-03-21 09:24:05 UTC
Like I wrote before I also have this problem but now I've tried with new user (with empty home folder). There was no ambiguity in kwrite/kate shortcuts until I changed a shortcut in System Settings -> Shortcuts -> Application Keyboard Shortcuts (specifically it was "Cut" - removed alternate shift+del). Max is probably more in depth in this :) I don't understand the technical details.

Late answer to David Edmundson: No, control+s is not a primary and alternate shortcut by default. Only after altering "Application Keyboard Shortcuts".

I've also noticed when in "Application Keyboard Shortcuts" if you are clicking Defaults and Reset buttons multiple times in the loop - lines in table are duplicating. But this is probably just a visual bug.
Comment 8 Freddie Chopin 2015-04-03 15:58:55 UTC
Same here - after upgrade to Plasma 5 applications like Kate or Kwrite are just unusable. For me even such trivial things like End or Home don't work at all, while PgUp or PgDown gives the error about ambiguity. Maybe it would be enough just to delete all Kate/Kwrite configuration that exists, so it would start "fresh"?
Comment 9 Freddie Chopin 2015-04-03 16:53:15 UTC
OK, maybe I have a lead here. There's a ~/.config/kdeglobals config file that has shortcuts. After I first looked there, the [Shortcuts] sections looked like a total chaos, so i renamed the file and relogged. After that if you just start Kate/Kwrite, most of the shortcuts work fine - copying, pasting, PgUp or PgDown. But if you just go to shortcut options of KDE, restore defaults and apply that, the chaos reappears.

For example, I just did that (restored default shortcuts and applied, this is only a part of what appears in this file:

--- >8 --- >8 --- >8 --- >8 --- >8 --- >8 ---
Activate Next Tab=Ctrl+]; ; Ctrl+]
Activate Previous Tab=Ctrl+[; ; Ctrl+[
Back=Alt+Left; Back; Alt+Left; Back
Close=Ctrl+W; Ctrl+Esc; Ctrl+W; Ctrl+Esc
Copy=Ctrl+C; Ctrl+Ins; Ctrl+C; Ctrl+Ins
Cut=Ctrl+X; Shift+Del; Ctrl+X; Shift+Del
--- >8 --- >8 --- >8 --- >8 --- >8 --- >8 ---

Now the funny thing is that if I do the same thing again, the chaos gets even worse, because another pair shortcuts is added everywhere... 

The same fragment after first iteration:

--- >8 --- >8 --- >8 --- >8 --- >8 --- >8 ---
Activate Next Tab=; Ctrl+.; Ctrl+]
Activate Previous Tab=; Ctrl+,; Ctrl+[
AddBookmark=Ctrl+B; ; Ctrl+B
Back=Alt+Left; Back; Alt+Left; Back; Alt+Left; Back
Begin=Ctrl+Home; ; Ctrl+Home
Close=Ctrl+W; Ctrl+Esc; Ctrl+W; Ctrl+Esc; Ctrl+W; Ctrl+Esc
Copy=Ctrl+C; Ctrl+Ins; Ctrl+C; Ctrl+Ins; Ctrl+C; Ctrl+Ins
Cut=Ctrl+X; Shift+Del; Ctrl+X; Shift+Del; Ctrl+X; Shift+Del
--- >8 --- >8 --- >8 --- >8 --- >8 --- >8 ---

Another iteration:

--- >8 --- >8 --- >8 --- >8 --- >8 --- >8 ---
Activate Next Tab=Ctrl+]; ; Ctrl+]
Activate Previous Tab=Ctrl+[; ; Ctrl+[
AddBookmark=Ctrl+B; ; Ctrl+B; Ctrl+B
Back=Alt+Left; Back; Alt+Left; Back; Alt+Left; Back; Alt+Left; Back
Begin=Ctrl+Home; ; Ctrl+Home; Ctrl+Home
Close=Ctrl+W; Ctrl+Esc; Ctrl+W; Ctrl+Esc; Ctrl+W; Ctrl+Esc; Ctrl+W; Ctrl+Esc
Copy=Ctrl+C; Ctrl+Ins; Ctrl+C; Ctrl+Ins; Ctrl+C; Ctrl+Ins; Ctrl+C; Ctrl+Ins
Cut=Ctrl+X; Shift+Del; Ctrl+X; Shift+Del; Ctrl+X; Shift+Del; Ctrl+X; Shift+Del
--- >8 --- >8 --- >8 --- >8 --- >8 --- >8 ---

Each time I do that, another pair appears...
Comment 10 Freddie Chopin 2015-04-03 17:14:41 UTC
The problem sort-of persists if I create a new user with new home folder. At first the shortcuts work fine, but as long as I restore default shortcuts almost the same thing happens, but only to part of the shortcuts. For example Ctrl+C and Ctrl+V stop working, but Home, End, PgUp and PgDown work fine.
Comment 11 Mladen Milinkovic, Max 2015-04-03 18:12:13 UTC
(In reply to Freddie Chopin from comment #10)
> The problem sort-of persists if I create a new user with new home folder. At
> first the shortcuts work fine, but as long as I restore default shortcuts
> almost the same thing happens, but only to part of the shortcuts. For
> example Ctrl+C and Ctrl+V stop working, but Home, End, PgUp and PgDown work
> fine.

If you feel like compiling/building your own package you can get patched sources here that have that issue fixed: https://github.com/maxrd2/kxmlgui/
It's temporary solution I use until it gets fixed upstream in KDE
Here's PKGBUILD if you use arch linux: http://pastebin.com/75aLDu4v
Comment 12 Freddie Chopin 2015-04-04 07:36:35 UTC
This commit look suspicious - https://projects.kde.org/projects/frameworks/kxmlgui/repository/revisions/c94ade60e4fb5f81467079706a18cca6c5e9081c or in Max's github https://github.com/maxrd2/kxmlgui/commit/c94ade60e4fb5f81467079706a18cca6c5e9081c 

I wonder if clean kxmlgui with this single change reverted would still show the problem...
Comment 13 Savor d'Isavano 2015-04-08 15:15:53 UTC
Someone submitted another bug report: https://bugs.kde.org/show_bug.cgi?id=345807
Not the same symptom but they are related and seem to have a same cause.
Comment 14 Freddie Chopin 2015-04-08 15:34:08 UTC
That's exactly the same thing I wrote in comment #9 - that's the same issue.
Comment 15 farseerfc 2015-04-09 01:30:27 UTC
*** Bug 345807 has been marked as a duplicate of this bug. ***
Comment 16 Christoph 2015-05-03 09:55:19 UTC
Same Problem here, very annoying
Comment 17 Martin Kostolný 2015-05-10 11:06:22 UTC
Just info: the problem persists with kxmlgui 5.10.0 (arch linux).
Comment 18 Simon Persson 2015-05-17 12:27:51 UTC
Created review request just now with a fix for this one. https://git.reviewboard.kde.org/r/123828/
Comment 19 vayu 2015-07-03 15:09:08 UTC
Same problem here on 5.11.0 after adjusting the keyboard shortcuts in systemsettings.  

I deleted all the entries for [Shortcuts] in kdeglobals ~/.config/kdeglobals and all seems well again for kate.
Comment 20 ttrovo 2015-07-12 08:36:11 UTC
I confirm it on Kubuntu 15.04 with KDE5, very annoying.
Also Konsole has a shortcut unfixed troubles (described in #343711).

The bug is about a half a year old.
Moral: Never ever update to a new version of KDE in first 1-2 years, it's always a pain,
Comment 21 pietz 2015-07-22 23:46:36 UTC
I also can confirm this. Since Plasma 5 I am going to hate nearly every KDE application because this damn error message pops up every minute when you are a poweruser and are used to use shortcuts.

Please fix this fast! I am wondering why none of the main developers uses shortcuts and gets an error message... What desktop do you use? Maybe I should switch, too :-)
Comment 22 Craig 2015-07-29 02:06:10 UTC
Is anyone else getting a crash when this happens? Everytime I hit a hotkey (Ctrl+something) kate crashes right as it throws this same ambigious error. Haven't tried checking yet with debugging or anything but just from the cmd line it's segfaulting (hitting Ctrl+S when open, or anything for that matter)

kf5.kservice.sycoca: Trying to open ksycoca from "/home/x/.cache/ksycoca5"
Calling notify on "Sound"
[1]    14681 segmentation fault (core dumped)  kate
Comment 23 Craig 2015-07-29 02:10:56 UTC
Sorry can't edit, forgot to include some further info on the above:
Running arch linux all latest, kate 15.04.3-1 plasma-workspace 5.3.2-2 plasma-framework 5.12.0-1. Unfortunately even after recompiling the packages for plasma/etc with debugging options dr konq is still showing the proper debug files missing but that's another/separate issue. Running the same just with gdb, target exec /usr/bin/kate, run :

kf5.kservice.sycoca: Trying to open ksycoca from "/home/craig/.cache/ksycoca5"
Calling notify on "Sound"
[New Thread 0x7fffe1f63700 (LWP 15148)]

Program received signal SIGSEGV, Segmentation fault.
0x00007fffd28d9c34 in ?? () from /usr/lib/libQtGui.so.4

I'm recompiling qt5 with debugging options but will take a while and recheck. Also tried reinstalling kate to no avail. Not sure when the issue started showing but typically I use kate frequently and just noticed it the past 4 days or so probably, didn't notice the ambigious error until ran it through gdb which halted it long enough for me to see the error popup (with nothing in it just the title)
Comment 24 Craig 2015-07-29 19:07:40 UTC
At some point in the recent past many shortcuts/hotkeys were duplicated, not sure how/why that happened but had to be in the past weeks. Upon realizing that I removed all the duplicate/identical secondary shortcuts and that resolved both the error and the crash/segfault. Not sure how/why that happened to begin with though as very odd.
Comment 25 Achilleas Koutsou 2015-07-29 20:05:40 UTC
I know everyone who needs to know how this bug is reproduced probably knows already, but I made a video that shows how it works a while ago and I neglected to post it. Here it is now, for anyone coming across this bug and still wondering what exactly is going on. I hope it clarifies a few things and helps users work around it, or at least understand what's happening (for sanity's sake).

Comment 26 jean-pierre.hoehmann 2015-08-05 13:03:25 UTC
Any chance this will ever get fixed? I used to love KDE 8and i really still do), but right now it seems throwing it out is my only option :(
Comment 27 Simon Persson 2015-08-09 04:51:58 UTC
(In reply to jean-pierre.hoehmann from comment #26)
> Any chance this will ever get fixed? I used to love KDE 8and i really still
> do), but right now it seems throwing it out is my only option :(

When I first tried Plasma 5 I almost immideately experienced this bug and decided to switch back to 4.X... if not even such a basic thing works then I thought it was not worth my time yet. When later I tried switching and it still was not fixed I decided to fix it, took half a day. The fix is linked in comment 18 here. Despite sending reminder to mailing list about it last month there still has been zero replies from the maintainers.

For now, to work around, just open the "kdeglobals" file under the "~/.config" folder and erase all the shortcut entries there. That gets you back to standard shortcuts without conflicts.
Comment 28 Christoph 2015-08-10 11:07:20 UTC
Please fix this ! Its damn annoying
Comment 29 lupus_in_fabula 2015-08-19 07:39:17 UTC
I agree with lots of you: this bug is bothering.
Anyway, Kate is the only application where I found this bug even though I still think it's global.
@Craig it crashes to me too. When it happens the cursor gets invisible for at least 10 seconds, then a crash with all the trimmings. The backtrace is the same of yours.
Comment 30 johnsc301 2015-08-23 14:17:02 UTC
I just got this bug on Dolphin after upgrading it to 15.08.0
I first experienced this on Kate after upgrading to Plasma 5.3
Dolphin was fine until the upgrade to the new dolphin
Comment 31 johnsc301 2015-08-24 23:19:38 UTC
OK So, I have an obnoxious workaround:
In Dolphin for eg., go to the shortcuts settings.
You have a list of shortcuts, take note of "Shortcut" and "Alternate"
Click on a shortcut and set it to None, and click on another shortcut.
You'll notice that the Alternate shortcut is not filled with what was in the Shortcut section.

Take Dolphin and "Copy" for example. The standard shortcut is Ctrl+C
After the upgrade to Plasma 5, I saw some shortcuts had the shortcut repeated in both Shortcut and in Alternate.
However, I was still getting errors despite getting rid of the duplicates
I clicked on the standard Shortcut for Copy in Dolphin and set it to None
When I clicked on the next shortcut, the Copy Alternate becomes Ctrl+C
I set that to none and Shortcut to Ctrl+C, and now, the Ambiguity error is gone.
Comment 32 johnsc301 2015-08-24 23:51:04 UTC
Here is a video of me demonstrating my workaround:
Comment 33 lupus_in_fabula 2015-08-27 07:33:07 UTC
At first I thought eliminating those ambiguities manually would have been useful; as a matter of fact, Kate didn't work anyway after its restart. Editing .config/kdeglobals worked for me
Comment 34 Simon Persson 2015-09-01 03:08:29 UTC
*** Bug 345542 has been marked as a duplicate of this bug. ***
Comment 35 Simon Persson 2015-09-07 02:28:39 UTC
Git commit 3afd24f55dcba2cd389c3760d1661dabb9251d14 by Simon Persson.
Committed on 07/09/2015 at 02:05.
Pushed by persson into branch 'Plasma/5.4'.

Fix KF5 port regression in kcm_standard_actions

The KShortcutsEditor reads the property "defaultShortcuts" from the
assigned QAction. This commit changes KCM code to correctly fill in
QActions with default "hardcoded" shortcuts.
Previously it was appending the defaults to the list of active
shortcuts, but that just creates shortcut lists that grow longer and
longer every time user saves settings in this KCM.
FIXED-IN: 5.4.1
REVIEW: 123828

M  +2    -3    kcms/standard_actions/standard_actions_module.cpp

Comment 36 jean-pierre.hoehmann 2015-09-07 12:37:54 UTC
In reply to Simon Persson from comment #27)

Sorry for not replying to our comment, I was really busy and forgot about this. I had seen your patch, but I had decided, that "if not even such a basic thing works then it was not worth my time yet." However, I am back in KDE by now (and using your patch), so I just wanted to leave a quick thanks for fixing this : )
Comment 37 Marcel 2015-09-09 17:21:30 UTC
Hell yeah, thanks for fixing this! :)
Comment 38 Janek Bevendorff 2015-10-02 15:30:55 UTC
Short question: the message above says that this issue is fixed in 5.4.1 which at least for me isn't true. Was the patch just too late and will be in 5.4.2 or did it somehow not fix the issue on my system?
Comment 39 jean-pierre.hoehmann 2015-10-02 19:40:03 UTC
I can confirm, that the fix is in 5.4.1 and works for me.
Comment 40 Janek Bevendorff 2015-10-02 23:39:51 UTC
Strange because I still have to remove all the duplicate shortcuts in kdeglobals after changing them from systemsettings. After I do that, it works fine except for Ctrl+V which is still ambiguous in Kate even if I delete the whole [Shortcuts] section.
The issue is 100% reproducible.
Comment 41 jean-pierre.hoehmann 2015-10-04 10:12:59 UTC
Do you need to delete the duplicates everytime or only once? I do not know if the fix will delete the duplicates that already exist.
Comment 42 sleepywitti 2015-10-04 14:51:31 UTC
The bug does still exist in Arch Linux which uses unpatched sources of KDE (plasma-desktop-5.4.1.tar.xz). 
When I apply the patch and build the package by myself everything works just fine - thanks a lot for fixing this annoying bug!
Comment 43 Janek Bevendorff 2015-10-04 15:44:03 UTC
I have to delete them every time. And as I said, even when I do, Kate still says that Ctrl+V is ambiguous (Ctrl+C, Ctrl+A etc. all work, though).
Comment 44 Janek Bevendorff 2015-10-04 15:45:09 UTC
Oh, I see. So, this is not officially in 5.4.1 but a separate patch? I'm using Chakra Linux which is based on Arch. Will it be in the 5.4.2 tars then?
Comment 45 jean-pierre.hoehmann 2015-10-05 16:57:41 UTC
I am running KDE 5.4.1 on Arch Linux and have uninstalled the patch recently, the fix is definitely in and working here.
Comment 46 johnsc301 2015-10-06 20:29:41 UTC
I am running plasma-desktop 5.4.2 and experience this in Ark.
I don't experience it in Kate, or any other app.

If I open up a compressed find, opening a file with Ark and utilizing Ctrl+F will give me the ambiguous shortcut dialog.
Comment 47 jean-pierre.hoehmann 2015-10-06 21:05:11 UTC
This bug should make all shortcuts ambigous, after changing then once. If you are having problems with specific shortcuts, you should double-check, that the shortcut is not, in fact, ambigous. Note that in some applications (not sure about Ark), the defaults contain ambiguities. For instance the shortcuts 'del' is ambigous in kMail by default (assigned to both 'Delete' and 'Move to trash').
Comment 48 Janek Bevendorff 2015-10-08 17:04:39 UTC
I just tested on 5.4.2. Problem seems to be gone. I still had to resolve an ambiguity for Ctrl+V in Kate, but I could do that via Settings menu->Configure shortcuts. Now it works. In the version before the shortcut stayed ambiguous, no matter what I tried.
Comment 49 johnsc301 2015-10-24 00:47:31 UTC
I just ran into this problem with Kid3. There aren't any ambiguous shortcuts, but I'm getting the popup.
When I do my trick when I set the default to Custom and back to default, the Alternate shortcut becomes the default, showing the ambiguity.
Comment 50 H.H. 2015-10-27 15:40:29 UTC
I had this problem still with Version 5.4.2. I had to delete the shortcuts section in .config/kdeglobals to get rid of this.
Comment 51 johnsc301 2015-10-30 15:48:32 UTC
The solution in Comment 50 worked for me! Thank you
Comment 52 Alexander Adam 2015-10-30 16:06:08 UTC
That are basically two issues here - right?

1. Something is adding cloned shortcuts (two shortcuts for the same thing).
2. The error messages that come up when such a configuration exists. It shouldn't be an issue at all if there is such a situation. The same shortcut for an action should be handled as if it was configured just once.

Or am I totally wrong here?
Comment 53 Syiad 2015-11-02 16:39:21 UTC
I still have the problem on a fresh install of Kubuntu 15.10 with Plasma 5.4.2.

The solution proposed in Comment 50 did not fix it for me. Now inserting via Ctrl+V works, but Ctrl+C and Ctrl+X still give the error message. Are there other legacy config files that I may have to clean up?
Comment 54 Mladen Milinkovic, Max 2015-12-16 00:36:04 UTC
I also am still having a problem for last 10 months.
Have tried all of the proposed patches here, and only that really solves the problem for me is (ugly) one i made and explained in Comment 5.
Does anyone knows what is actually appending those default shortcuts to the list?