Bug 343294 - String with <componentname> word not appear completely
Summary: String with <componentname> word not appear completely
Status: RESOLVED FIXED
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-25 18:41 UTC by André Marcelo Alvarenga
Modified: 2015-02-09 08:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description André Marcelo Alvarenga 2015-01-25 18:41:39 UTC
In www_www.po there are the string:

(...)
<li>Now supports finding ui files in resources (default location: :/kxmlgui5/<componentname>)</li>\n
(...)

but in https://www.kde.org/announcements/kde-frameworks-5.4.0.php, the string is displayed:

Now supports finding ui files in resources (default location: :/kxmlgui5/)

The <componentname> is not displayed.
This also happen with translated pages.

Reproducible: Always
Comment 1 Ingo Malchow 2015-01-25 19:04:38 UTC
This is due to the web engine considering everything between the greater than/less than sign a tag, which should not be visible to the user.
To fix this, you'd need change the tags in the original string from < to &#60; and > to &#62;
However, i am not sure about any possible string freeze for announcements, so i leave this info here for those who know it better than me (most likely albert :P)
Comment 2 Albert Astals Cid 2015-01-25 20:30:33 UTC
SVN commit 1412939 by aacid:

Fix html

CCMAIL: faure@kde.org


 M  +1 -1      kde-frameworks-5.4.0.php  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1412939
Comment 3 Albert Astals Cid 2015-01-25 20:31:38 UTC
I've commited it, it'll make the page untranslated until people fix the translations but 5.4.0 is not that new anymore so i think it's better that it's correct than to make it seem we have more translations.

Also Cc'ed David in hope he'll read it and not repeat the mistake in the future.
Comment 4 David Faure 2015-02-09 08:06:16 UTC
Git commit 9549e7fd738c6b4cb332e0263c4120fbb7a8bffd by David Faure.
Committed on 09/02/2015 at 08:05.
Pushed by dfaure into branch 'frameworks/5.0'.

Fix < and > in pseudo-markdown input, I mean them as literals

M  +1    -1    create_sources_inc

http://commits.kde.org/sysadmin/release-tools/9549e7fd738c6b4cb332e0263c4120fbb7a8bffd