Bug 342710 - api.kde.org: Replace outdated KDE brand with new one
Summary: api.kde.org: Replace outdated KDE brand with new one
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kdoctools
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Documentation Editorial Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-10 20:29 UTC by Jarosław Staniek
Modified: 2015-02-20 00:07 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
80x80 KDE logo image (9.94 KB, image/png)
2015-01-12 21:39 UTC, Allen Winter
Details
New KDE logo image "part of the KDE family" (12.44 KB, image/png)
2015-01-13 14:55 UTC, Allen Winter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jarosław Staniek 2015-01-10 20:29:46 UTC
http://api.kde.org/common/kde_logo.png is used at least by http://api.kde.org/cmake/modules.html. This suggest invalid meaning of what KDE is now...

Reproducible: Always
Comment 1 Allen Winter 2015-01-12 20:10:48 UTC
http://api.kde.org/cmake/modules.html is generated by meinproc4.

It uses the stylesheet in ksgmltools2/customization/kde-web.xsl

not a specific api.kde.org bug nor a specific bug in our web pages.
the bug is in the kde stylesheet.
Comment 2 Albert Astals Cid 2015-01-12 20:43:14 UTC
Right, common/en/kde_logo.png in kdoctools is obviously old :D
Comment 3 Allen Winter 2015-01-12 20:48:52 UTC
I noticed one other thing.

in the generated html you'll see the height and width are set for the kde_logo.png to be 296 x 79.
make sure to change that to the dimensions of the new kde_logo.png

ie. in the generated html you'll see
<img src="../common/kde_logo.png" alt="KDE -         The K Desktop Environment" width="296" height="79" border="0">

and you'll need to adjust that accordingly to the new png
Comment 4 Luigi Toscano 2015-01-12 21:17:19 UTC
I'm not exactly the most skilled with graphics, who can we ping for this?
Comment 5 Jarosław Staniek 2015-01-12 21:22:42 UTC
@Luigi Can't we use the KDE logo from the top of https://techbase.kde.org/Development/Tutorials/API_Documentation and use the black letters for the header text ("modules - cmake" on the first page) ?
Comment 6 Albert Astals Cid 2015-01-12 21:23:10 UTC
Just use something from https://www.kde.org/stuff/clipart.php ?
Comment 7 Allen Winter 2015-01-12 21:37:52 UTC
I will attach an 80x80 png that was suggested by Nuno
Comment 8 Allen Winter 2015-01-12 21:39:30 UTC
Created attachment 90375 [details]
80x80 KDE logo image

suggested to me by Nuno
Comment 10 Luigi Toscano 2015-01-12 21:45:56 UTC
top-kde.jpg is also used in the main page of api.kde.org...
Comment 11 Albert Astals Cid 2015-01-12 21:48:58 UTC
Aren't they a bit small for a website though?
Comment 12 Allen Winter 2015-01-13 14:55:39 UTC
Created attachment 90388 [details]
New KDE logo image "part of the KDE family"
Comment 13 Allen Winter 2015-01-13 14:56:37 UTC
the PNG I just attached is also close to dimensions of the old one too.  I like this better.
found on the KDE clipart page. https://www.kde.org/stuff/clipart.php
Comment 14 Luigi Toscano 2015-01-14 01:02:28 UTC
Few questions:
- where is the source document for cmake, just to test also that specific case?
- are you (people in CC) fine with also backporting this to kdelibs (KDE/4.14)? mainproc4 is kdelibs, not kdoctools.
Comment 15 Albert Astals Cid 2015-01-14 20:50:24 UTC
meinproc4 backport it's fine, the logo is obviously wrong.

No idea about the other question.
Comment 16 Allen Winter 2015-01-14 21:36:38 UTC
#generate the docbook from our cmake modules
cmake -DCMAKE_MODULE_PATH=/path/to/kdelibs/cmake/modules --help-custom-modules cmake.docbook

#generate the html from the docbook
meinproc4 --stylesheet /usr/share/apps/ksgmltools2/customization/kde-web.xsl -o cmake.html cmake.docbook
Comment 17 Luigi Toscano 2015-01-15 22:34:45 UTC
Please comment here, there are some open questions: https://git.reviewboard.kde.org/r/122080/

Side note about this specific case: since cmake 3.0, the generation method must change, as the --help-custom-modules option is not available and the documentation is rst-based.
Comment 18 Luigi Toscano 2015-02-19 23:56:48 UTC
Git commit 22bfb13996bbf29c2001dcf0c16781e0e70cd367 by Luigi Toscano.
Committed on 19/02/2015 at 23:42.
Pushed by ltoscano into branch 'master'.

More up-to-date image for web pages

"Part of KDE family" logo from https://www.kde.org/stuff/clipart.php,
by Philipp Schmieder:
"I am the original author of those graphics and you may use them
unter the LGPL version 2.1, or version 3 or later versions approved
by the membership of KDE e.V. :-)"
REVIEW: 122080

A  +-    --    common/en/part_of_the_kde_family_horizontal_190.png
M  +2    -2    src/customization/kde-web-navig.xsl

http://commits.kde.org/kdoctools/22bfb13996bbf29c2001dcf0c16781e0e70cd367
Comment 19 Luigi Toscano 2015-02-20 00:07:15 UTC
Git commit fb981a96647f7de61d2095e2738cefc3bb0b9faf by Luigi Toscano.
Committed on 20/02/2015 at 00:07.
Pushed by ltoscano into branch 'KDE/4.14'.

More up-to-date image for web pages

"Part of KDE family" logo from https://www.kde.org/stuff/clipart.php,
by Philipp Schmieder:
"I am the original author of those graphics and you may use them
unter the LGPL version 2.1, or version 3 or later versions approved
by the membership of KDE e.V. :-)"

Backport for kdoctools framework.
REVIEW: 122080

A  +-    --    doc/common/part_of_the_kde_family_horizontal_190.png
M  +2    -2    kdoctools/customization/kde-web-navig.xsl

http://commits.kde.org/kdelibs/fb981a96647f7de61d2095e2738cefc3bb0b9faf