Bug 342622 - Gwenview crashes in Video/Movie Folder
Summary: Gwenview crashes in Video/Movie Folder
Status: RESOLVED DUPLICATE of bug 340373
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-01-08 11:24 UTC by Unknown
Modified: 2015-01-14 14:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2015-01-08 11:24:54 UTC
Application: gwenview (4.14.0 pre)
KDE Platform Version: 4.14.3
Qt Version: 4.8.6
Operating System: Linux 3.16.7-7-desktop x86_64
Distribution: "openSUSE 13.2 (Harlequin) (x86_64)"

-- Information about the crash:
I opened Gwenview and browsed to my video-directory. In this directory are 5 movies - 2 mkv and 3 avi videos.

Everytime i opened this directory Gwenview crashed.

My File-Browser Dolphin can open this folder without any problems.

I am using openSUSE 13.2 x64 with KDE 4.14.3 and Linux-Kernel 3.16.7

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff65a7a1880 (LWP 32519))]

Thread 2 (Thread 0x7ff64270a700 (LWP 32520)):
#0  0x00007ff6572653cd in poll () from /lib64/libc.so.6
#1  0x00007ff652da6be4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ff652da6cec in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ff6596130de in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007ff6595e4e6f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007ff6595e5165 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007ff6594e20bf in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007ff6595c6783 in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007ff6594e479f in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007ff6536e00a4 in start_thread () from /lib64/libpthread.so.0
#10 0x00007ff65726d7fd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7ff65a7a1880 (LWP 32519)):
[KCrash Handler]
#5  0x00007ff6571bd187 in raise () from /lib64/libc.so.6
#6  0x00007ff6571be538 in abort () from /lib64/libc.so.6
#7  0x00007ff6571fb0c4 in __libc_message () from /lib64/libc.so.6
#8  0x00007ff65720092e in malloc_printerr () from /lib64/libc.so.6
#9  0x00007ff657201636 in _int_free () from /lib64/libc.so.6
#10 0x00007ff65620b197 in Exiv2::RiffVideo::infoTagsHandler() () from /usr/lib64/libexiv2.so.13
#11 0x00007ff656210025 in Exiv2::RiffVideo::decodeBlock() () from /usr/lib64/libexiv2.so.13
#12 0x00007ff65620fc78 in Exiv2::RiffVideo::tagDecoder(Exiv2::DataBuf&, unsigned long) () from /usr/lib64/libexiv2.so.13
#13 0x00007ff656210025 in Exiv2::RiffVideo::decodeBlock() () from /usr/lib64/libexiv2.so.13
#14 0x00007ff656210398 in Exiv2::RiffVideo::readMetadata() () from /usr/lib64/libexiv2.so.13
#15 0x00007ff65a0e08c0 in Gwenview::Exiv2ImageLoader::load(QByteArray const&) () from /usr/lib64/libgwenviewlib.so.4
#16 0x00007ff65a11f6c6 in ?? () from /usr/lib64/libgwenviewlib.so.4
#17 0x00007ff65a11ea1b in Gwenview::TimeUtils::dateTimeForFileItem(KFileItem const&, Gwenview::TimeUtils::CachePolicy) () from /usr/lib64/libgwenviewlib.so.4
#18 0x00007ff65a1128f9 in Gwenview::PreviewItemDelegate::paint(QPainter*, QStyleOptionViewItem const&, QModelIndex const&) const () from /usr/lib64/libgwenviewlib.so.4
#19 0x00007ff6583f47b1 in QListView::paintEvent(QPaintEvent*) () from /usr/lib64/libQtGui.so.4
#20 0x00007ff657f2d9f0 in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#21 0x00007ff6582ca5ee in QFrame::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#22 0x00007ff6583d9e13 in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib64/libQtGui.so.4
#23 0x00007ff6595e6416 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#24 0x00007ff657ede74c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#25 0x00007ff657ee4cad in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#26 0x00007ff658bf6baa in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#27 0x00007ff6595e62ad in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#28 0x00007ff657f28111 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#29 0x00007ff657f28b40 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#30 0x00007ff657f27ccc in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#31 0x00007ff657f28b40 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#32 0x00007ff657f289af in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#33 0x00007ff657f27ccc in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#34 0x00007ff657f28b40 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#35 0x00007ff657f27ccc in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#36 0x00007ff657f28b40 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#37 0x00007ff657f27ccc in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#38 0x00007ff657f28b40 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#39 0x00007ff657f27ccc in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#40 0x00007ff657f28b40 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#41 0x00007ff657f27ccc in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/libQtGui.so.4
#42 0x00007ff6580e6cce in ?? () from /usr/lib64/libQtGui.so.4
#43 0x00007ff657f1d5c0 in QWidgetPrivate::syncBackingStore() () from /usr/lib64/libQtGui.so.4
#44 0x00007ff657f2d56a in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#45 0x00007ff6582e30b3 in QMainWindow::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#46 0x00007ff658ce2459 in KXmlGuiWindow::event(QEvent*) () from /usr/lib64/libkdeui.so.5
#47 0x00007ff657ede76c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#48 0x00007ff657ee4cad in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#49 0x00007ff658bf6baa in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#50 0x00007ff6595e62ad in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#51 0x00007ff6595e957d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#52 0x00007ff6596138fe in ?? () from /usr/lib64/libQtCore.so.4
#53 0x00007ff652da6a04 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#54 0x00007ff652da6c48 in ?? () from /usr/lib64/libglib-2.0.so.0
#55 0x00007ff652da6cec in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#56 0x00007ff6596130be in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#57 0x00007ff657f7b676 in ?? () from /usr/lib64/libQtGui.so.4
#58 0x00007ff6595e4e6f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#59 0x00007ff6595e5165 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#60 0x00007ff6595ea5b9 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#61 0x0000000000429ded in ?? ()
#62 0x00007ff6571a9b05 in __libc_start_main () from /lib64/libc.so.6
#63 0x000000000042a092 in _start ()

Possible duplicates by query: bug 342604, bug 342030, bug 342000, bug 341554, bug 341504.

Reported using DrKonqi
Comment 1 Christoph Feck 2015-01-14 14:28:33 UTC
This is the same libexiv2 crash as was reported for digikam.

*** This bug has been marked as a duplicate of bug 340373 ***