Bug 342548 - Okular hang up while printing pdf with state "rendering completed"
Summary: Okular hang up while printing pdf with state "rendering completed"
Status: RESOLVED UPSTREAM
Alias: None
Product: okular
Classification: Applications
Component: PDF backend (show other bugs)
Version: 0.17.5
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-06 13:12 UTC by PeterG
Modified: 2015-08-11 22:51 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Monthly statement Okular printout hang up. (142.49 KB, application/pdf)
2015-01-06 13:12 UTC, PeterG
Details

Note You need to log in before you can comment on or make changes to this bug.
Description PeterG 2015-01-06 13:12:47 UTC
Created attachment 90257 [details]
Monthly statement Okular printout hang up.

Until december 2014 I could print my monthly statemets without any problems.
From there Okular (or who else?) hang up.
CUPS printer state shows:
"epsondec07c        Epson Stylus SX610FW - CUPS+Gutenprint v5.2.9    Beschäftigt - "Rendering completed" "
Job state says:
" ...... verarbeitet seit
                 Sun Dec 14 14:01:30 2014 
                 "Rendering completed"   "
All other (PDF-) documents are printed well.
I tried this on Suse12.3, Okular 016.5 and Suse 13.1 with Okular 017.5.
I searched for a workaround and found evince printing the statement very well.
Attached is the statement changed with a PDF-Editor to hide sensitive data.
Don't mind about the comments within the document. They were inserted from the PDF-Editor.
The print behavior of the original and the worked file is the same.
Comment 1 bunu 2015-01-06 21:46:41 UTC
[I am a GCI student]

At the moment I have no printer to test this. Could you, please, inform if you are still able to print older statements. Note that the okular version you use is quite old and this issue might be solved by now.
Comment 2 Albert Astals Cid 2015-01-06 21:54:58 UTC
Peter: Can you print preview it?
Comment 3 PeterG 2015-01-10 14:38:13 UTC
bunu: As I said, older statements, same bank, prntout is OK.
OpenSUSE offers no later verison in its official repo. I would ensure to use official software only.
Albert: Preview is empty.
Also the PDF-Option "Rasterung erzwingen" - I think that is "print as graphic" - does not work.
Comment 4 Albert Astals Cid 2015-01-10 15:56:32 UTC
does pdftops and opening the resulting ps with gs work?
Comment 5 PeterG 2015-01-13 09:20:05 UTC
(In reply to Albert Astals Cid from comment #4)
> does pdftops and opening the resulting ps with gs work?

Could you give me more information about this? I'm sorry I'm not familiar with all the abbreviations.
Thank you.
Comment 6 Jonathan Verner 2015-01-13 18:55:37 UTC
pdftops is a command line program to convert pdf documents to the PostScript file format. 
Using it is easy:

  1. open a terminal
  2. cd to the directory with the pdf file
  3. enter pdftops your_file.pdf

This should create a new file named 'your_file.ps'. Then you can try viewing it with 
the gs program. This is a  commandline program (ghostscript) for working with post script
files. You can run it in a terminal using

  gs your_file.ps

(Note that it can also work with pdf files).
This should open a window with the first page of your file. Pressing enter in the terminal
should go through the pages and quit, after reaching the last page. Or you can stop it
using Ctrl-C.
Comment 7 PeterG 2015-01-14 15:38:54 UTC
Thanks for the perfect hints.
I did ->
pdftops KA_20141208-1_public.pdf
Syntax Warning: FoFiType1::parse a line has more than 255 characters, we don't support this

This warning appears about 100 to 150 times.
The ".ps"-file has ben created.
After entering -> gs KA_20141208-1_public.ps
a window came up, flashed 1 second and then disappeared.
The terminal output was:
GPL Ghostscript 9.07 (2013-02-14)
Copyright (C) 2012 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Loading NimbusSanL-Bold font from /usr/share/ghostscript/9.06/Resource/Font/NimbusSanL-Bold... 3461368 2075877 23109360 20842461 1 done.
Error: /undefined in e657865630ad9d66f633b846a989b9974b0179fc6cc445bc1325eb8f274dd24a5
Operand stack:
   --dict:8/12(L)--   --nostringval--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1894   1   3   %oparray_pop   1893   1   3   %oparray_pop   1877   1   3   %oparray_pop   1771   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--
Dictionary stack:
   --dict:1159/1684(ro)(G)--   --dict:0/20(G)--   --dict:78/200(L)--   --dict:69/75(L)--
Current allocation mode is local
Current file position is 4306645
GPL Ghostscript 9.07: Unrecoverable error, exit code 1
Comment 8 Albert Astals Cid 2015-01-14 21:20:50 UTC
That means it's a bug of poppler the library we use for pdf handling please report a bug upstream at https://bugs.freedesktop.org/
Comment 9 David Young 2015-08-11 09:55:51 UTC
I got similar problem and my pdf does not give syntax error in gs. 

this command hang up over 10 minutes to continue. 

okular --print katakana_chinese.pdf&  

convert it to ps, there is no syntax error. 

->  pdftops katakana_chinese.pdf                                                                                                  (resume⚡)
 10050 + 17:45:20 + ~/org/books/Japanese 
->  gs katakana_chinese.ps                                                                                                        (resume⚡)
GPL Ghostscript 9.16 (2015-03-30)
Copyright (C) 2015 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
>>showpage, press <return> to continue<<

>>showpage, press <return> to continue<<

>>showpage, press <return> to continue<<

GS>

 10051 + 17:54:19 + ~/org/books/Japanese 
->  okular -v                                                                                                                                                    (resume⚡)
Qt: 4.8.6
KDE Development Platform: 4.14.9
Okular: 0.22.0
 10052 + 17:54:29 + ~/org/books/Japanese 
->  uname -a                                                                                                                                                     (resume⚡)
Linux localhost.localdomain 4.1.2-200.fc22.x86_64 #1 SMP Wed Jul 15 20:12:12 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
 10053 + 17:54:31 + ~/org/books/Japanese 
->
Comment 10 Albert Astals Cid 2015-08-11 22:51:19 UTC
Since your bug is not this bug as you very well said, why are you commenting in this bug instead of opening a new one?