Bug 342329 - KMail crashes after restart of IMAP account
Summary: KMail crashes after restart of IMAP account
Status: RESOLVED DUPLICATE of bug 340014
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-12-30 10:10 UTC by Abyss
Modified: 2017-01-20 21:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Abyss 2014-12-30 10:10:39 UTC
Application: kmail (4.14.3)
KDE Platform Version: 4.14.3
Qt Version: 4.8.6
Operating System: Linux 3.17.7-300.fc21.x86_64 x86_64
Distribution: "Fedora release 21 (Twenty One)"

-- Information about the crash:
- What I was doing when the application crashed:
The KMail received some errors and was unable to open messages anymore, so I go to Settings -> Accounts -> Restart.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fecc093f900 (LWP 27415))]

Thread 4 (Thread 0x7fec4d5a4700 (LWP 27418)):
#0  0x00007fecbbd0f590 in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fecb2388093 in JSC::BlockAllocator::blockFreeingThreadMain() () at /lib64/libQtWebKit.so.4
#2  0x00007fecb268d636 in WTF::wtfThreadEntryPoint(void*) () at /lib64/libQtWebKit.so.4
#3  0x00007fecbbd0a52a in start_thread (arg=0x7fec4d5a4700) at pthread_create.c:310
#4  0x00007fecba2d377d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fec4c954700 (LWP 27419)):
#0  0x00007fecba2c81dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fecac4a7e24 in g_main_context_iterate (priority=2147483647, n_fds=1, fds=0x7fec400013e0, timeout=1073, context=0x7fec400009a0) at gmain.c:4076
#2  0x00007fecac4a7e24 in g_main_context_iterate (context=context@entry=0x7fec400009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3776
#3  0x00007fecac4a7f3c in g_main_context_iteration (context=0x7fec400009a0, may_block=1) at gmain.c:3842
#4  0x00007fecbc0d3a3e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#5  0x00007fecbc0a3261 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#6  0x00007fecbc0a35c5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#7  0x00007fecbbf98b59 in QThread::exec() () at /lib64/libQtCore.so.4
#8  0x00007fecbbf9b3bf in QThreadPrivate::start(void*) () at /lib64/libQtCore.so.4
#9  0x00007fecbbd0a52a in start_thread (arg=0x7fec4c954700) at pthread_create.c:310
#10 0x00007fecba2d377d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fec3decd700 (LWP 28736)):
#0  0x00007fecbbd0f590 in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fecbefca45a in QTWTF::TCMalloc_PageHeap::scavengerThread() () at /lib64/libQtScript.so.4
#2  0x00007fecbefca489 in  () at /lib64/libQtScript.so.4
#3  0x00007fecbbd0a52a in start_thread (arg=0x7fec3decd700) at pthread_create.c:310
#4  0x00007fecba2d377d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fecc093f900 (LWP 27415)):
[KCrash Handler]
#5  0x00007fecbbfe0dd8 in QString::operator==(QString const&) const () at /lib64/libQtCore.so.4
#6  0x00007fecc04be6ec in KStatusNotifierItem::setToolTipSubTitle(QString const&) () at /lib64/libkdeui.so.5
#7  0x00007fecbf66fbfe in KMail::KMSystemTray::unreadMail(QAbstractItemModel const*, QModelIndex const&) () at /lib64/libkmailprivate.so.4
#8  0x00007fecbf66fadd in KMail::KMSystemTray::unreadMail(QAbstractItemModel const*, QModelIndex const&) () at /lib64/libkmailprivate.so.4
#9  0x00007fecbf66fde5 in KMail::KMSystemTray::initListOfCollection() () at /lib64/libkmailprivate.so.4
#10 0x00007fecbf678f2d in KMKernel::toggleSystemTray() () at /lib64/libkmailprivate.so.4
#11 0x00007fecbf6abadf in KMMainWidget::readConfig() () at /lib64/libkmailprivate.so.4
#12 0x00007fecbf6abc09 in KMMainWidget::slotConfigChanged() () at /lib64/libkmailprivate.so.4
#13 0x00007fecbf79611a in KMMainWidget::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () at /lib64/libkmailprivate.so.4
#14 0x00007fecbc0b925c in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /lib64/libQtCore.so.4
#15 0x00007fecbf79584d in KMKernel::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () at /lib64/libkmailprivate.so.4
#16 0x00007fecbc0b925c in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /lib64/libQtCore.so.4
#17 0x00007fecbc0b925c in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /lib64/libQtCore.so.4
#18 0x00007fecc02ec0e8 in KDialog::slotButtonClicked(int) () at /lib64/libkdeui.so.5
#19 0x00007fecc02edd1f in KDialog::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) [clone .part.56] () at /lib64/libkdeui.so.5
#20 0x00007fecbc0b925c in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /lib64/libQtCore.so.4
#21 0x00007fecbc0c0e1e in QSignalMapper::mapped(int) () at /lib64/libQtCore.so.4
#22 0x00007fecbc0c0fa6 in QSignalMapper::map(QObject*) () at /lib64/libQtCore.so.4
#23 0x00007fecbc0b925c in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /lib64/libQtCore.so.4
#24 0x00007fecbb86c252 in QAbstractButton::clicked(bool) () at /lib64/libQtGui.so.4
#25 0x00007fecbb5ac363 in QAbstractButtonPrivate::emitClicked() () at /lib64/libQtGui.so.4
#26 0x00007fecbb5ad7a4 in QAbstractButtonPrivate::click() () at /lib64/libQtGui.so.4
#27 0x00007fecbb5ad8b4 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () at /lib64/libQtGui.so.4
#28 0x00007fecbb231118 in QWidget::event(QEvent*) () at /lib64/libQtGui.so.4
#29 0x00007fecbb1ddefc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQtGui.so.4
#30 0x00007fecbb1e4abf in QApplication::notify(QObject*, QEvent*) () at /lib64/libQtGui.so.4
#31 0x00007fecc03939ea in KApplication::notify(QObject*, QEvent*) () at /lib64/libkdeui.so.5
#32 0x00007fecbc0a470d in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /lib64/libQtCore.so.4
#33 0x00007fecbb1e411f in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () at /lib64/libQtGui.so.4
#34 0x00007fecbb25a532 in QETWidget::translateMouseEvent(_XEvent const*) () at /lib64/libQtGui.so.4
#35 0x00007fecbb258f2c in QApplication::x11ProcessEvent(_XEvent*) () at /lib64/libQtGui.so.4
#36 0x00007fecbb280fb4 in x11EventSourceDispatch(_GSource*, int (*)(void*), void*) () at /lib64/libQtGui.so.4
#37 0x00007fecac4a7aeb in g_main_context_dispatch (context=0x16d49e0) at gmain.c:3111
#38 0x00007fecac4a7aeb in g_main_context_dispatch (context=context@entry=0x16d49e0) at gmain.c:3710
#39 0x00007fecac4a7e88 in g_main_context_iterate (context=context@entry=0x16d49e0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3781
#40 0x00007fecac4a7f3c in g_main_context_iteration (context=0x16d49e0, may_block=1) at gmain.c:3842
#41 0x00007fecbc0d3a1e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#42 0x00007fecbb281136 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtGui.so.4
#43 0x00007fecbc0a3261 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#44 0x00007fecbc0a35c5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#45 0x00007fecbc0a8ca9 in QCoreApplication::exec() () at /lib64/libQtCore.so.4
#46 0x0000000000402ef2 in main ()

Possible duplicates by query: bug 341938, bug 340014.

Reported using DrKonqi
Comment 1 James W 2014-12-30 23:25:46 UTC
Hi there,
I cannot reproduce this with KMail 4.14.3. Do you remember what the Kmail errors were?

(note: I'm a Google Code-in student)
Comment 2 Myriam Schweingruber 2015-01-02 12:00:54 UTC
Also, installing the debug packages for KMail and its dependencies would be a good idea here, your backtrace lacks this information. See also https://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports for more information
Comment 3 Abyss 2015-02-09 05:54:29 UTC
I have switched to the OpenSuse Tumbleweed and KMail works here much better. I can't reproduce the problem anymore.
Comment 4 Denis Kurz 2017-01-20 21:47:42 UTC

*** This bug has been marked as a duplicate of bug 340014 ***