Bug 341408 - ark cant open libreoffice files on libreoffoce, instead it show as a compressed file
Summary: ark cant open libreoffice files on libreoffoce, instead it show as a compress...
Status: RESOLVED DUPLICATE of bug 179066
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: 2.19
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-29 15:44 UTC by zezadas
Modified: 2014-12-01 08:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zezadas 2014-11-29 15:44:57 UTC
ark cant open libreoffice, instead open the doc as a compressed archive

Reproducible: Always

Steps to Reproduce:
1.open rar
2.open docx or xlsx
3. it open has a compressed archive showing the xml and related files


Expected Results:  
open file on libreoffice, since it works when uncompressed
Comment 1 Christoph Feck 2014-11-29 20:11:53 UTC
Can you please be more specific about "open docx or xlsx"? How do you open those (i.e. where do you click, or what do you enter on the command line? If you really use "ark" to open those files, it is expected they are shown as archives, because they _are_ archives.
Comment 2 Arjun AK 2014-11-30 12:46:24 UTC
Maybe he meant he can't preview docx files using ark. When you click on odt files, they are opened by okular whereas when you click on docx files, they get opened as archives.
Comment 3 Christoph Feck 2014-11-30 14:06:25 UTC
Should be fixed with commit for bug 179066 (in version 14.12 to be released next month).
Comment 4 zezadas 2014-11-30 20:42:16 UTC
Sorry, I meant preview, I have a rar file with some office doc's and opening that rar with ark when I try to open that docs, they open in another ark, I was expecting that they open in office.
Comment 5 Arjun AK 2014-12-01 08:39:55 UTC

*** This bug has been marked as a duplicate of bug 179066 ***