Bug 341395 - Gwenview crashed when closing programme
Summary: Gwenview crashed when closing programme
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-11-29 08:15 UTC by kde12345
Modified: 2014-11-29 12:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kde12345 2014-11-29 08:15:53 UTC
Application: gwenview (4.14.0 pre)
KDE Platform Version: 4.14.3
Qt Version: 4.8.6
Operating System: Linux 3.16.6-2-desktop x86_64
Distribution: "openSUSE 13.2 (Harlequin) (x86_64)"

-- Information about the crash:
Gwenview chrashes everytime, when i close the programme. It only chrasches, when a picture was loaded. If I start Gwenview without loading a picture, it crasches not.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2a4bccb880 (LWP 2788))]

Thread 2 (Thread 0x7f2a339d5700 (LWP 2789)):
#0  0x00007f2a4431b904 in g_mutex_unlock () at /usr/lib64/libglib-2.0.so.0
#1  0x00007f2a442d9280 in g_main_context_prepare () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f2a442d9b03 in  () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f2a442d9cec in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#4  0x00007f2a4ab460de in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#5  0x00007f2a4ab17e6f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#6  0x00007f2a4ab18165 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#7  0x00007f2a4aa150bf in QThread::exec() () at /usr/lib64/libQtCore.so.4
#8  0x00007f2a4aaf9783 in  () at /usr/lib64/libQtCore.so.4
#9  0x00007f2a4aa1779f in  () at /usr/lib64/libQtCore.so.4
#10 0x00007f2a44c130a4 in start_thread () at /lib64/libpthread.so.0
#11 0x00007f2a487a07fd in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f2a4bccb880 (LWP 2788)):
[KCrash Handler]
#5  0x00007f2a495ffd29 in QRasterWindowSurface::~QRasterWindowSurface() () at /usr/lib64/libQtGui.so.4
#6  0x00007f2a495ffda9 in QRasterWindowSurface::~QRasterWindowSurface() () at /usr/lib64/libQtGui.so.4
#7  0x00007f2a4961807c in  () at /usr/lib64/libQtGui.so.4
#8  0x00007f2a49454709 in  () at /usr/lib64/libQtGui.so.4
#9  0x00007f2a494548a9 in QWidgetPrivate::deleteExtra() () at /usr/lib64/libQtGui.so.4
#10 0x00007f2a49454abd in QWidgetPrivate::~QWidgetPrivate() () at /usr/lib64/libQtGui.so.4
#11 0x00007f2a49454d49 in QWidgetPrivate::~QWidgetPrivate() () at /usr/lib64/libQtGui.so.4
#12 0x00007f2a4ab320b5 in QObject::~QObject() () at /usr/lib64/libQtCore.so.4
#13 0x00007f2a4945d4cc in QWidget::~QWidget() () at /usr/lib64/libQtGui.so.4
#14 0x00007f2a4945d749 in QWidget::~QWidget() () at /usr/lib64/libQtGui.so.4
#15 0x00007f2a499a8045 in  () at /usr/lib64/libQtGui.so.4
#16 0x00007f2a486f2bf9 in __run_exit_handlers () at /lib64/libc.so.6
#17 0x00007f2a486f2c45 in  () at /lib64/libc.so.6
#18 0x00007f2a486dcb0c in __libc_start_main () at /lib64/libc.so.6
#19 0x000000000042a092 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2014-11-29 12:42:31 UTC
Which widget style are you using? Oxygen-transparent?

*** This bug has been marked as a duplicate of bug 261539 ***