Bug 341274 - Digikam crash on startup
Summary: Digikam crash on startup
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Metadata-Video (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-11-26 05:16 UTC by clhancock
Modified: 2018-02-28 12:37 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description clhancock 2014-11-26 05:16:01 UTC
Application: digikam (4.6.0)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.14.25-1-lts x86_64
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:
opened Firefox, opened Digikam. Running in Cinnamon. Can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Aborted
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc2785d6a00 (LWP 17231))]

Thread 4 (Thread 0x7fc25136d700 (LWP 17233)):
#0  0x00007fc2714457bd in poll () from /usr/lib/libc.so.6
#1  0x00007fc256b1170c in ?? () from /usr/lib/libusb-1.0.so.0
#2  0x00007fc26f674314 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007fc27144e5bd in clone () from /usr/lib/libc.so.6

Thread 3 (Thread 0x7fc247b7a700 (LWP 17234)):
[KCrash Handler]
#5  0x00007fc271399a97 in raise () from /usr/lib/libc.so.6
#6  0x00007fc27139ae6a in abort () from /usr/lib/libc.so.6
#7  0x00007fc2713d9623 in __libc_message () from /usr/lib/libc.so.6
#8  0x00007fc2713dea9e in malloc_printerr () from /usr/lib/libc.so.6
#9  0x00007fc2713df25b in _int_free () from /usr/lib/libc.so.6
#10 0x00007fc26f2e5b1d in Exiv2::RiffVideo::infoTagsHandler() () from /usr/lib/libexiv2.so.13
#11 0x00007fc26f2edf2f in Exiv2::RiffVideo::decodeBlock() () from /usr/lib/libexiv2.so.13
#12 0x00007fc26f2edb78 in Exiv2::RiffVideo::tagDecoder(Exiv2::DataBuf&, unsigned long) () from /usr/lib/libexiv2.so.13
#13 0x00007fc26f2edf2f in Exiv2::RiffVideo::decodeBlock() () from /usr/lib/libexiv2.so.13
#14 0x00007fc26f2ee320 in Exiv2::RiffVideo::readMetadata() () from /usr/lib/libexiv2.so.13
#15 0x00007fc2769946bd in KExiv2Iface::KExiv2::load(QString const&) const () from /usr/lib/libkexiv2.so.11
#16 0x00007fc276280186 in Digikam::DMetadata::load(QString const&) const () from /usr/lib/libdigikamcore.so.4.6.0
#17 0x00007fc275ca2db7 in Digikam::ImageScanner::loadFromDisk() () from /usr/lib/libdigikamdatabase.so.4.6.0
#18 0x00007fc275ca2fa0 in Digikam::ImageScanner::newFile(int) () from /usr/lib/libdigikamdatabase.so.4.6.0
#19 0x00007fc275c35506 in Digikam::CollectionScanner::scanNewFile(QFileInfo const&, int) () from /usr/lib/libdigikamdatabase.so.4.6.0
#20 0x00007fc275c38be2 in Digikam::CollectionScanner::scanAlbum(Digikam::CollectionLocation const&, QString const&) () from /usr/lib/libdigikamdatabase.so.4.6.0
#21 0x00007fc275c38a9f in Digikam::CollectionScanner::scanAlbum(Digikam::CollectionLocation const&, QString const&) () from /usr/lib/libdigikamdatabase.so.4.6.0
#22 0x00007fc275c38a9f in Digikam::CollectionScanner::scanAlbum(Digikam::CollectionLocation const&, QString const&) () from /usr/lib/libdigikamdatabase.so.4.6.0
#23 0x00007fc275c38a9f in Digikam::CollectionScanner::scanAlbum(Digikam::CollectionLocation const&, QString const&) () from /usr/lib/libdigikamdatabase.so.4.6.0
#24 0x00007fc275c39433 in Digikam::CollectionScanner::scanAlbumRoot(Digikam::CollectionLocation const&) () from /usr/lib/libdigikamdatabase.so.4.6.0
#25 0x00007fc275c3ac85 in Digikam::CollectionScanner::completeScan() () from /usr/lib/libdigikamdatabase.so.4.6.0
#26 0x00000000005e8b30 in ?? ()
#27 0x00007fc271caa05f in ?? () from /usr/lib/libQtCore.so.4
#28 0x00007fc26f674314 in start_thread () from /usr/lib/libpthread.so.0
#29 0x00007fc27144e5bd in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7fc247379700 (LWP 17235)):
#0  0x00007fc26a735019 in g_mutex_lock () from /usr/lib/libglib-2.0.so.0
#1  0x00007fc26a6efc00 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#2  0x00007fc26a6f0b45 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0x00007fc26a6f0dac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0x00007fc271de3397 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007fc271db2de1 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007fc271db3145 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x00007fc271ca77f9 in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0x00007fc271d936c3 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007fc271caa05f in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007fc26f674314 in start_thread () from /usr/lib/libpthread.so.0
#11 0x00007fc27144e5bd in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7fc2785d6a00 (LWP 17231)):
#0  0x00007fc26f6798cf in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007fc271caa5b6 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007fc271ca9bee in QThread::wait(unsigned long) () from /usr/lib/libQtCore.so.4
#3  0x00000000005e711b in ?? ()
#4  0x00000000005e73e7 in ?? ()
#5  0x00007fc27139c392 in __run_exit_handlers () from /usr/lib/libc.so.6
#6  0x00007fc27139c3e5 in exit () from /usr/lib/libc.so.6
#7  0x00007fc25f3301d4 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#8  0x00007fc273a01d30 in KApplication::xioErrhandler(_XDisplay*) () from /usr/lib/libkdeui.so.5
#9  0x00007fc26fc1799e in _XIOError () from /usr/lib/libX11.so.6
#10 0x00007fc26fc152fd in _XEventsQueued () from /usr/lib/libX11.so.6
#11 0x00007fc26fc06ba0 in XEventsQueued () from /usr/lib/libX11.so.6
#12 0x00007fc272d33f8c in ?? () from /usr/lib/libQtGui.so.4
#13 0x00007fc26a6f0671 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#14 0x00007fc26a6f0c33 in ?? () from /usr/lib/libglib-2.0.so.0
#15 0x00007fc26a6f0dac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#16 0x00007fc271de337d in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#17 0x00007fc272d34526 in ?? () from /usr/lib/libQtGui.so.4
#18 0x00007fc271db2de1 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#19 0x00007fc271db3145 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#20 0x00000000005e4541 in ?? ()
#21 0x0000000000529e57 in ?? ()
#22 0x00007fc271dcd491 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#23 0x00007fc272c90b2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#24 0x00007fc272c97588 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#25 0x00007fc273a032da in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#26 0x00007fc271db428d in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#27 0x00007fc271db7651 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#28 0x00007fc271de3233 in ?? () from /usr/lib/libQtCore.so.4
#29 0x00007fc26a6f0a0d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0x00007fc26a6f0cf8 in ?? () from /usr/lib/libglib-2.0.so.0
#31 0x00007fc26a6f0dac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#32 0x00007fc271de337d in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#33 0x00007fc272d34526 in ?? () from /usr/lib/libQtGui.so.4
#34 0x00007fc271db2de1 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#35 0x00007fc271db3145 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#36 0x00007fc271db86e9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#37 0x0000000000496636 in ?? ()
#38 0x00007fc271386040 in __libc_start_main () from /usr/lib/libc.so.6
#39 0x0000000000498eef in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 331679.

Possible duplicates by query: bug 340373, bug 335816, bug 331679.

Reported using DrKonqi
Comment 1 caulier.gilles 2014-11-26 07:01:39 UTC

*** This bug has been marked as a duplicate of bug 340373 ***
Comment 2 caulier.gilles 2014-12-02 21:27:44 UTC
*** Bug 341504 has been marked as a duplicate of this bug. ***
Comment 3 daniel köbsch 2014-12-02 21:31:18 UTC
ok, additional comment

i solved this – no, found an workaround:
i moved ALL *.{avi|mov|xcf|xmb} out of the directory and now digikam works.
i guess it is some foul movie, but not shure.

maybe that helps
Comment 4 caulier.gilles 2014-12-02 21:32:47 UTC
yes, it is as Exiv2 GDB backtrace said (RIFF video format)

It's already reported to Exiv2 bugzilla and fixed for next Exiv2 0.25

Gilles Caulier
Comment 5 caulier.gilles 2014-12-04 19:47:34 UTC
*** Bug 341554 has been marked as a duplicate of this bug. ***
Comment 6 caulier.gilles 2014-12-08 12:40:18 UTC
*** Bug 341654 has been marked as a duplicate of this bug. ***
Comment 7 caulier.gilles 2018-02-28 12:37:59 UTC
With 6.0.0, we have now a FFMpeg low level metadata parser based on libav C API
for video files database registration.

The Exiv2 video support is not used anymore as this code is buggous and nobody
sound motivated in Exiv2 to finalize the code.

The original post for this file must be fixed now and video metadata support
with ffmpeg must be enough to populate database entries.

Gilles Caulier