Bug 340911 - kwin crash
Summary: kwin crash
Status: RESOLVED DUPLICATE of bug 340657
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-11-12 22:46 UTC by Peter Federighi
Modified: 2014-11-16 20:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Federighi 2014-11-12 22:46:47 UTC
Application: kwin (4.11.12)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.16.6-2-desktop x86_64
Distribution: "openSUSE 13.2 (Harlequin) (x86_64)"

-- Information about the crash:
I moved the mouse to the upper left corner of the screen which is set to go to present windows.  The only window open at the time was Firefox.  Kwin crashed.

The crash does not seem to be reproducible.

-- Backtrace:
Application: KWin (kwin), signal: Bus error
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6611552800 (LWP 1216))]

Thread 3 (Thread 0x7f65df79c700 (LWP 1223)):
#0  0x00007f660ad4005f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f65f112dbb3 in  () at /usr/lib64/dri/r600_dri.so
#2  0x00007f65f112d3d7 in  () at /usr/lib64/dri/r600_dri.so
#3  0x00007f660ad3c0a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007f6610d6c7fd in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7f65dec3a700 (LWP 1224)):
#0  0x00007f660ad4005f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f660ff6d8cb in  () at /usr/lib64/libQtScript.so.4
#2  0x00007f660ff6d909 in  () at /usr/lib64/libQtScript.so.4
#3  0x00007f660ad3c0a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007f6610d6c7fd in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f6611552800 (LWP 1216)):
[KCrash Handler]
#5  0x00007f6610d0904c in __strncmp_sse2 () at /lib64/libc.so.6
#6  0x00007f660b8db05c in KSharedDataCache::find(QString const&, QByteArray*) const () at /usr/lib64/libkdecore.so.5
#7  0x00007f660fa1f975 in KImageCache::findPixmap(QString const&, QPixmap*) const () at /usr/lib64/libkdeui.so.5
#8  0x00007f660f431d33 in Plasma::Theme::findInCache(QString const&, QPixmap&) () at /usr/lib64/libplasma.so.3
#9  0x00007f660f42dc9d in  () at /usr/lib64/libplasma.so.3
#10 0x00007f660f42e16d in Plasma::Svg::paint(QPainter*, QRectF const&, QString const&) () at /usr/lib64/libplasma.so.3
#11 0x00007f660f3c7d7d in  () at /usr/lib64/libplasma.so.3
#12 0x00007f660f3c8b7b in  () at /usr/lib64/libplasma.so.3
#13 0x00007f660f3c98ab in Plasma::FrameSvg::paintFrame(QPainter*, QPointF const&) () at /usr/lib64/libplasma.so.3
#14 0x00007f6557823eaf in  () at /usr/lib64/kde4/imports/org/kde/plasma/core/libcorebindingsplugin.so
#15 0x00007f660a82aa77 in  () at /usr/lib64/libQtGui.so.4
#16 0x00007f660a82b835 in  () at /usr/lib64/libQtGui.so.4
#17 0x00007f660a82acb5 in  () at /usr/lib64/libQtGui.so.4
#18 0x00007f660a82b835 in  () at /usr/lib64/libQtGui.so.4
#19 0x00007f660a82acb5 in  () at /usr/lib64/libQtGui.so.4
#20 0x00007f660a82b835 in  () at /usr/lib64/libQtGui.so.4
#21 0x00007f660a82acb5 in  () at /usr/lib64/libQtGui.so.4
#22 0x00007f660a82b835 in  () at /usr/lib64/libQtGui.so.4
#23 0x00007f660a82bee6 in  () at /usr/lib64/libQtGui.so.4
#24 0x00007f660a84961e in QGraphicsView::paintEvent(QPaintEvent*) () at /usr/lib64/libQtGui.so.4
#25 0x00007f661034b5bd in QDeclarativeView::paintEvent(QPaintEvent*) () at /usr/lib64/libQtDeclarative.so.4
#26 0x00007f660a29f9f0 in QWidget::event(QEvent*) () at /usr/lib64/libQtGui.so.4
#27 0x00007f660a63c5ee in QFrame::event(QEvent*) () at /usr/lib64/libQtGui.so.4
#28 0x00007f660a848429 in QGraphicsView::viewportEvent(QEvent*) () at /usr/lib64/libQtGui.so.4
#29 0x00007f660b0d4416 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () at /usr/lib64/libQtCore.so.4
#30 0x00007f660a25074c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQtGui.so.4
#31 0x00007f660a256cad in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQtGui.so.4
#32 0x00007f660f9c0bda in KApplication::notify(QObject*, QEvent*) () at /usr/lib64/libkdeui.so.5
#33 0x00007f660b0d42ad in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib64/libQtCore.so.4
#34 0x00007f660a29a111 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () at /usr/lib64/libQtGui.so.4
#35 0x00007f660a29ab40 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () at /usr/lib64/libQtGui.so.4
#36 0x00007f660a299ccc in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () at /usr/lib64/libQtGui.so.4
#37 0x00007f660a458cce in  () at /usr/lib64/libQtGui.so.4
#38 0x00007f660a459045 in  () at /usr/lib64/libQtGui.so.4
#39 0x00007f660a2ba598 in  () at /usr/lib64/libQtGui.so.4
#40 0x00007f660a2c6d56 in QApplication::x11ProcessEvent(_XEvent*) () at /usr/lib64/libQtGui.so.4
#41 0x00007f660a2edf30 in  () at /usr/lib64/libQtGui.so.4
#42 0x00007f660b0d2e6f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#43 0x00007f660b0d3165 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#44 0x00007f660b0d85b9 in QCoreApplication::exec() () at /usr/lib64/libQtCore.so.4
#45 0x00007f66110ad7a3 in kdemain () at /usr/lib64/libkdeinit4_kwin.so
#46 0x00007f6610ca8b05 in __libc_start_main () at /lib64/libc.so.6
#47 0x000000000040075e in _start ()

Reported using DrKonqi
Comment 1 Thomas Lübking 2014-11-12 22:59:35 UTC
"/var" full or ever ran sth. called "bleachbit"?
Comment 2 Christoph Feck 2014-11-16 20:40:31 UTC
Thomas, could be related to openSUSE 13.2 switching to btrfs.

*** This bug has been marked as a duplicate of bug 340657 ***
Comment 3 Thomas Lübking 2014-11-16 20:58:26 UTC
Wow, that's many dupes =)

Do you know how SuSE mounts btrfs on /var?
I've a "rw,noatime,ssd,discard,nospace_cache" partition (root, contains /var, no extra partition) and never experienced this crash so far.