Bug 340901 - oxygen-gtk3-1.4.1 spinner doesn't work with gtk3-3.14.4
Summary: oxygen-gtk3-1.4.1 spinner doesn't work with gtk3-3.14.4
Status: RESOLVED FIXED
Alias: None
Product: Oxygen
Classification: Unclassified
Component: gtk3-engine (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-12 18:24 UTC by Rex Dieter
Modified: 2014-11-14 17:39 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rex Dieter 2014-11-12 18:24:44 UTC
See downstream fedora 21 bug,
https://bugzilla.redhat.com/show_bug.cgi?id=1103496#c60

"After talking to Benjamin some more, the copy of the old Adwaita css spinner that is in oxygen-gtk now doesn't work anymore because it relied on a background rendering hack that is no longer working. "

The suggested (much simpler) css code seems to work as advertised (though it's not using an oxygen style spinner anymore):

@keyframes spin {
  to { -gtk-icon-transform: rotate(1turn);}
}

.spinner {
  background: none;
  -gtk-icon-source: -gtk-icontheme("process-working-symbolic");
}

.spinner:active {
  background: none;
  animation: spin 1s linear infinite;
}

Reproducible: Always
Comment 1 Hugo Pereira Da Costa 2014-11-14 17:39:41 UTC
Git commit 75d1884df6740c268b665935af909a9a1e1ef6be by Hugo Pereira Da Costa.
Committed on 14/11/2014 at 17:37.
Pushed by hpereiradacosta into branch 'gtk3-1.4'.

update spinner code (copied from Adwaita) to have working spinner for gtk+-3.14

M  +20   -108  rc/gtk-spinner.css

http://commits.kde.org/oxygen-gtk/75d1884df6740c268b665935af909a9a1e1ef6be