Bug 340491 - krunner enhancement: let it learn what the user want or prefer commands
Summary: krunner enhancement: let it learn what the user want or prefer commands
Status: RESOLVED DUPLICATE of bug 340283
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: 5.0
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Kai Uwe Broulik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-30 12:10 UTC by Gerion
Modified: 2020-07-08 10:46 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerion 2014-10-30 12:10:21 UTC
I always use krunner to launch programs. Since kde 5, it often breaks my workflow. Let me give two examples:
When I type "pidgin" or "pid" and press Enter immediatly, krunner always select some folder named "pidgin" and open it per dolphin.
When I type "fire" to launch firefox, krunner always select some videofile starting with fire and plays it with mediaplayer xy.

It would be nice, if you implement some kind of learning system, so krunner prefer firefox, when the user type "fire" or even "f".
Or as a probably much more simpler solution: Implement a (choosable?) priority in krunner so programs or commands would be preferred over the other results.

Many thanks!

Reproducible: Always
Comment 1 Alexander Lohnau 2020-07-08 10:46:28 UTC

*** This bug has been marked as a duplicate of bug 340283 ***