Bug 340470 - Unable to filter for opening square brackets: [
Summary: Unable to filter for opening square brackets: [
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: bars: filter (show other bugs)
Version: 4.14.0
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-29 16:51 UTC by Nico Dorn
Modified: 2014-11-09 14:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 14.12


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Dorn 2014-10-29 16:51:06 UTC
Filtering the folder contents with a string that contains an opening square bracket never returns any results. Other brackets (round brackets, face brackets and angle brackets) work fine though.

Reproducible: Always

Steps to Reproduce:
1. Navigate to folder that contains some files which have one or more opening square brackets in its names.
2. Type "[" into the filter bar

Actual Results:  
No file is shown.

Expected Results:  
The files that have an opening square bracket in its name should be shown.
Comment 1 Emmanuel Pescosta 2014-10-31 17:38:07 UTC
Thanks for the bug report!
I can reproduce the problem in Dolphin 4.14.2.
Comment 2 Arjun AK 2014-11-04 14:35:27 UTC
https://git.reviewboard.kde.org/r/120986/
Comment 3 Arjun AK 2014-11-09 14:07:26 UTC
Git commit e28147bf386351f51f9b22626d7e44008769cc9b by Arjun AK.
Committed on 09/11/2014 at 13:50.
Pushed by arjunak into branch 'Applications/14.12'.

Ensure input is a valid regexp before enabling regexp filter mode

Checking whether the input contains '*', '?' or '[' alone will
not do since there can be files with '[' in their name.

REVIEW: 120986
FIXED-IN: 14.12

M  +4    -4    dolphin/src/kitemviews/private/kfileitemmodelfilter.cpp

http://commits.kde.org/kde-baseapps/e28147bf386351f51f9b22626d7e44008769cc9b