Bug 340137 - Implement support for window groups (window tabs) in Breeze
Summary: Implement support for window groups (window tabs) in Breeze
Status: RESOLVED INTENTIONAL
Alias: None
Product: Breeze
Classification: Plasma
Component: window decoration (show other bugs)
Version: 5.2.95
Platform: Archlinux Linux
: NOR wishlist
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on: 343690
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-19 21:54 UTC by Rodrigo Fernandes
Modified: 2021-09-16 19:31 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigo Fernandes 2014-10-19 21:54:56 UTC
Breeze is missing support for window groups.

Reproducible: Always

Steps to Reproduce:
1. Check "Window Behaviour -> Advanced -> Automatically group similar windows"
2. Open a second window to a program (Two Konsoles or two Dolphins, etc) 


Actual Results:  
The window appears seperatly as a normal window.

Expected Results:  
It should instead have appeared as a window tab, along side an the program's existing window.


Additionally "middle click move to group does not work".
Comment 1 Martin Flöser 2014-10-20 06:25:12 UTC
Please do not use breeze at this moment. The recommended window decoration is Oxygen at the time being which supports Window Tabs (see http://blog.martin-graesslin.com/blog/2014/07/why-breeze-is-not-the-default-window-decoration/). The Aurorae version will never support window tabs, while the new KDecoration2 deco will support tabs. Thus this feature request is kind of a wontfix or cantfix as the current version will never support it.
Comment 2 Philipp A. 2015-04-16 10:07:23 UTC
i don’t see how to activate window tabbing using breeze
Comment 3 Rodrigo Fernandes 2015-04-16 10:11:54 UTC
Thanks for reopening. I've updated the version. This version (5.2.95) uses kdecoration2 but it still does not support window tabs.
Comment 4 Martin Flöser 2015-04-16 11:39:46 UTC
I'm sorry to say, but window tabbing is not yet implemented for kdecoration2 :-(
Comment 5 Philipp A. 2015-04-17 18:21:23 UTC
you said

> the new KDecoration2 deco will support tabs

is this still planned at least?
Comment 6 Martin Flöser 2015-04-18 12:15:21 UTC
yes, sure. But it needs someone to step up to do it (I unfortunately are currently focused on Wayland).
Comment 7 Jürgen Scholz 2015-06-22 14:49:39 UTC
I just stumbled over this bug when I noticed that grouping is not possible with Breeze. I understand the focus being on wayland at the moment. Still I hope for this feature to return. :)

Cheers!
Comment 8 Kai Uwe Broulik 2018-01-04 17:20:50 UTC

*** This bug has been marked as a duplicate of bug 343690 ***
Comment 9 Christoph Feck 2018-01-04 17:41:08 UTC
It's not a duplicate, but a dependency. Implementing tabbing support in libkdecoration2 doesn't magically add tabs to the breeze decoration.
Comment 10 koukasio 2019-10-18 18:05:51 UTC
I am in need of this feature. I have not updated to KDE5 because of it. I really hope someone will implement it, as I don't have the skills to do it myself. I am sure that there will be many users to find peace.
Comment 11 Gauthier 2021-08-31 08:26:31 UTC
(In reply to Martin Flöser from comment #6)
> yes, sure. But it needs someone to step up to do it (I unfortunately are
> currently focused on Wayland).

I guess no one has been stepping up for this? Or is there now any plans to bring it back?
Comment 12 Nate Graham 2021-09-16 19:31:43 UTC
This isn't something it makes sense to have only in the Breeze window decoration theme; people with any window decoration theme should be able to use it, should it be re-implemented. We already have a KWin bug report about that (Bug 343690), so closing this.