Bug 339999 - Copy pictures to the appropriate folder but the link in index.xml is always the root of kphotoalbum
Summary: Copy pictures to the appropriate folder but the link in index.xml is always t...
Status: RESOLVED DUPLICATE of bug 334393
Alias: None
Product: kphotoalbum
Classification: Unclassified
Component: Import/Export (show other bugs)
Version: 4.5
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KPhotoAlbum Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-15 17:24 UTC by Sim
Modified: 2014-12-15 18:51 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sim 2014-10-15 17:24:37 UTC
Export pictures from Kphotoalbum version 4.1.1 to kim file (either chosing option 1 - copy the pictures into the kim file or option 3 - automatically copy pictures next to kim file).

Importing kim into Kphotoalbum version 4.5.
Chose picture path to be subfolder of root of kphotoalbum collection (home/me/root-of-kphotoalbum-collection/2014/new_pictures)
Import done
Checking thumbnails - showing standard thumbnail, because path of the pictures is expected to be in the root instead of the appropriate subfolder.

Reproducible: Always

Steps to Reproduce:
1. Export picture of kphotoalbum 4.1.1 into kim
2. Import kim into kphotoalbum 4.5
3. Chose subfolder of root of kphotoalbum pictures
4. Check if path of picture is right (subfolder)
5. Nope

Actual Results:  
A standard thumbnail is shown, because the path of the picture is wrong

Expected Results:  
Displaying the right thumbnail

I know, that the creation of thumbnails is handled differently in version 4.5 than 4.1.1
But this is not the problem.

Workaround:
Open index.xml in an editor (gedit).
Search for file="DSC and replace those strings with file="2014/new_pictures/DSC
Comment 1 Andreas Schleth 2014-10-19 13:26:13 UTC
This seems to be the same as Bug 334393 from 4.4 https://bugs.kde.org/show_bug.cgi?id=334393

I can confirm the malfunction.   KPA 4.5 compiled from source with openSuSE 13.1.
Comment 2 Johannes Zarl-Zierl 2014-12-15 18:51:15 UTC

*** This bug has been marked as a duplicate of bug 334393 ***