Bug 339963 - KMix fails to reconnect to pulseaudio in some cases
Summary: KMix fails to reconnect to pulseaudio in some cases
Status: RESOLVED DUPLICATE of bug 318986
Alias: None
Product: kmix
Classification: Unclassified
Component: Backend: Pulseaudio (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Colin Guthrie
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-14 17:05 UTC by Stefan Brüns
Modified: 2021-02-12 13:35 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Brüns 2014-10-14 17:05:35 UTC
after a connection loss, kmix call pa_context_connect(..., PA_CONTEXT_NOFAIL, ...)

This call fails e.g. when noautospawn is set or the autospawn failed. As kmix specifies NOFAIL for the connection, libpulse listens on DBUS for a new pa daemon.

KMix should ignore the pa_context_connect return value and keep the state callback.

Reproducible: Always
Comment 1 Andrew Crouthamel 2018-11-12 02:47:58 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 2 Andrew Crouthamel 2018-11-21 04:48:49 UTC
Dear Bug Submitter,

This is a reminder that this bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? This bug will be moved back to REPORTED Status for manual review later, which may take a while. If you are able to, please lend us a hand.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Jonathan Marten 2021-02-12 13:35:35 UTC

*** This bug has been marked as a duplicate of bug 318986 ***