Bug 339866 - Dolphin search displays "Invalid protocol" error.
Summary: Dolphin search displays "Invalid protocol" error.
Status: RESOLVED DOWNSTREAM
Alias: None
Product: dolphin
Classification: Unclassified
Component: search (show other bugs)
Version: 16.12.2
Platform: Debian unstable Linux
: NOR normal with 5 votes (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-11 07:03 UTC by Zane Tu
Modified: 2016-03-31 19:24 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zane Tu 2014-10-11 07:03:01 UTC
Environment: Dolphin 4.14.1 on Debian sid (amd64)

When I try searching in Dolphin, it always displays a red warning bar showing "Invalid protocol" , and no search is ever performed. 

Console output: 
dolphin(7601): couldn't create slave: "Unable to create io-slave:
klauncher said: Unknown protocol 'baloosearch'.
" 

After I installed "ballo", "baloo4" and "baloo-utils", the red warning bar (as well as the console output above) was gone but Dophin still couldn't find anything (status bar showing "0 Folders, 0 Files"), no matter what I input as search keyword. 

Reproducible: Always

Steps to Reproduce:
1. Open Dolphin 
2. Press CTRL+F
3. Input some characters as search keyword

Actual Results:  
A red warning bar showing "Invalid protocol" pops up below the search bar. 

Expected Results:  
Dolphin finds folders/files whose names contain the search keyword
Comment 1 Emmanuel Pescosta 2014-10-13 09:47:40 UTC
It needs some time to index your hard drive.

Can you still reproduce this problem?
If yes we should reassign it to baloo.
Comment 2 Emmanuel Pescosta 2014-10-13 09:57:24 UTC
> the red warning bar (as well as the console output above) was gone but Dophin still couldn't
> find anything

Duplicate of bug https://bugs.kde.org/show_bug.cgi?id=333715 ?
Comment 3 Zane Tu 2014-10-13 20:50:25 UTC
(In reply to Emmanuel Pescosta from comment #1)
> It needs some time to index your hard drive.
> 
> Can you still reproduce this problem?
> If yes we should reassign it to baloo.

Yes. I can reproduce this "invalid protocol" problem by removing "baloo", "baloo4" and "baloo-utils" and restarting dolphin.
Comment 4 Zane Tu 2014-10-13 21:04:12 UTC
(In reply to Emmanuel Pescosta from comment #2)
> > the red warning bar (as well as the console output above) was gone but Dophin still couldn't
> > find anything
> 
> Duplicate of bug https://bugs.kde.org/show_bug.cgi?id=333715 ?

I guess not. I don't enable "Everywhere" when searching. 
Additional notes: 
Dolphin search works again after I reboot the machine (with "baloo", "baloo4" and "baloo-utils" installed, of course).
Comment 5 Emmanuel Pescosta 2014-10-17 12:40:24 UTC
> Dolphin search works again

I'll mark this bug as "resolved - works for me", feel free to reopen it when you can reproduce this problem in future.
Comment 6 Zane Tu 2014-10-18 06:03:10 UTC
(In reply to Emmanuel Pescosta from comment #5)
> > Dolphin search works again
> 
> I'll mark this bug as "resolved - works for me", feel free to reopen it when
> you can reproduce this problem in future.

I guess there is some misunderstanding here. Althouth my issue was resovled, this is certainly a bug that should be fixed, because currently the package "dolphin" does not depend on "baloo4", "baloo" or "baloo-utils". That said, once I remove "baloo4", "baloo" or "baloo-utils", the bug comes back again.
Comment 7 Arjun AK 2014-10-22 16:36:05 UTC
(In reply to Emmanuel Pescosta from comment #1)
> It needs some time to index your hard drive.
> 
> Can you still reproduce this problem?
> If yes we should reassign it to baloo.

Shouldn't search work even without baloo?
Comment 8 Emmanuel Pescosta 2014-10-22 16:50:33 UTC
(In reply to Arjun AK from comment #7)
> (In reply to Emmanuel Pescosta from comment #1)
> > It needs some time to index your hard drive.
> > 
> > Can you still reproduce this problem?
> > If yes we should reassign it to baloo.
> 
> Shouldn't search work even without baloo?

Yes it definitely should work. I absolutely agree with you! ;)

When Dolphin is compiled with Baloo, then it always checks if the Baloo file indexing is enabled and if the search directory is/will be indexed by Baloo. The problem here is the "will be indexed" - maybe we can find a good way to check if we can rely on Baloo (in other words: if Baloo has an almost up to date database) or if we should better use the filenamesearch ioslave instead.

When Dolphin is compiled without Baloo or if the file indexing is disabled, Dolphin always uses the filenamesearch ioslave.

Relevant code is in DolphinSearchBox::urlForSearching()

But this bug is a packaging problem which has to be fixed downstream.

@Zane Tu:
Can you please open a bug report in your distribution's bug tracker. When Dolphin is compiled with Baloo support, the Dolphin package must depend on the Baloo packages. Thanks!
Comment 9 Zane Tu 2014-10-24 17:17:59 UTC
> @Zane Tu:
> Can you please open a bug report in your distribution's bug tracker. 

Done. 
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=766426
Comment 10 Thomas Grauschopf 2015-04-09 16:29:16 UTC
I'd like to add some weird observation:

When I try dolphin file search in my home directory or one of its subfolders, I get the "Invalid protocol" error. Very annoying indeed.

However, file search works fine in directories outside (/, /tmp, /usr/bin). Pretty bizarre.
Comment 11 Jeppe Bundsgaard 2015-05-06 14:55:02 UTC
>I'd like to add some weird observation:

>When I try dolphin file search in my home directory or one of its subfolders, I get the "Invalid protocol" error. Very annoying indeed.

>However, file search works fine in directories outside (/, /tmp, /usr/bin). Pretty bizarre.

I can reproduce this. This points to some kind of configuration file error. Any idea where to look? I am using Kubuntu 15.04, and the problem just appeared a few weeks ago (it worked with 15.04 in the beginning).
Comment 12 Washington Indacochea Delgado 2015-05-10 14:26:02 UTC
I use dolphin on UbuntuStudio, and now I update to 15.04 and the search option not working more. Before on 12.04 and next 14.04 I enable the search option for install and configurate this package:

systemsettings

but now on 15.04 I installing this and not appear the search option

But I find on synaptic a package called:

kde-config-baloo-advanced

now I run on a terminal(You need install baloo):

kcmshell4 kcm_baloofileadv

an see this picture:

http://pix.toile-libre.org/upload/original/1431267661.png

it appears that packages have changed.

I don't know why not working the search option, next I reboot my system but not working
Comment 13 Washington Indacochea Delgado 2015-05-10 16:22:40 UTC
I find a solution for my, I just needed to install:

baloo-utils

working now.

See this post to know what I do:

http://facilitarelsoftwarelibre.blogspot.com/2015/05/activar-la-busqueda-de-dolphin-en.html
Comment 14 Nikola Schnelle 2015-08-20 22:43:30 UTC
I get this error in plasma 5.4 beta, dolphin 15.08 beta when file search is disabled. Kubuntu 15.10.

http://www.dodaj.rs/?b/mE/vvY7cxp/snapshot1.png
Comment 15 Paul Jurczak 2015-10-18 23:59:08 UTC
I have the same problem with Kubuntu 15.04. File search is enabled and baloo-utils are installed.
Comment 16 Roy Leith 2015-10-21 08:57:23 UTC
(In reply to Thomas Grauschopf from comment #10)
> I'd like to add some weird observation:
> 
> When I try dolphin file search in my home directory or one of its
> subfolders, I get the "Invalid protocol" error. Very annoying indeed.
> 
> However, file search works fine in directories outside (/, /tmp, /usr/bin).
> Pretty bizarre.

I trump your observation: My file searches in my home directory (which has a large mounted partition in it) works just fine. Any searches in system folders or mounted media in Dolphin gives the 'invalid protocol' message. This appears to be a distribution configuration issue. 

For information: it's a fresh installation of 15.04 (the install in-place was disastrous due to the broken kwalletmanager) and with all of the baloo packages installed by the installation except the baloo transitional package.

Since limited searches to, for instance, /usr/share are affected, it would not appear to be a baloo issue, but a dolphin issue. I can't help thinking that it could be resolved by hacking a dolphin config file until a professional fix is issued.

I am using the wonderful Catfish program until this is resolved.
Comment 17 Roy Leith 2015-10-21 09:35:52 UTC
Just rechecked:

The Help file says:

'The option from Everywhere with activated Baloo services searches in all indexed folders, without Baloo this option starts the search from the user's Home folder.'

A dolphin search 'from here' in the home folder comes up with 'baloosearch - / - dolphin'.

Changing the search to 'everywhere' does the same, but only the home folder is searched. It looks as though baloo is only indexing the home folder path, whatever options are selected. Dolphin seems incapable of using indexes without baloo. 

Any search outside of the home folder and sub-folders, whether 'from here' or 'everywhere' comes up with the 'invalid protocol' message. The window header reports, for example, 'share - dolphin'.

I cannot tell if it is the indexing which is restricted to the /home/user path or whether dolphin is employing the wrong search protocol regardless of the 'from here/everywhere' switch, or both.
Comment 18 Gregor Mi 2015-10-23 12:54:06 UTC
Reproduced on openSUSE 13.2, Plasma 5.4.2, Dolphin 15.07.90:

Messagebar shows "Invalid protocol".

Console says:

"Trying to convert empty KLocalizedString to QString."
kf5.kio.core: KLocalSocket(0x2634040) Jumbo packet of 110740 bytes
couldn't create slave: "Unable to create io-slave:\nklauncher said: Unknown protocol 'baloosearch'.\n"
Comment 19 Gregor Mi 2015-10-23 12:58:55 UTC
The issues status says "resolved downstream". Could also the upstream message could be improved, for example by saying "Invalid protocol. See console output for details"?
Comment 20 Matthieu Vergne 2015-10-24 15:37:27 UTC
I also have this invalid protocol issue, although I made a fresh install of Kubuntu a few weeks ago.
Comment 21 Roy Leith 2015-10-25 06:09:19 UTC
Good news, everyone! 

Five days after updating to 15.04, I was offered an upgrade to 15.10. That seems to have resolved the problem with Dolphin/baloo search.
Comment 22 Karl 2016-03-31 19:24:05 UTC
This bug should be updated for a fix - 

"Invalid Protocol" is not a useful error string - the error should do a little testing and inform that either baloo is not installed or that indexing is not complete.


Error messages should tell the user something that can help.