Bug 339583 - Show the resulting format in comboboxes
Summary: Show the resulting format in comboboxes
Status: RESOLVED DUPLICATE of bug 394698
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_formats (show other bugs)
Version: 5.0.1
Platform: Kubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2014-10-01 19:34 UTC by Mike C. Fletcher
Modified: 2021-01-06 00:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike C. Fletcher 2014-10-01 19:34:59 UTC
In the settings module for Regional Formats, you display formats as Regions, which means little to the user.  Common use case "I want 24-hour time format" require hunting about until you find a Region that happens to use both your language and a 24-hour format.

While I recognize that the values (locales) being selected are those that are actually set (to configure Qt), the drop-downs should show what the effect would be, for instance, for the Time Sub-format:

English Canada (en_CA) 3:44 PM
United Kingdom - UK English (en_UK) 15:44

would at least make it obvious from the drop-down what you are selecting as a format.

This doesn't address the desires of those who, for instance, speak Albanian yet want a 12-hour clock format, of course.

Reproducible: Always

Steps to Reproduce:
1. Go to Regional Format Page
2. Attempt to Configure an en_CA region with a 24-hour time format


Actual Results:  
Have to find the English section and then use arrow-keys to switch the values while scanning the sample text at the bottom to check the formats.

Expected Results:  
Be able to see at a glance the sub-format being selected.
Comment 1 Nate Graham 2021-01-06 00:04:08 UTC
This makes perfect sense for the common case where you know what format you want to switch to, but you don't necessarily know which locale implements it.
Comment 2 Nate Graham 2021-01-06 00:14:08 UTC

*** This bug has been marked as a duplicate of bug 394698 ***