Bug 339430 - akonadi_davgroupware_resource: Error when uploading item: 100
Summary: akonadi_davgroupware_resource: Error when uploading item: 100
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: DAV Resource (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-26 13:47 UTC by Thomas Roemer
Modified: 2015-02-03 14:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Roemer 2014-09-26 13:47:50 UTC
KDE 4.14.1, OpenSUSE 12.3
Access to my Mailserver (Zimbra 7.2 - IMAP and WebDAV)

The initial raeding of all appointments, after config of the DAV ressource, is fine! No password fail.
Calling of the settings 
A new appointment can't be saved properly. The settings of "Kontact"/Calendar said: No connection to the host: smtp.1und1.de.
But the previously configured server is called: mail1.site (local network - my ghetto.hosting mailserver ;)
There is something wrong, I think.;-D
BTW: It is possible to add a contact without an error.

I think this is the behavior after update to KDE 4.14.1, but not 100% sure, unfortunately...

Reproducible: Always

Steps to Reproduce:
1. DAV ressource delete
2. DAV ressource create - with host, user and password - working as expected
3. write an appointment, fails with the error described above

Actual Results:  
No new appointments are possible from this client - my android google calendar is working fine.
Comment 1 Grégory Oestreicher 2014-09-30 18:40:19 UTC
OK, so if I understand correctly the problem:
- you configure the resource to access Zimbra at host mail1.site
- the resource fetches the calendars and the events successfully
- when you want to write a new event the resource tries to connect to smtp.1und1.de

Is that it?

Could you post the content of the file ~/.kde4/share/config/akonadi_davgroupware_resource_XXrc, where XX is the resource ID? Feel free to replace the hostname you configured with 'mail1.site'.

Also, can you have a look in akonadiconsole (in the 'Browser' tab) the properties of the calendars, especially their remote identifier?

Thanks,
Grégory
Comment 2 Thomas Roemer 2014-11-05 08:01:08 UTC
The problem doesn't exist in this environment:
Repository: openSUSE-12.3-Update
Name: kdebase4-session
Version: 4.10.5-1.100.1

I will check later on a openSUSE 13.1 platform the actual update.
Thanks for your great support in our email communication. But I have not enough time to follow your advise to sniff the communication between imap and akonadi. I have to anonymize the data, as you recommended before.
Feel free to close the report...
thx a lot
Comment 3 Thomas Roemer 2014-12-02 08:29:42 UTC
At KDE 4.14.3 there is still the same behavior.

The plugin resolv the login name and search at my provider try to login with an other hostname as I defined in the settings for the zimbra-server on my intranet.

The plugin try to write my new appointment at smtp.1und1.de because my login name at the zimbra server is hosted there.
Why is the plugin trying to resolv/expand the loginname to use another login-server as I defined it before?!
Comment 4 Thomas Roemer 2015-02-03 14:00:46 UTC
The problem has been solved.

The client ask Zimbra for this "flag": "Hostname of public service"
The Zimbra Server deliver the domain that I have configure: The smtp of my provider.

Zimbra/configuration/@domain settings:
Hostname des öffentlichen Diensts: none
Hostname of public service: none

This setting should work for internal using (intranet).