Bug 338769 - qr/bar code do not show up if url is https copied from google chrome
Summary: qr/bar code do not show up if url is https copied from google chrome
Status: RESOLVED NOT A BUG
Alias: None
Product: klipper
Classification: Unclassified
Component: plasma-widget (show other bugs)
Version: 0.9.7
Platform: Other Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Martin Flöser
URL:
Keywords:
: 333789 341886 372536 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-09-03 02:41 UTC by Paweł Szutkowski
Modified: 2016-11-16 14:18 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paweł Szutkowski 2014-09-03 02:41:26 UTC
If I copy an URL stated with https from google-chrome and then i use "show qr code" option in clipper, i will show empty windows without code. It's funny because when I paste same link somewhere, it'll work fine. Links looks this same in klipper's history

Reproducible: Always

Steps to Reproduce:
1.Copy/select URL of https website from chrome
2.Use Show Qr code option from klipper
3.Try this same after copying it from somewhere else or after editing it in klipper but don't changing anything
Comment 1 Martin Flöser 2014-09-03 07:39:47 UTC
works fine for me, though when I copy something from Chrome it ends up with 
two entries: one empty and one with the content. Ensure that the one is 
content is the selected item.
Comment 2 Paweł Szutkowski 2014-09-03 14:53:32 UTC
I'm using:
google-chrome 36.0.1985.143
klipper 0.9.7 ( packet manager say it's 4.11.11)
linux-3.15.0-sabayon
kde 4.13.3 with Polish layout

It happens only after I click "Enter key" to load a website. If I just type something in URL box, I can copy it and klipper will make nice working QR, but if the website is loaded, then klipper will show empty window.
It's weird that it's happening
Also, i upgraded klipper from Sabayon (Gentoo based distro) from klipper-4.11.10  to klipper-4.11.11 and now klipper shows empty window always when I copy URL with http OR https from URL box when its loaded.

PS: I I've 'non-working' URL in the clipboard and want to modife clipbord content inside of Klipper, i shows empty text box, but when I paste this URL to kwrite and copy it, both, QR code generation and clipboard editing works fine. Maybe there is some \0 character or something at the start of URL when it's whole copied...

PS 2: It's easy to get around, i just don'y copy whole URL addres, if I won't copy 'https://' part, it will work fine.
Comment 3 Martin Flöser 2014-09-03 15:17:39 UTC
I'm relatively sure that this is a Chrome issue. They recently changed the toolkit from GTK to a custom one. That means the had to write the X11-clipboard interaction code themselves and that probably is buggy.
Comment 4 Paweł Szutkowski 2014-09-03 16:08:15 UTC
Yup, I thinks so too. Thanks for Your help and patient. I'm marking it as a resolved.
Comment 5 Martin Flöser 2014-10-27 07:18:08 UTC
*** Bug 333789 has been marked as a duplicate of this bug. ***
Comment 6 Martin Flöser 2014-12-15 08:29:53 UTC
*** Bug 341886 has been marked as a duplicate of this bug. ***
Comment 7 Tomáš Chvátal 2015-07-05 08:31:14 UTC
Upstream report:
http://code.google.com/p/chromium/issues/detail?id=442253

Overall if the chromium does not fix it maybe klipper side could be fixed?
If I kill klipper from plasma5 and use KDE4 variant, or just the X copy mechanisms it works fine, so people will in the end be rather blaming klipper because only it can't handle the thing.
Comment 8 Sudhir Khanger 2015-07-05 10:53:46 UTC
Can we not have something that ignores empty strings like one of the two strings sent to Klipper by Chrome, if that is the case?

When I paste things copied from Chrome to KWrite using middle click, it doesn't paste two separate lines.
Comment 9 Martin Flöser 2016-11-16 14:18:54 UTC
*** Bug 372536 has been marked as a duplicate of this bug. ***