Bug 338692 - crash on close
Summary: crash on close
Status: RESOLVED DUPLICATE of bug 336417
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-08-31 11:16 UTC by Christoph Thielecke
Modified: 2014-09-05 13:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Thielecke 2014-08-31 11:16:54 UTC
Application: akregator (4.14)
KDE Platform Version: 4.14.0
Qt Version: 4.8.6
Operating System: Linux 3.13.0-35-generic x86_64
Distribution: Ubuntu 14.04.1 LTS

-- Information about the crash:
I ran akregator for a while and open some articles using the webkit part. Then I close the application and it crashed.

-- Backtrace:
Application: Akregator (akregator), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9ce3324800 (LWP 7979))]

Thread 4 (Thread 0x7f9cbcd3d700 (LWP 7980)):
#0  update_get_addr (ti=0x7f9ce1abba50) at dl-tls.c:758
#1  0x00007f9ce1653044 in get_thread_data () at thread/qthread_unix.cpp:188
#2  QThreadData::current () at thread/qthread_unix.cpp:219
#3  0x00007f9ce1783af5 in postEventSourcePrepare (s=0x7f9cb8001350, timeout=0x7f9cbcd3cbe4) at kernel/qeventdispatcher_glib.cpp:263
#4  0x00007f9cda9d668d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f9cda9d6f03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f9cda9d70ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f9ce17837be in QEventDispatcherGlib::processEvents (this=0x7f9cb80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#8  0x00007f9ce17550af in QEventLoop::processEvents (this=this@entry=0x7f9cbcd3cda0, flags=...) at kernel/qeventloop.cpp:149
#9  0x00007f9ce17553a5 in QEventLoop::exec (this=this@entry=0x7f9cbcd3cda0, flags=...) at kernel/qeventloop.cpp:204
#10 0x00007f9ce1651c5f in QThread::exec (this=this@entry=0x1030f30) at thread/qthread.cpp:537
#11 0x00007f9ce1736823 in QInotifyFileSystemWatcherEngine::run (this=0x1030f30) at io/qfilesystemwatcher_inotify.cpp:265
#12 0x00007f9ce165432f in QThreadPrivate::start (arg=0x1030f30) at thread/qthread_unix.cpp:349
#13 0x00007f9cdb0a7182 in start_thread (arg=0x7f9cbcd3d700) at pthread_create.c:312
#14 0x00007f9cdfec5fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f9cb6ea3700 (LWP 8074)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f9cc589a81d in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f9cc589a859 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f9cdb0a7182 in start_thread (arg=0x7f9cb6ea3700) at pthread_create.c:312
#4  0x00007f9cdfec5fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f9cb4ada700 (LWP 8076)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f9cc55db20d in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f9cc58c9fd6 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f9cdb0a7182 in start_thread (arg=0x7f9cb4ada700) at pthread_create.c:312
#4  0x00007f9cdfec5fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f9ce3324800 (LWP 7979)):
[KCrash Handler]
#6  0x00007f9ce176a607 in isSignalConnected (signal_index=7, this=0x9) at kernel/qobject_p.h:237
#7  QMetaObject::activate (sender=0xf40800, m=m@entry=0x7f9ce2a33760 <Akregator::Frame::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff95c89160) at kernel/qobject.cpp:3444
#8  0x00007f9ce281a782 in Akregator::Frame::signalCompleted (this=<optimized out>, _t1=0xf40800) at moc_frame.cpp:200
#9  0x00007f9ce28115b8 in Akregator::Frame::slotSetState (this=<optimized out>, state=state@entry=Akregator::Frame::Completed) at ../../../akregator/src/frame.cpp:94
#10 0x00007f9cc7d471f7 in Akregator::MainWidget::slotFetchingStopped (this=0xe3d150) at ../../../akregator/src/mainwidget.cpp:808
#11 0x00007f9ce176a87a in QMetaObject::activate (sender=sender@entry=0xd1f3a0, m=m@entry=0x7f9ce2a337e0 <Akregator::FetchQueue::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#12 0x00007f9ce281a363 in Akregator::FetchQueue::signalStopped (this=this@entry=0xd1f3a0) at moc_fetchqueue.cpp:126
#13 0x00007f9ce2811039 in Akregator::FetchQueue::slotAbort (this=this@entry=0xd1f3a0) at ../../../akregator/src/fetchqueue.cpp:68
#14 0x00007f9ce28110aa in Akregator::FetchQueue::~FetchQueue (this=0xd1f3a0, __in_chrg=<optimized out>) at ../../../akregator/src/fetchqueue.cpp:50
#15 0x00007f9ce2811119 in Akregator::FetchQueue::~FetchQueue (this=0xd1f3a0, __in_chrg=<optimized out>) at ../../../akregator/src/fetchqueue.cpp:53
#16 0x00007f9ce28100d9 in Akregator::Kernel::~Kernel (this=0x7f9ce2a34c58 <Akregator::Kernel::self()::self>, __in_chrg=<optimized out>) at ../../../akregator/src/kernel.cpp:66
#17 0x00007f9cdfe07149 in __run_exit_handlers (status=0, listp=0x7f9ce018a6c8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#18 0x00007f9cdfe07195 in __GI_exit (status=<optimized out>) at exit.c:104
#19 0x00007f9cdfdececc in __libc_start_main (main=0x407740 <main(int, char**)>, argc=5, argv=0x7fff95c89488, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff95c89478) at libc-start.c:321
#20 0x0000000000407edb in _start ()

Possible duplicates by query: bug 283920.

Reported using DrKonqi
Comment 1 Christoph Feck 2014-08-31 12:53:34 UTC
Looks like a global QObject that references already deleted stuff. Not good.
Comment 2 Alexandre Detiste 2014-08-31 14:47:31 UTC
Hi,

I have got the same on Debian unstable: akregator allways (and only) crash at shutdown

Application: akregator (4.14)
KDE Platform Version: 4.14.0
Qt Version: 4.8.6+git64-g5dc8b2b+dfsg-1

Application: Akregator (akregator), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#5  0x00007fe5469529ad in isSignalConnected (signal_index=7, this=0x5) at kernel/qobject_p.h:237
#6  QMetaObject::activate (sender=0x138b240, m=<optimized out>, local_signal_index=4, argv=0x7fff52ee6c10) at kernel/qobject.cpp:3472
#7  0x00007fe54877f2a2 in Akregator::Frame::signalCompleted(Akregator::Frame*) () from /usr/lib/libakregatorprivate.so.4
#8  0x00007fe548774a8b in Akregator::Frame::slotSetState(Akregator::Frame::State) () from /usr/lib/libakregatorprivate.so.4
#9  0x00007fe52ecfa407 in Akregator::MainWidget::slotFetchingStopped() () from /usr/lib/kde4/akregatorpart.so
#10 0x00007fe546952c5c in QMetaObject::activate (sender=0x1299930, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3567
#11 0x00007fe5487746b9 in Akregator::FetchQueue::slotAbort() () from /usr/lib/libakregatorprivate.so.4
#12 0x00007fe54877473a in Akregator::FetchQueue::~FetchQueue() () from /usr/lib/libakregatorprivate.so.4
#13 0x00007fe5487747a9 in Akregator::FetchQueue::~FetchQueue() () from /usr/lib/libakregatorprivate.so.4
#14 0x00007fe5487735d9 in Akregator::Kernel::~Kernel() () from /usr/lib/libakregatorprivate.so.4
#15 0x00007fe545c97ec9 in __run_exit_handlers (status=0, listp=0x7fe5460035a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#16 0x00007fe545c97f15 in __GI_exit (status=<optimized out>) at exit.c:104
#17 0x00007fe545c81b4c in __libc_start_main (main=0x407230, argc=3, argv=0x7fff52ee6f58, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff52ee6f48) at libc-start.c:321
#18 0x00000000004079ed in _start ()
Comment 3 Vojtěch Zeisek 2014-09-04 11:54:43 UTC
Application: akregator (4.14)
KDE Platform Version: 4.14.0
Qt Version: 4.8.5
Operating System: Linux 3.11.10-21-desktop x86_64
Distribution: "openSUSE 13.1 (Bottle) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Akregator crashes every time on exit (Ctrl + Q). It started with upgrade to 4.14.

The crash can be reproduced every time.

-- Backtrace:
Application: Akregator (akregator), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fdb742da880 (LWP 1537))]

Thread 6 (Thread 0x7fdb4fef0700 (LWP 6730)):
#0  0x00007fdb6c0270af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fdb57c4ef76 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007fdb57c4efa9 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007fdb6c0230db in start_thread () from /lib64/libpthread.so.0
#4  0x00007fdb70e4890d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fdb4d7ac700 (LWP 6737)):
#0  0x00007fdb6c0270af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fdb579c12cd in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007fdb57c76ad6 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007fdb6c0230db in start_thread () from /lib64/libpthread.so.0
#4  0x00007fdb70e4890d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fdae3ac8700 (LWP 6843)):
#0  0x00007fdb6c0270af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fdae3ae8a4b in ?? () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007fdb6c0230db in start_thread () from /lib64/libpthread.so.0
#3  0x00007fdb70e4890d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fdae32c7700 (LWP 6844)):
#0  0x00007fdb6c0270af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fdae3ae8a4b in ?? () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007fdb6c0230db in start_thread () from /lib64/libpthread.so.0
#3  0x00007fdb70e4890d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fdae2ac6700 (LWP 6845)):
#0  0x00007fdb6c0270af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fdae3ae8a4b in ?? () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007fdb6c0230db in start_thread () from /lib64/libpthread.so.0
#3  0x00007fdb70e4890d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fdb742da880 (LWP 1537)):
[KCrash Handler]
#5  0x00007fdb726ffaf7 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#6  0x00007fdb737ceba2 in Akregator::Frame::signalCompleted (this=<optimized out>, _t1=0x25ffc10) at /usr/src/debug/kdepim-4.14.0/build/akregator/src/moc_frame.cpp:200
#7  0x00007fdb737c59d8 in Akregator::Frame::slotSetState (this=<optimized out>, state=state@entry=Akregator::Frame::Completed) at /usr/src/debug/kdepim-4.14.0/akregator/src/frame.cpp:94
#8  0x00007fdb5a36d0c7 in Akregator::MainWidget::slotFetchingStopped (this=0x20f8960) at /usr/src/debug/kdepim-4.14.0/akregator/src/mainwidget.cpp:808
#9  0x00007fdb726ffd68 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#10 0x00007fdb737ce783 in Akregator::FetchQueue::signalStopped (this=<optimized out>) at /usr/src/debug/kdepim-4.14.0/build/akregator/src/moc_fetchqueue.cpp:126
#11 0x00007fdb737c5459 in Akregator::FetchQueue::slotAbort (this=this@entry=0x208ca00) at /usr/src/debug/kdepim-4.14.0/akregator/src/fetchqueue.cpp:68
#12 0x00007fdb737c54ca in Akregator::FetchQueue::~FetchQueue (this=0x208ca00, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.14.0/akregator/src/fetchqueue.cpp:50
#13 0x00007fdb737c5539 in Akregator::FetchQueue::~FetchQueue (this=0x208ca00, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.14.0/akregator/src/fetchqueue.cpp:53
#14 0x00007fdb737c4519 in Akregator::Kernel::~Kernel (this=0x7fdb739e8c58 <Akregator::Kernel::self()::self>, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.14.0/akregator/src/kernel.cpp:66
#15 0x00007fdb70d993d9 in __run_exit_handlers () from /lib64/libc.so.6
#16 0x00007fdb70d99425 in exit () from /lib64/libc.so.6
#17 0x00007fdb70d82bec in __libc_start_main () from /lib64/libc.so.6
#18 0x000000000040872d in _start () at ../sysdeps/x86_64/start.S:122

Possible duplicates by query: bug 338692, bug 336417.

Nahlásit https://bugs.kde.org/


PS: I received error 410 during last step when using Drkonqui (I logged into Bugzilla on the beginning), so I copy and paste the report here.
Comment 4 Christoph Feck 2014-09-05 13:36:37 UTC

*** This bug has been marked as a duplicate of bug 336417 ***