Bug 338599 - A combobox is not the right control for selecting locale options
Summary: A combobox is not the right control for selecting locale options
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_formats (show other bugs)
Version: 5.0.1
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: John Layt
URL:
Keywords: usability
: 336108 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-27 16:55 UTC by Thomas Pfeiffer
Modified: 2021-10-06 07:45 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Pfeiffer 2014-08-27 16:55:34 UTC
Currently, the locales are selected using select boxes. This is not the right control for selecting an item among such a huge list because it's cumbersome to navigate. The HIG ( https://techbase.kde.org/Projects/Usability/HIG/DropDown ) states "For a single selection out of a large number of items (n>20), use a list view" (with a filter).
Comment 1 Sebastian Kügler 2014-08-28 10:18:01 UTC
We have 6 comboboxes which are all too big. This needs a serious design concept, we can't just replace them all with lists + filters, because people don't have 6000px height displays.
Comment 2 Thomas Pfeiffer 2014-08-28 16:51:38 UTC
Agreed, it won't be a simple "replace selectboxes with list boxes".
Maybe the widget you created for timezone selection in Plasma Active (or a slightly modified version thereof) would be useful here?
The HIG I wrote for it precisely matches our situation:
"The Selection Dialog is used when users have to select one element out of a number of items that would not fit into the drop-down of a ComboBox and there is not enough space to show them in a ListView"
Comment 3 David Edmundson 2014-11-05 18:27:24 UTC
*** Bug 336108 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2021-01-06 00:14:45 UTC
This would be fixed automatically by fixing Bug 394698.
Comment 5 Nate Graham 2021-10-05 17:21:11 UTC
Git commit 25485ac8d35ec25c1cf1475516016d6f8b93a9f2 by Nate Graham, on behalf of Han Young.
Committed on 05/10/2021 at 17:20.
Pushed by ngraham into branch 'master'.

port formats to qml
Related: bug 279658, bug 362865, bug 389529, bug 410606, bug 422467, bug 426313

FIXED-IN: 5.24

M  +16   -7    kcms/formats/CMakeLists.txt
D  +0    -113  kcms/formats/formats.desktop
M  +46   -326  kcms/formats/kcmformats.cpp
M  +15   -33   kcms/formats/kcmformats.h
D  +0    -385  kcms/formats/kcmformatswidget.ui

https://invent.kde.org/plasma/plasma-workspace/commit/25485ac8d35ec25c1cf1475516016d6f8b93a9f2
Comment 6 Ben Cooksley 2021-10-06 07:45:26 UTC
Git commit 32a565bae7e2f7243d2715df56b8617dc8dd3612 by Ben Cooksley, on behalf of Han Young.
Committed on 06/10/2021 at 07:41.
Pushed by bcooksley into branch 'master'.

kcms/formats: port to QML
Related: bug 279658, bug 362865, bug 389529, bug 410606, bug 422467, bug 426313

FIXED-IN: 5.24

M  +16   -7    kcms/formats/CMakeLists.txt
A  +66   -0    kcms/formats/exampleutility.cpp     [License: GPL(v2.0+)]
D  +0    -113  kcms/formats/formats.desktop
A  +61   -0    kcms/formats/formatssettings.kcfg
A  +6    -0    kcms/formats/formatssettings.kcfgc
M  +46   -326  kcms/formats/kcmformats.cpp
M  +15   -33   kcms/formats/kcmformats.h
D  +0    -385  kcms/formats/kcmformatswidget.ui
A  +176  -0    kcms/formats/localelistmodel.cpp     [License: GPL (v2+)]
A  +58   -0    kcms/formats/localelistmodel.h     [License: GPL (v2+)]
A  +140  -0    kcms/formats/optionsmodel.cpp     [License: GPL(v2.0+)]
A  +32   -0    kcms/formats/optionsmodel.h     [License: GPL(v2.0+)]
A  +126  -0    kcms/formats/package/contents/ui/main.qml     [License: LGPL(v3.0+)]
A  +23   -0    kcms/formats/package/metadata.desktop

https://invent.kde.org/plasma/plasma-workspace/commit/32a565bae7e2f7243d2715df56b8617dc8dd3612