Bug 338567 - Since upgrade to 4.14.0 empty imap folders
Summary: Since upgrade to 4.14.0 empty imap folders
Status: RESOLVED DUPLICATE of bug 338186
Alias: None
Product: kmail2
Classification: Applications
Component: folders (show other bugs)
Version: 4.14.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-26 09:34 UTC by Thomas Stein
Modified: 2014-08-26 14:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Stein 2014-08-26 09:34:53 UTC
Hello.

After upgrading to 4.14.0 my imap folders are empty. When i use another Imapclient all is fine. I'm using Courier-Imap 4.15. Akonadiserver is 1.13.0. Suspiciuos warnings from akonadi log:

akonadi_imap_resource_1(9375) BatchFetcher::onUidSearchDone: Search job failed:  "Search failed, server replied: A000198 NO Error in IMAP command received by server. " 
akonadi_imap_resource_1(9375) RetrieveItemsTask::onRetrievalDone: "" 
akonadi_imap_resource_1(9375) RetrieveItemsTask::onFinalSelectDone: "Select failed, server replied: A000199 NO Mailbox does not exist, or must be subscribed to. " 
akonadi_imap_resource_1(9375) BatchFetcher::onUidSearchDone: Search job failed:  "Search failed, server replied: A000201 NO Error in IMAP command received by server. " 
akonadi_imap_resource_1(9375) RetrieveItemsTask::onRetrievalDone: "" 
akonadi_imap_resource_1(9375) BatchFetcher::onUidSearchDone: Search job failed:  "Search failed, server replied: A000203 NO Error in IMAP command received by server. " 
akonadi_imap_resource_1(9375) RetrieveItemsTask::onRetrievalDone: "" 
akonadi_imap_resource_1(9375) BatchFetcher::onUidSearchDone: Search job failed:  "Search failed, server replied: A000205 NO Error in IMAP command received by server. " 
akonadi_imap_resource_1(9375) RetrieveItemsTask::onRetrievalDone: "" 
akonadi_imap_resource_1(9375) BatchFetcher::onUidSearchDone: Search job failed:  "Search failed, server replied: A000207 NO Error in IMAP command received by server. " 
akonadi_imap_resource_1(9375) RetrieveItemsTask::onRetrievalDone: "" 
akonadi_imap_resource_1(9375) BatchFetcher::onUidSearchDone: Search job failed:  "Search failed, server replied: A000209 NO Error in IMAP command received by server. " 
akonadi_imap_resource_1(9375) RetrieveItemsTask::onRetrievalDone: "" 
akonadi_imap_resource_1(9375) BatchFetcher::onUidSearchDone: Search job failed:  "Search failed, server replied: A000211 NO Error in IMAP command received by server. " 
akonadi_imap_resource_1(9375) RetrieveItemsTask::onRetrievalDone: "" 
akonadi_imap_resource_1(9375) RetrieveItemsTask::onFinalSelectDone: "Select failed, server replied: A000212 NO Mailbox does not exist, or must be subscribed to. " 
akonadi_imap_resource_1(9375) RetrieveCollectionMetadataTask::onGetAclDone: GetACL failed:  "GetAcl failed, server replied: A000234 NO Mailbox does not exist, or must be subscribed to. " 
akonadi_imap_resource_1(9375) RetrieveCollectionMetadataTask::onRightsReceived: MyRights failed:  "MyRights failed, server replied: A000235 NO Mailbox does not exist, or must be subscribed to. " 
akonadi_imap_resource_1(9375) RetrieveCollectionMetadataTask::onGetAclDone: GetACL failed:  "GetAcl failed, server replied: A000240 NO Mailbox does not exist, or must be subscribed to. " 
akonadi_imap_resource_1(9375) RetrieveCollectionMetadataTask::onRightsReceived: MyRights failed:  "MyRights failed, server replied: A000241 NO Mailbox does not exist, or must be subscribed to. " 
akonadi_imap_resource_1(9375) RetrieveCollectionMetadataTask::onGetAclDone: GetACL failed:  "GetAcl failed, server replied: A000261 NO Mailbox does not exist, or must be subscribed to. " 
akonadi_imap_resource_1(9375) RetrieveCollectionMetadataTask::onRightsReceived: MyRights failed:  "MyRights failed, server replied: A000262 NO Mailbox does not exist, or must be subscribed to. " 

No errors is .xsession-errors. Also it works with dovecot so it must be a regression of some kind. Thanks for looking into it.

best regards
t.
Comment 1 Christoph Feck 2014-08-26 14:06:40 UTC

*** This bug has been marked as a duplicate of bug 338186 ***