Bug 338557 - IMAP resource doesn't fetch mail on Courier servers
Summary: IMAP resource doesn't fetch mail on Courier servers
Status: RESOLVED DUPLICATE of bug 338186
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: GIT (master)
Platform: Kubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-25 20:24 UTC by Thomas Tanghus
Modified: 2014-08-25 20:50 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Tanghus 2014-08-25 20:24:32 UTC
I updated Saturday 23/8-2014 from the Kubuntu PPA on 14.04, and initially thought it was just a quiet weekend ;)
After checking with my webmail (RoundCube) I could see that I had received several mails, that KMail didn't pick up.
I use a hosted mail service running Courier IMAP, and I have confirmed the same issue with another user also using Courier IMAP.

I'm not very keen on trying to delete/create a new resource, as I have dozens 
of filters and dozens of folders each with different setups, so it would take 
me hours to recreate the setup.

How can I debug the cause of this so I can provide proper info?
Comment 1 Thomas Tanghus 2014-08-25 20:27:02 UTC
I've marked this as git master because 4.14 wasn't available in the list.
Comment 2 didi.debian 2014-08-25 20:28:15 UTC
I have the same problem as reported by Thomas, but I'm running Debian Sid, with kontact 4.14
Comment 3 didi.debian 2014-08-25 20:32:03 UTC
The mail accounts which stopped working for me seem to use Courier as well.
Just send a mail to my gmail account (from yahoo) and that does work.
Comment 4 Thomas Tanghus 2014-08-25 20:38:47 UTC
The report from the server when telnetting to it is: "* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2011 Double Precision, Inc.  See COPYING for distribution information.
Connection closed by foreign host"
Comment 5 Christoph Feck 2014-08-25 20:50:40 UTC

*** This bug has been marked as a duplicate of bug 338186 ***