Bug 338552 - Caldav (owncloud) synchronization hangs when modifying a contact with picture
Summary: Caldav (owncloud) synchronization hangs when modifying a contact with picture
Status: RESOLVED NOT A BUG
Alias: None
Product: kaddressbook
Classification: Applications
Component: general (show other bugs)
Version: 4.13.2
Platform: OpenSUSE Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-25 16:18 UTC by Fabian
Modified: 2014-08-26 09:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian 2014-08-25 16:18:07 UTC
I use my own owncloud server (version 7.0.1) to synchronize my events and contacts. Some of my contacts contain a picture. I've added them using my android devices as well as kaddressbook some time ago.
But if I now open one of these contacts in kaddressbook and press ok, my akonadi resource goes offline (silently in the background!) and refuses all further synchronization. The error messages in the terminal looks like this:

akonadi_davgroupware_resource_25(29895): Error when uploading item: 512 "Bei der Abfrage ist ein Problem aufgetreten. Der Eintrag wurde auf dem Server nicht verändert
Bei der Aktion „https://user@server/remote.php/carddav/addressbooks/user/contacts/l17MGyE8PG.vcf hochladen“ ist der unerwartete Fehler 412 aufgetreten. (412)." 

I've found no other solution than delete and re-add the akonadi resource. All my contacts including their pictures are downloaded properly. But if I modify a contact with picture the procedure starts again. 
This bug makes kaddressbook unusable!
Comment 1 Fabian 2014-08-26 09:05:56 UTC
I found out that this problem is a result of this owncloud issue:
https://github.com/owncloud/contacts/issues/585