Bug 338531 - Unable to migrate notes, "Failed to create resource: Agent instance creation timed out."
Summary: Unable to migrate notes, "Failed to create resource: Agent instance creation ...
Status: RESOLVED NOT A BUG
Alias: None
Product: knotes
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-24 19:02 UTC by Raman Gupta
Modified: 2014-08-24 19:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raman Gupta 2014-08-24 19:02:30 UTC
I am unable to migrate my old knotes into Knotes KDE version 4.13.3. I have reviewed and tried all the debugging information in #333640, and it still doesn't work. The migration log is:

[Sun Aug 24 14:53:40 2014] Info   : Starting migration...
[Sun Aug 24 14:53:40 2014] Info   : Beginning KNotes migration...
[Sun Aug 24 14:53:40 2014] Info   : Creating instance of type akonadi_akonotes_resource
[Sun Aug 24 14:53:50 2014] ERROR  : Migration failed: Failed to create resource: Agent instance creation timed out.
[Sun Aug 24 14:53:50 2014] Info   : KNotes migration finished
[Sun Aug 24 14:53:50 2014] Info   : Migration finished.

The old kresources does exist and points to a valid notes.ics:

cat .kde/share/config/kresources/notes/stdrc 
[General]
ResourceKeys=4AAtTLzChG
Standard=4AAtTLzChG

[Resource_4AAtTLzChG]
NotesURL[$e]=file://$HOME/.kde/share/apps/knotes/notes.ics
ResourceIdentifier=4AAtTLzChG
ResourceIsActive=true
ResourceIsReadOnly=false
ResourceName=Notes
ResourceType=file

# ls -l $HOME/.kde/share/apps/knotes/notes.ics
-rw-rw-r--. 1 raman raman 2918 Mar 13 23:50 /home/raman/.kde/share/apps/knotes/notes.ics

I have tried "akonadictl fsck" and "akonadictl restart". Here is the output of "akonadictl status":

# akonadictl status
Akonadi Control: running
Akonadi Server: running
search paths:  ("/home/raman/.kde/lib64/kde4/plugins/", "/usr/lib64/kde4/plugins/", "/usr/lib64/qt4/plugins", "/usr/lib64/kde4/plugins", "/usr/bin", "/home/raman/.kde/lib64/kde4/", "/usr/lib64/kde4/") 
Akonadi Server Search Support: available (Remote Search, Akonadi Baloo Search Plugin)
Available Agent Types: akonadi_akonotes_resource, akonadi_archivemail_agent, akonadi_baloo_indexer, akonadi_birthdays_resource, akonadi_contacts_resource, akonadi_davgroupware_resource, akonadi_facebook_resource, akonadi_folderarchive_agent, akonadi_googlecalendar_resource, akonadi_googlecontacts_resource, akonadi_ical_resource, akonadi_icaldir_resource, akonadi_imap_resource, akonadi_invitations_agent, akonadi_kabc_resource, akonadi_kalarm_dir_resource, akonadi_kalarm_resource, akonadi_kcal_resource, akonadi_kdeaccounts_resource, akonadi_kolabproxy_resource, akonadi_localbookmarks_resource, akonadi_maildir_resource, akonadi_maildispatcher_agent, akonadi_mailfilter_agent, akonadi_mailtransport_dummy_resource, akonadi_mbox_resource, akonadi_migration_agent, akonadi_mixedmaildir_resource, akonadi_nepomuk_feeder, akonadi_newmailnotifier_agent, akonadi_nntp_resource, akonadi_notes_agent, akonadi_notes_resource, akonadi_openxchange_resource, akonadi_pop3_resource, akonadi_sendlater_agent, akonadi_vcard_resource, akonadi_vcarddir_resource

I have erased all the akonadi_akonotes_resource_* using akonadiconsole and tried again, and still get the same error every time. I have no idea what the problem is.
Comment 1 Raman Gupta 2014-08-24 19:26:32 UTC
Resetting akonadi using the instructions here solved the problem:

http://docs.kde.org/stable/en/kdepim/kmail/clean-start-after-a-failed-migration.html